aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/libgcrypt/libgcrypt-1.2.2/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'linden/indra/libgcrypt/libgcrypt-1.2.2/Makefile.in')
-rwxr-xr-xlinden/indra/libgcrypt/libgcrypt-1.2.2/Makefile.in675
1 files changed, 675 insertions, 0 deletions
diff --git a/linden/indra/libgcrypt/libgcrypt-1.2.2/Makefile.in b/linden/indra/libgcrypt/libgcrypt-1.2.2/Makefile.in
new file mode 100755
index 0000000..05b67d2
--- /dev/null
+++ b/linden/indra/libgcrypt/libgcrypt-1.2.2/Makefile.in
@@ -0,0 +1,675 @@
1# Makefile.in generated by automake 1.9.4 from Makefile.am.
2# @configure_input@
3
4# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
5# 2003, 2004 Free Software Foundation, Inc.
6# This Makefile.in is free software; the Free Software Foundation
7# gives unlimited permission to copy and/or distribute it,
8# with or without modifications, as long as this notice is preserved.
9
10# This program is distributed in the hope that it will be useful,
11# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
12# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
13# PARTICULAR PURPOSE.
14
15@SET_MAKE@
16
17# Copyright (C) 1992, 1999, 2000, 2002 Free Software Foundation, Inc.
18#
19# This file is part of Libgcrypt.
20#
21# Libgcrypt is free software; you can redistribute it and/or modify
22# it under the terms of the GNU Lesser General Public License as
23# published by the Free Software Foundation; either version 2.1 of
24# the License, or (at your option) any later version.
25#
26# Libgcrypt is distributed in the hope that it will be useful,
27# but WITHOUT ANY WARRANTY; without even the implied warranty of
28# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
29# GNU Lesser General Public License for more details.
30#
31# You should have received a copy of the GNU Lesser General Public
32# License along with this program; if not, write to the Free Software
33# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
34srcdir = @srcdir@
35top_srcdir = @top_srcdir@
36VPATH = @srcdir@
37pkgdatadir = $(datadir)/@PACKAGE@
38pkglibdir = $(libdir)/@PACKAGE@
39pkgincludedir = $(includedir)/@PACKAGE@
40top_builddir = .
41am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
42INSTALL = @INSTALL@
43install_sh_DATA = $(install_sh) -c -m 644
44install_sh_PROGRAM = $(install_sh) -c
45install_sh_SCRIPT = $(install_sh) -c
46INSTALL_HEADER = $(INSTALL_DATA)
47transform = $(program_transform_name)
48NORMAL_INSTALL = :
49PRE_INSTALL = :
50POST_INSTALL = :
51NORMAL_UNINSTALL = :
52PRE_UNINSTALL = :
53POST_UNINSTALL = :
54build_triplet = @build@
55host_triplet = @host@
56target_triplet = @target@
57DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
58 $(srcdir)/Makefile.in $(srcdir)/config.h.in \
59 $(top_srcdir)/configure AUTHORS COPYING COPYING.LIB ChangeLog \
60 INSTALL NEWS THANKS TODO compile config.guess config.sub \
61 depcomp install-sh ltmain.sh missing mkinstalldirs
62subdir = .
63ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
64am__aclocal_m4_deps = $(top_srcdir)/m4/libtool.m4 \
65 $(top_srcdir)/acinclude.m4 $(top_srcdir)/configure.ac
66am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
67 $(ACLOCAL_M4)
68am__CONFIG_DISTCLEAN_FILES = config.status config.cache config.log \
69 configure.lineno configure.status.lineno
70mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
71CONFIG_HEADER = config.h
72CONFIG_CLEAN_FILES =
73SOURCES =
74DIST_SOURCES =
75RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
76 html-recursive info-recursive install-data-recursive \
77 install-exec-recursive install-info-recursive \
78 install-recursive installcheck-recursive installdirs-recursive \
79 pdf-recursive ps-recursive uninstall-info-recursive \
80 uninstall-recursive
81ETAGS = etags
82CTAGS = ctags
83DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
84distdir = $(PACKAGE)-$(VERSION)
85top_distdir = $(distdir)
86am__remove_distdir = \
87 { test ! -d $(distdir) \
88 || { find $(distdir) -type d ! -perm -200 -exec chmod u+w {} ';' \
89 && rm -fr $(distdir); }; }
90DIST_ARCHIVES = $(distdir).tar.gz $(distdir).tar.bz2
91GZIP_ENV = --best
92distuninstallcheck_listfiles = find . -type f -print
93distcleancheck_listfiles = find . -type f -print
94ACLOCAL = @ACLOCAL@
95AMDEP_FALSE = @AMDEP_FALSE@
96AMDEP_TRUE = @AMDEP_TRUE@
97AMTAR = @AMTAR@
98AR = @AR@
99AUTOCONF = @AUTOCONF@
100AUTOHEADER = @AUTOHEADER@
101AUTOMAKE = @AUTOMAKE@
102AWK = @AWK@
103CC = @CC@
104CCAS = @CCAS@
105CCASFLAGS = @CCASFLAGS@
106CCDEPMODE = @CCDEPMODE@
107CFLAGS = @CFLAGS@
108CPP = @CPP@
109CPPFLAGS = @CPPFLAGS@
110CROSS_COMPILING_FALSE = @CROSS_COMPILING_FALSE@
111CROSS_COMPILING_TRUE = @CROSS_COMPILING_TRUE@
112CXX = @CXX@
113CXXCPP = @CXXCPP@
114CXXDEPMODE = @CXXDEPMODE@
115CXXFLAGS = @CXXFLAGS@
116CYGPATH_W = @CYGPATH_W@
117DEFS = @DEFS@
118DEPDIR = @DEPDIR@
119ECHO = @ECHO@
120ECHO_C = @ECHO_C@
121ECHO_N = @ECHO_N@
122ECHO_T = @ECHO_T@
123EGREP = @EGREP@
124EXEEXT = @EXEEXT@
125F77 = @F77@
126FFLAGS = @FFLAGS@
127GCRYPT_CIPHERS = @GCRYPT_CIPHERS@
128GCRYPT_DIGESTS = @GCRYPT_DIGESTS@
129GCRYPT_PUBKEY_CIPHERS = @GCRYPT_PUBKEY_CIPHERS@
130GCRYPT_RANDOM = @GCRYPT_RANDOM@
131GPG_ERROR_CFLAGS = @GPG_ERROR_CFLAGS@
132GPG_ERROR_CONFIG = @GPG_ERROR_CONFIG@
133GPG_ERROR_LIBS = @GPG_ERROR_LIBS@
134HAVE_LD_VERSION_SCRIPT_FALSE = @HAVE_LD_VERSION_SCRIPT_FALSE@
135HAVE_LD_VERSION_SCRIPT_TRUE = @HAVE_LD_VERSION_SCRIPT_TRUE@
136INSTALL_DATA = @INSTALL_DATA@
137INSTALL_PROGRAM = @INSTALL_PROGRAM@
138INSTALL_SCRIPT = @INSTALL_SCRIPT@
139INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
140LDFLAGS = @LDFLAGS@
141LIBGCRYPT_CIPHERS = @LIBGCRYPT_CIPHERS@
142LIBGCRYPT_CONFIG_API_VERSION = @LIBGCRYPT_CONFIG_API_VERSION@
143LIBGCRYPT_CONFIG_CFLAGS = @LIBGCRYPT_CONFIG_CFLAGS@
144LIBGCRYPT_CONFIG_LIBS = @LIBGCRYPT_CONFIG_LIBS@
145LIBGCRYPT_DIGESTS = @LIBGCRYPT_DIGESTS@
146LIBGCRYPT_LT_AGE = @LIBGCRYPT_LT_AGE@
147LIBGCRYPT_LT_CURRENT = @LIBGCRYPT_LT_CURRENT@
148LIBGCRYPT_LT_REVISION = @LIBGCRYPT_LT_REVISION@
149LIBGCRYPT_PUBKEY_CIPHERS = @LIBGCRYPT_PUBKEY_CIPHERS@
150LIBGCRYPT_THREAD_MODULES = @LIBGCRYPT_THREAD_MODULES@
151LIBOBJS = @LIBOBJS@
152LIBS = @LIBS@
153LIBTOOL = @LIBTOOL@
154LN_S = @LN_S@
155LTLIBOBJS = @LTLIBOBJS@
156MAINT = @MAINT@
157MAINTAINER_MODE_FALSE = @MAINTAINER_MODE_FALSE@
158MAINTAINER_MODE_TRUE = @MAINTAINER_MODE_TRUE@
159MAKEINFO = @MAKEINFO@
160MPI_MOD_LIST_LO = @MPI_MOD_LIST_LO@
161MPI_MOD_LIST_O = @MPI_MOD_LIST_O@
162MPI_SFLAGS = @MPI_SFLAGS@
163NOEXECSTACK_FLAGS = @NOEXECSTACK_FLAGS@
164OBJEXT = @OBJEXT@
165PACKAGE = @PACKAGE@
166PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
167PACKAGE_NAME = @PACKAGE_NAME@
168PACKAGE_STRING = @PACKAGE_STRING@
169PACKAGE_TARNAME = @PACKAGE_TARNAME@
170PACKAGE_VERSION = @PACKAGE_VERSION@
171PATH_SEPARATOR = @PATH_SEPARATOR@
172RANLIB = @RANLIB@
173SET_MAKE = @SET_MAKE@
174SHELL = @SHELL@
175STRIP = @STRIP@
176VERSION = @VERSION@
177ac_ct_AR = @ac_ct_AR@
178ac_ct_CC = @ac_ct_CC@
179ac_ct_CXX = @ac_ct_CXX@
180ac_ct_F77 = @ac_ct_F77@
181ac_ct_RANLIB = @ac_ct_RANLIB@
182ac_ct_STRIP = @ac_ct_STRIP@
183am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
184am__fastdepCC_TRUE = @am__fastdepCC_TRUE@
185am__fastdepCXX_FALSE = @am__fastdepCXX_FALSE@
186am__fastdepCXX_TRUE = @am__fastdepCXX_TRUE@
187am__include = @am__include@
188am__leading_dot = @am__leading_dot@
189am__quote = @am__quote@
190am__tar = @am__tar@
191am__untar = @am__untar@
192bindir = @bindir@
193build = @build@
194build_alias = @build_alias@
195build_cpu = @build_cpu@
196build_os = @build_os@
197build_vendor = @build_vendor@
198datadir = @datadir@
199exec_prefix = @exec_prefix@
200host = @host@
201host_alias = @host_alias@
202host_cpu = @host_cpu@
203host_os = @host_os@
204host_vendor = @host_vendor@
205includedir = @includedir@
206infodir = @infodir@
207install_sh = @install_sh@
208libdir = @libdir@
209libexecdir = @libexecdir@
210localstatedir = @localstatedir@
211mandir = @mandir@
212mkdir_p = @mkdir_p@
213oldincludedir = @oldincludedir@
214prefix = @prefix@
215program_transform_name = @program_transform_name@
216sbindir = @sbindir@
217sharedstatedir = @sharedstatedir@
218sysconfdir = @sysconfdir@
219target = @target@
220target_alias = @target_alias@
221target_cpu = @target_cpu@
222target_os = @target_os@
223target_vendor = @target_vendor@
224ACLOCAL_AMFLAGS = -I m4
225AUTOMAKE_OPTIONS = dist-bzip2
226DIST_SUBDIRS = mpi cipher src doc tests w32-dll
227SUBDIRS = mpi cipher src doc tests
228EXTRA_DIST = BUGS autogen.sh README.apichanges README.SVN
229DISTCLEANFILES =
230all: config.h
231 $(MAKE) $(AM_MAKEFLAGS) all-recursive
232
233.SUFFIXES:
234am--refresh:
235 @:
236$(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am $(am__configure_deps)
237 @for dep in $?; do \
238 case '$(am__configure_deps)' in \
239 *$$dep*) \
240 echo ' cd $(srcdir) && $(AUTOMAKE) --gnu '; \
241 cd $(srcdir) && $(AUTOMAKE) --gnu \
242 && exit 0; \
243 exit 1;; \
244 esac; \
245 done; \
246 echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu Makefile'; \
247 cd $(top_srcdir) && \
248 $(AUTOMAKE) --gnu Makefile
249.PRECIOUS: Makefile
250Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
251 @case '$?' in \
252 *config.status*) \
253 echo ' $(SHELL) ./config.status'; \
254 $(SHELL) ./config.status;; \
255 *) \
256 echo ' cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe)'; \
257 cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe);; \
258 esac;
259
260$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
261 $(SHELL) ./config.status --recheck
262
263$(top_srcdir)/configure: @MAINTAINER_MODE_TRUE@ $(am__configure_deps)
264 cd $(srcdir) && $(AUTOCONF)
265$(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ $(am__aclocal_m4_deps)
266 cd $(srcdir) && $(ACLOCAL) $(ACLOCAL_AMFLAGS)
267
268config.h: stamp-h1
269 @if test ! -f $@; then \
270 rm -f stamp-h1; \
271 $(MAKE) stamp-h1; \
272 else :; fi
273
274stamp-h1: $(srcdir)/config.h.in $(top_builddir)/config.status
275 @rm -f stamp-h1
276 cd $(top_builddir) && $(SHELL) ./config.status config.h
277$(srcdir)/config.h.in: @MAINTAINER_MODE_TRUE@ $(am__configure_deps)
278 cd $(top_srcdir) && $(AUTOHEADER)
279 rm -f stamp-h1
280 touch $@
281
282distclean-hdr:
283 -rm -f config.h stamp-h1
284
285mostlyclean-libtool:
286 -rm -f *.lo
287
288clean-libtool:
289 -rm -rf .libs _libs
290
291distclean-libtool:
292 -rm -f libtool
293uninstall-info-am:
294
295# This directory's subdirectories are mostly independent; you can cd
296# into them and run `make' without going through this Makefile.
297# To change the values of `make' variables: instead of editing Makefiles,
298# (1) if the variable is set in `config.status', edit `config.status'
299# (which will cause the Makefiles to be regenerated when you run `make');
300# (2) otherwise, pass the desired values on the `make' command line.
301$(RECURSIVE_TARGETS):
302 @set fnord $$MAKEFLAGS; amf=$$2; \
303 dot_seen=no; \
304 target=`echo $@ | sed s/-recursive//`; \
305 list='$(SUBDIRS)'; for subdir in $$list; do \
306 echo "Making $$target in $$subdir"; \
307 if test "$$subdir" = "."; then \
308 dot_seen=yes; \
309 local_target="$$target-am"; \
310 else \
311 local_target="$$target"; \
312 fi; \
313 (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
314 || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
315 done; \
316 if test "$$dot_seen" = "no"; then \
317 $(MAKE) $(AM_MAKEFLAGS) "$$target-am" || exit 1; \
318 fi; test -z "$$fail"
319
320mostlyclean-recursive clean-recursive distclean-recursive \
321maintainer-clean-recursive:
322 @set fnord $$MAKEFLAGS; amf=$$2; \
323 dot_seen=no; \
324 case "$@" in \
325 distclean-* | maintainer-clean-*) list='$(DIST_SUBDIRS)' ;; \
326 *) list='$(SUBDIRS)' ;; \
327 esac; \
328 rev=''; for subdir in $$list; do \
329 if test "$$subdir" = "."; then :; else \
330 rev="$$subdir $$rev"; \
331 fi; \
332 done; \
333 rev="$$rev ."; \
334 target=`echo $@ | sed s/-recursive//`; \
335 for subdir in $$rev; do \
336 echo "Making $$target in $$subdir"; \
337 if test "$$subdir" = "."; then \
338 local_target="$$target-am"; \
339 else \
340 local_target="$$target"; \
341 fi; \
342 (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
343 || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
344 done && test -z "$$fail"
345tags-recursive:
346 list='$(SUBDIRS)'; for subdir in $$list; do \
347 test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) tags); \
348 done
349ctags-recursive:
350 list='$(SUBDIRS)'; for subdir in $$list; do \
351 test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) ctags); \
352 done
353
354ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
355 list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
356 unique=`for i in $$list; do \
357 if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
358 done | \
359 $(AWK) ' { files[$$0] = 1; } \
360 END { for (i in files) print i; }'`; \
361 mkid -fID $$unique
362tags: TAGS
363
364TAGS: tags-recursive $(HEADERS) $(SOURCES) config.h.in $(TAGS_DEPENDENCIES) \
365 $(TAGS_FILES) $(LISP)
366 tags=; \
367 here=`pwd`; \
368 if ($(ETAGS) --etags-include --version) >/dev/null 2>&1; then \
369 include_option=--etags-include; \
370 empty_fix=.; \
371 else \
372 include_option=--include; \
373 empty_fix=; \
374 fi; \
375 list='$(SUBDIRS)'; for subdir in $$list; do \
376 if test "$$subdir" = .; then :; else \
377 test ! -f $$subdir/TAGS || \
378 tags="$$tags $$include_option=$$here/$$subdir/TAGS"; \
379 fi; \
380 done; \
381 list='$(SOURCES) $(HEADERS) config.h.in $(LISP) $(TAGS_FILES)'; \
382 unique=`for i in $$list; do \
383 if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
384 done | \
385 $(AWK) ' { files[$$0] = 1; } \
386 END { for (i in files) print i; }'`; \
387 if test -z "$(ETAGS_ARGS)$$tags$$unique"; then :; else \
388 test -n "$$unique" || unique=$$empty_fix; \
389 $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
390 $$tags $$unique; \
391 fi
392ctags: CTAGS
393CTAGS: ctags-recursive $(HEADERS) $(SOURCES) config.h.in $(TAGS_DEPENDENCIES) \
394 $(TAGS_FILES) $(LISP)
395 tags=; \
396 here=`pwd`; \
397 list='$(SOURCES) $(HEADERS) config.h.in $(LISP) $(TAGS_FILES)'; \
398 unique=`for i in $$list; do \
399 if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
400 done | \
401 $(AWK) ' { files[$$0] = 1; } \
402 END { for (i in files) print i; }'`; \
403 test -z "$(CTAGS_ARGS)$$tags$$unique" \
404 || $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
405 $$tags $$unique
406
407GTAGS:
408 here=`$(am__cd) $(top_builddir) && pwd` \
409 && cd $(top_srcdir) \
410 && gtags -i $(GTAGS_ARGS) $$here
411
412distclean-tags:
413 -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
414
415distdir: $(DISTFILES)
416 $(am__remove_distdir)
417 mkdir $(distdir)
418 $(mkdir_p) $(distdir)/m4 $(distdir)/src
419 @srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
420 topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \
421 list='$(DISTFILES)'; for file in $$list; do \
422 case $$file in \
423 $(srcdir)/*) file=`echo "$$file" | sed "s|^$$srcdirstrip/||"`;; \
424 $(top_srcdir)/*) file=`echo "$$file" | sed "s|^$$topsrcdirstrip/|$(top_builddir)/|"`;; \
425 esac; \
426 if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
427 dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
428 if test "$$dir" != "$$file" && test "$$dir" != "."; then \
429 dir="/$$dir"; \
430 $(mkdir_p) "$(distdir)$$dir"; \
431 else \
432 dir=''; \
433 fi; \
434 if test -d $$d/$$file; then \
435 if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
436 cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \
437 fi; \
438 cp -pR $$d/$$file $(distdir)$$dir || exit 1; \
439 else \
440 test -f $(distdir)/$$file \
441 || cp -p $$d/$$file $(distdir)/$$file \
442 || exit 1; \
443 fi; \
444 done
445 list='$(DIST_SUBDIRS)'; for subdir in $$list; do \
446 if test "$$subdir" = .; then :; else \
447 test -d "$(distdir)/$$subdir" \
448 || $(mkdir_p) "$(distdir)/$$subdir" \
449 || exit 1; \
450 distdir=`$(am__cd) $(distdir) && pwd`; \
451 top_distdir=`$(am__cd) $(top_distdir) && pwd`; \
452 (cd $$subdir && \
453 $(MAKE) $(AM_MAKEFLAGS) \
454 top_distdir="$$top_distdir" \
455 distdir="$$distdir/$$subdir" \
456 distdir) \
457 || exit 1; \
458 fi; \
459 done
460 $(MAKE) $(AM_MAKEFLAGS) \
461 top_distdir="$(top_distdir)" distdir="$(distdir)" \
462 dist-hook
463 -find $(distdir) -type d ! -perm -777 -exec chmod a+rwx {} \; -o \
464 ! -type d ! -perm -444 -links 1 -exec chmod a+r {} \; -o \
465 ! -type d ! -perm -400 -exec chmod a+r {} \; -o \
466 ! -type d ! -perm -444 -exec $(SHELL) $(install_sh) -c -m a+r {} {} \; \
467 || chmod -R a+r $(distdir)
468dist-gzip: distdir
469 tardir=$(distdir) && $(am__tar) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).tar.gz
470 $(am__remove_distdir)
471dist-bzip2: distdir
472 tardir=$(distdir) && $(am__tar) | bzip2 -9 -c >$(distdir).tar.bz2
473 $(am__remove_distdir)
474
475dist-tarZ: distdir
476 tardir=$(distdir) && $(am__tar) | compress -c >$(distdir).tar.Z
477 $(am__remove_distdir)
478
479dist-shar: distdir
480 shar $(distdir) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).shar.gz
481 $(am__remove_distdir)
482
483dist-zip: distdir
484 -rm -f $(distdir).zip
485 zip -rq $(distdir).zip $(distdir)
486 $(am__remove_distdir)
487
488dist dist-all: distdir
489 tardir=$(distdir) && $(am__tar) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).tar.gz
490 tardir=$(distdir) && $(am__tar) | bzip2 -9 -c >$(distdir).tar.bz2
491 $(am__remove_distdir)
492
493# This target untars the dist file and tries a VPATH configuration. Then
494# it guarantees that the distribution is self-contained by making another
495# tarfile.
496distcheck: dist
497 case '$(DIST_ARCHIVES)' in \
498 *.tar.gz*) \
499 GZIP=$(GZIP_ENV) gunzip -c $(distdir).tar.gz | $(am__untar) ;;\
500 *.tar.bz2*) \
501 bunzip2 -c $(distdir).tar.bz2 | $(am__untar) ;;\
502 *.tar.Z*) \
503 uncompress -c $(distdir).tar.Z | $(am__untar) ;;\
504 *.shar.gz*) \
505 GZIP=$(GZIP_ENV) gunzip -c $(distdir).shar.gz | unshar ;;\
506 *.zip*) \
507 unzip $(distdir).zip ;;\
508 esac
509 chmod -R a-w $(distdir); chmod a+w $(distdir)
510 mkdir $(distdir)/_build
511 mkdir $(distdir)/_inst
512 chmod a-w $(distdir)
513 dc_install_base=`$(am__cd) $(distdir)/_inst && pwd | sed -e 's,^[^:\\/]:[\\/],/,'` \
514 && dc_destdir="$${TMPDIR-/tmp}/am-dc-$$$$/" \
515 && cd $(distdir)/_build \
516 && ../configure --srcdir=.. --prefix="$$dc_install_base" \
517 $(DISTCHECK_CONFIGURE_FLAGS) \
518 && $(MAKE) $(AM_MAKEFLAGS) \
519 && $(MAKE) $(AM_MAKEFLAGS) dvi \
520 && $(MAKE) $(AM_MAKEFLAGS) check \
521 && $(MAKE) $(AM_MAKEFLAGS) install \
522 && $(MAKE) $(AM_MAKEFLAGS) installcheck \
523 && $(MAKE) $(AM_MAKEFLAGS) uninstall \
524 && $(MAKE) $(AM_MAKEFLAGS) distuninstallcheck_dir="$$dc_install_base" \
525 distuninstallcheck \
526 && chmod -R a-w "$$dc_install_base" \
527 && ({ \
528 (cd ../.. && umask 077 && mkdir "$$dc_destdir") \
529 && $(MAKE) $(AM_MAKEFLAGS) DESTDIR="$$dc_destdir" install \
530 && $(MAKE) $(AM_MAKEFLAGS) DESTDIR="$$dc_destdir" uninstall \
531 && $(MAKE) $(AM_MAKEFLAGS) DESTDIR="$$dc_destdir" \
532 distuninstallcheck_dir="$$dc_destdir" distuninstallcheck; \
533 } || { rm -rf "$$dc_destdir"; exit 1; }) \
534 && rm -rf "$$dc_destdir" \
535 && $(MAKE) $(AM_MAKEFLAGS) dist \
536 && rm -rf $(DIST_ARCHIVES) \
537 && $(MAKE) $(AM_MAKEFLAGS) distcleancheck
538 $(am__remove_distdir)
539 @(echo "$(distdir) archives ready for distribution: "; \
540 list='$(DIST_ARCHIVES)'; for i in $$list; do echo $$i; done) | \
541 sed -e '1{h;s/./=/g;p;x;}' -e '$${p;x;}'
542distuninstallcheck:
543 @cd $(distuninstallcheck_dir) \
544 && test `$(distuninstallcheck_listfiles) | wc -l` -le 1 \
545 || { echo "ERROR: files left after uninstall:" ; \
546 if test -n "$(DESTDIR)"; then \
547 echo " (check DESTDIR support)"; \
548 fi ; \
549 $(distuninstallcheck_listfiles) ; \
550 exit 1; } >&2
551distcleancheck: distclean
552 @if test '$(srcdir)' = . ; then \
553 echo "ERROR: distcleancheck can only run from a VPATH build" ; \
554 exit 1 ; \
555 fi
556 @test `$(distcleancheck_listfiles) | wc -l` -eq 0 \
557 || { echo "ERROR: files left in build directory after distclean:" ; \
558 $(distcleancheck_listfiles) ; \
559 exit 1; } >&2
560check-am: all-am
561check: check-recursive
562all-am: Makefile config.h
563installdirs: installdirs-recursive
564installdirs-am:
565install: install-recursive
566install-exec: install-exec-recursive
567install-data: install-data-recursive
568uninstall: uninstall-recursive
569
570install-am: all-am
571 @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
572
573installcheck: installcheck-recursive
574install-strip:
575 $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
576 install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
577 `test -z '$(STRIP)' || \
578 echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
579mostlyclean-generic:
580
581clean-generic:
582
583distclean-generic:
584 -test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
585 -test -z "$(DISTCLEANFILES)" || rm -f $(DISTCLEANFILES)
586
587maintainer-clean-generic:
588 @echo "This command is intended for maintainers to use"
589 @echo "it deletes files that may require special tools to rebuild."
590clean: clean-recursive
591
592clean-am: clean-generic clean-libtool mostlyclean-am
593
594distclean: distclean-recursive
595 -rm -f $(am__CONFIG_DISTCLEAN_FILES)
596 -rm -f Makefile
597distclean-am: clean-am distclean-generic distclean-hdr \
598 distclean-libtool distclean-tags
599
600dvi: dvi-recursive
601
602dvi-am:
603
604html: html-recursive
605
606info: info-recursive
607
608info-am:
609
610install-data-am:
611
612install-exec-am:
613
614install-info: install-info-recursive
615
616install-man:
617
618installcheck-am:
619
620maintainer-clean: maintainer-clean-recursive
621 -rm -f $(am__CONFIG_DISTCLEAN_FILES)
622 -rm -rf $(top_srcdir)/autom4te.cache
623 -rm -f Makefile
624maintainer-clean-am: distclean-am maintainer-clean-generic
625
626mostlyclean: mostlyclean-recursive
627
628mostlyclean-am: mostlyclean-generic mostlyclean-libtool
629
630pdf: pdf-recursive
631
632pdf-am:
633
634ps: ps-recursive
635
636ps-am:
637
638uninstall-am: uninstall-info-am
639
640uninstall-info: uninstall-info-recursive
641
642.PHONY: $(RECURSIVE_TARGETS) CTAGS GTAGS all all-am am--refresh check \
643 check-am clean clean-generic clean-libtool clean-recursive \
644 ctags ctags-recursive dist dist-all dist-bzip2 dist-gzip \
645 dist-hook dist-shar dist-tarZ dist-zip distcheck distclean \
646 distclean-generic distclean-hdr distclean-libtool \
647 distclean-recursive distclean-tags distcleancheck distdir \
648 distuninstallcheck dvi dvi-am html html-am info info-am \
649 install install-am install-data install-data-am install-exec \
650 install-exec-am install-info install-info-am install-man \
651 install-strip installcheck installcheck-am installdirs \
652 installdirs-am maintainer-clean maintainer-clean-generic \
653 maintainer-clean-recursive mostlyclean mostlyclean-generic \
654 mostlyclean-libtool mostlyclean-recursive pdf pdf-am ps ps-am \
655 tags tags-recursive uninstall uninstall-am uninstall-info-am
656
657
658# Add all the files listed in "distfiles" files to the distribution,
659# apply version number s to some files and create a VERSION file which
660# we need for the Prereq: patch file trick.
661dist-hook:
662 @set -e; \
663 for file in `cd $(top_srcdir); \
664 find mpi -type f -name distfiles`; do \
665 dir=`dirname $$file` ; $(mkinstalldirs) $(distdir)/$$dir ; \
666 for i in distfiles `cat $(top_srcdir)/$$file` ; do \
667 ln $(top_srcdir)/$$dir/$$i $(distdir)/$$dir/$$i 2> /dev/null \
668 || cp -p $(top_srcdir)/$$dir/$$i $(distdir)/$$dir/$$i; \
669 done ; \
670 done
671 @set -e; \
672 echo "$(VERSION)" > $(distdir)/VERSION
673# Tell versions [3.59,3.63) of GNU make to not export all variables.
674# Otherwise a system limit (for SysV at least) may be exceeded.
675.NOEXPORT: