aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--linden/indra/CMakeLists.txt10
1 files changed, 3 insertions, 7 deletions
diff --git a/linden/indra/CMakeLists.txt b/linden/indra/CMakeLists.txt
index d198115..8dca9d8 100644
--- a/linden/indra/CMakeLists.txt
+++ b/linden/indra/CMakeLists.txt
@@ -12,8 +12,8 @@ if (COMMAND cmake_policy)
12 cmake_policy(SET CMP0003 OLD) 12 cmake_policy(SET CMP0003 OLD)
13endif (COMMAND cmake_policy) 13endif (COMMAND cmake_policy)
14 14
15set(ROOT_PROJECT_NAME "SecondLife" CACHE STRING 15set(ROOT_PROJECT_NAME "Imprudence" CACHE STRING
16 "The root project/makefile/solution name. Defaults to SecondLife.") 16 "The root project/makefile/solution name. Defaults to Imprudence.")
17project(${ROOT_PROJECT_NAME}) 17project(${ROOT_PROJECT_NAME})
18 18
19set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake") 19set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
@@ -50,10 +50,6 @@ add_subdirectory(${LIBS_OPEN_PREFIX}llvfs)
50add_subdirectory(${LIBS_OPEN_PREFIX}llwindow) 50add_subdirectory(${LIBS_OPEN_PREFIX}llwindow)
51add_subdirectory(${LIBS_OPEN_PREFIX}llxml) 51add_subdirectory(${LIBS_OPEN_PREFIX}llxml)
52 52
53if (EXISTS ${LIBS_CLOSED_DIR}llkdu AND NOT STANDALONE)
54 add_subdirectory(${LIBS_CLOSED_PREFIX}llkdu)
55endif (EXISTS ${LIBS_CLOSED_DIR}llkdu AND NOT STANDALONE)
56
57add_subdirectory(${LIBS_OPEN_PREFIX}lscript) 53add_subdirectory(${LIBS_OPEN_PREFIX}lscript)
58 54
59if (WINDOWS AND EXISTS ${LIBS_CLOSED_DIR}copy_win_scripts) 55if (WINDOWS AND EXISTS ${LIBS_CLOSED_DIR}copy_win_scripts)
@@ -87,7 +83,7 @@ if (VIEWER)
87 endif (LINUX) 83 endif (LINUX)
88 84
89 add_subdirectory(${VIEWER_PREFIX}newview) 85 add_subdirectory(${VIEWER_PREFIX}newview)
90 add_dependencies(viewer secondlife-bin) 86 add_dependencies(viewer imprudence-bin)
91endif (VIEWER) 87endif (VIEWER)
92 88
93# Linux builds the viewer and server in 2 separate projects 89# Linux builds the viewer and server in 2 separate projects