aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/ChangeLog.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog.txt')
-rw-r--r--ChangeLog.txt540
1 files changed, 540 insertions, 0 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt
index 9646bd5..4fedaa8 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -1,3 +1,543 @@
12009-09-15 McCabe Maxsted <hakushakukun@gmail.com>
2
3 * Applied patch by Robin Cornelius for VWR-11128 - Python not always detected by develop.py.
4
5 modified: linden/indra/cmake/Python.cmake
6
7
8 * Applied patch by Robin Cornelius for VWR-11138 - Make develop.py play nicely with express editions of Visual Studio.
9
10 modified: linden/indra/develop.py
11
12
13 * Added Codebastard Redgrave's windlight presets to Imprudence.
14
15 new file: linden/indra/newview/app_settings/windlight/skies/Rouge%201.xml
16 new file: linden/indra/newview/app_settings/windlight/skies/Rouge%202.xml
17 new file: linden/indra/newview/app_settings/windlight/skies/Rouge%203.xml
18 new file: linden/indra/newview/app_settings/windlight/skies/Rouge%204.xml
19 new file: linden/indra/newview/app_settings/windlight/skies/Rouge%205.xml
20 new file: linden/indra/newview/app_settings/windlight/skies/Rouge%206.xml
21
22
23 * Added tabs to mini-map radar.
24
25 modified: linden/indra/newview/llfloatermap.cpp
26 modified: linden/indra/newview/llfloatermap.h
27 modified: linden/indra/newview/skins/default/xui/en-us/floater_mini_map.xml
28
29
302009-09-14 McCabe Maxsted <hakushakukun@gmail.com>
31
32 * Small improvement to hide selection outlines in LLSelectMgr.
33
34 modified: linden/indra/newview/llselectmgr.cpp
35
36
37 * Small performance change from Emerald viewer in LLVLComposition.
38
39 modified: linden/indra/newview/llvlcomposition.cpp
40
41
42 * Applied BlockClickSit debug setting from Emerald to block sit click action.
43
44 modified: linden/indra/newview/app_settings/settings.xml
45 modified: linden/indra/newview/lltoolpie.cpp
46
47
48 * Fixed unhandled exception in llviewerobjectlist.cpp
49
50 modified: linden/indra/newview/llviewerobjectlist.cpp
51
52
532009-09-13 McCabe Maxsted <hakushakukun@gmail.com>
54
55 * Added prev/next buttons for windlight presets, cleaned up some stuff.
56
57 modified: linden/indra/newview/llfloaterwindlight.cpp
58 modified: linden/indra/newview/llfloaterwindlight.h
59 modified: linden/indra/newview/llwindlightremotectrl.cpp
60 modified: linden/indra/newview/llwlparammanager.cpp
61 modified: linden/indra/newview/llwlparammanager.h
62 modified: linden/indra/newview/skins/default/textures/textures.xml
63 modified: linden/indra/newview/skins/default/xui/en-us/floater_windlight_options.xml
64
65
66 * Fixed World options not showing up when windlight remote expanded.
67
68 modified: linden/indra/newview/skins/default/xui/en-us/panel_windlight_remote_expanded.xml
69
70
71 * Added missing left/right arrow textures.
72
73 new file: linden/indra/newview/skins/default/textures/arrow_left.tga
74 new file: linden/indra/newview/skins/default/textures/arrow_right.tga
75 new file: linden/indra/newview/skins/silver/textures/arrow_left.tga
76 new file: linden/indra/newview/skins/silver/textures/arrow_right.tga
77
78
792009-09-12 McCabe Maxsted <hakushakukun@gmail.com>
80
81 * Clarified 'show in search' in profile.
82
83 modified: linden/indra/newview/skins/default/xui/en-us/panel_avatar.xml
84
85
86 * Fixed windlight toolbar not updating windlight floater pulldown.
87
88 modified: linden/indra/newview/llfloaterwindlight.cpp
89 modified: linden/indra/newview/llwindlightremotectrl.cpp
90 modified: linden/indra/newview/llwlparammanager.cpp
91 modified: linden/indra/newview/llwlparammanager.h
92
93
94 * Fixed windlight toolbar presets not applying when region default.
95
96 modified: linden/indra/newview/llwindlightremotectrl.cpp
97
98
992009-09-11 McCabe Maxsted <hakushakukun@gmail.com>
100
101 * Applied inventory Search menu from Emerald viewer (still ugly).
102
103 modified: newview/app_settings/settings.xml
104 modified: newview/llfolderview.cpp
105 modified: newview/llfolderview.h
106 modified: newview/llinventoryactions.cpp
107 modified: newview/llinventoryview.cpp
108 modified: newview/skins/default/xui/en-us/floater_inventory.xml
109
110
111 * Applied patch for long distance opensim hypergrid tps (SVC-2491)
112 (Feature currently disabled in OpenSim)
113
114 modified: linden/indra/newview/llviewermessage.cpp
115
116
117 * Fixed browser window showing wrong title.
118
119 modified: linden/indra/newview/skins/default/xui/en-us/floater_media_browser.xml
120
121
122 * Fixed double click tp from working on HUDs.
123
124 modified: linden/indra/newview/lltoolpie.cpp
125
126
127 * Added minimize to snapshot window.
128
129 modified: linden/indra/newview/skins/default/xui/en-us/floater_snapshot.xml
130
131
132 * Upped the max bandwidth setting to 5000kbps (default 1000kbps).
133
134 modified: linden/indra/newview/llviewerthrottle.cpp
135 modified: linden/indra/newview/skins/default/xui/en-us/panel_preferences_network.xml
136 modified: linden/indra/newview/app_settings/settings.xml
137
138
139 * Applied patch to wear multiple attachments at once (VWR-5063).
140
141 modified: linden/indra/newview/llinventoryactions.cpp
142 modified: linden/indra/newview/llinventorybridge.cpp
143
144
145 * Fixed profile account info spacing.
146
147 modified: indra/newview/skins/default/xui/en-us/panel_avatar.xml
148
149
150 * Applied patch by Latif Khalifa for VWR-5370 (Detached "Contacts" panel cannot be hidden/closed via menu or shortcut (Ctrl/Cmd-Shift-F))
151
152 modified: linden/indra/newview/llfloaterchatterbox.h
153
154
155 * Applied and modified Emerald viewer feature that shows what groups are hidden in your profile.
156
157 modified: linden/indra/newview/llpanelavatar.cpp
158 modified: linden/indra/newview/skins/default/xui/en-us/panel_avatar.xml
159
160
1612009-09-10 McCabe Maxsted <hakushakukun@gmail.com>
162
163 * Created new toolbar control for windlight presets and options.
164
165 new file: linden/indra/newview/llwindlightremotectrl.cpp
166 new file: linden/indra/newview/llwindlightremotectrl.h
167 new file: linden/indra/newview/skins/default/xui/en-us/panel_windlight_controls.xml
168 new file: linden/indra/newview/skins/default/xui/en-us/panel_windlight_remote.xml
169 new file: linden/indra/newview/skins/default/xui/en-us/panel_windlight_remote_expanded.xml
170 modified: linden/indra/newview/CMakeLists.txt
171 modified: linden/indra/newview/app_settings/settings.xml
172 modified: linden/indra/newview/llfloaterwindlight.cpp
173 modified: linden/indra/newview/lloverlaybar.cpp
174 modified: linden/indra/newview/lloverlaybar.h
175 modified: linden/indra/newview/llpaneldisplay.cpp
176 modified: linden/indra/newview/llpaneldisplay.h
177 modified: linden/indra/newview/llwlparammanager.cpp
178 modified: linden/indra/newview/llwlparammanager.h
179 modified: linden/indra/newview/skins/default/xui/en-us/panel_overlaybar.xml
180 modified: linden/indra/newview/skins/default/xui/en-us/panel_preferences_graphics1.xml
181
182
183 * Fixed missing 'm' for draw distance slider.
184
185 modified: linden/indra/newview/skins/default/xui/en-us/panel_windlight_remote_expanded.xml
186
187
1882009-09-09 McCabe Maxsted <hakushakukun@gmail.com>
189
190 * Backported clickable object names from 1.23.
191
192 new file: llcommon/llcursortypes.cpp
193 new file: llcommon/llcursortypes.h
194 new file: newview/llfloaterobjectiminfo.cpp
195 new file: newview/llfloaterobjectiminfo.h
196 new file: newview/skins/default/xui/en-us/floater_object_im_info.xm
197 modified: llcommon/CMakeLists.txt
198 modified: llcommon/llchat.h
199 modified: llui/llpanel.cpp
200 modified: llui/llpanel.h
201 modified: llui/lltextbox.cpp
202 modified: llui/lltextbox.h
203 modified: llui/lltexteditor.cpp
204 modified: llui/lltexteditor.h
205 modified: llui/llview.cpp
206 modified: llui/llview.h
207 modified: llwindow/llwindow.h
208 modified: newview/CMakeLists.txt
209 modified: newview/app_settings/settings.xml
210 modified: newview/llfloaterabout.cpp
211 modified: newview/llfloaterchat.cpp
212 modified: newview/llgroupnotify.cpp
213 modified: newview/llimpanel.cpp
214 modified: newview/llstylemap.cpp
215 modified: newview/llstylemap.h
216 modified: newview/llviewermessage.cpp
217 modified: newview/skins/default/colors_base.xml
218 modified: newview/skins/silver/colors_base.xml
219
220
221 * Applied ReinstateShowTextureUUID Cool Viewer patch (reverts the "fix" for VWR-1919).
222 Patch by Henri Beauchamp, modified by McCabe Maxsted.
223
224 modified: linden/indra/newview/lltexturectrl.cpp
225 modified: linden/indra/newview/llviewermenu.cpp
226
227
228 * Fixed unlink option enabling when selecting textures.
229
230 modified: linden/indra/newview/llfloatertools.cpp
231 modified: linden/indra/newview/llviewermenu.cpp
232
233
234 * Redid layout of profile window, added group invite button.
235
236 modified: linden/indra/newview/llpanelavatar.cpp
237 modified: linden/indra/newview/llpanelavatar.h
238 modified: linden/indra/newview/skins/default/xui/en-us/floater_profile.xml
239 modified: linden/indra/newview/skins/default/xui/en-us/panel_avatar.xml
240 deleted: linden/indra/newview/skins/silver/xui/en-us/panel_avatar.xml
241
242
243 * Admin options now only show for other people's profiles.
244
245 modified: linden/indra/newview/llpanelavatar.cpp
246
247
2482009-09-08 McCabe Maxsted <hakushakukun@gmail.com>
249
250 * Created my own version of Emerald's chat channel tool.
251
252 modified: linden/indra/newview/app_settings/settings.xml
253 modified: linden/indra/newview/llchatbar.cpp
254 modified: linden/indra/newview/llchatbar.h
255 modified: linden/indra/newview/llfloaterchat.cpp
256 modified: linden/indra/newview/llfloaterchat.h
257 modified: linden/indra/newview/llprefschat.cpp
258 modified: linden/indra/newview/llprefsim.cpp
259 modified: linden/indra/newview/skins/default/xui/en-us/panel_chat_bar.xml
260 modified: linden/indra/newview/skins/default/xui/en-us/panel_preferences_chat.xml
261 modified: linden/indra/newview/skins/default/xui/en-us/floater_chat_history.xml
262
263
264 * New chat channel preference should change only on apply.
265
266 modified: linden/indra/newview/llprefschat.cpp
267 modified: linden/indra/newview/skins/default/xui/en-us/panel_preferences_chat.xml
268
269
270 * Commented out permissions button
271 (todo: backport this if there's time).
272
273 modified: linden/indra/newview/skins/default/xui/en-us/floater_tools.xml
274
275
2762009-09-07 McCabe Maxsted <hakushakukun@gmail.com>
277
278 * Fixed tool brush size.
279
280 modified: linden/indra/newview/app_settings/settings.xml
281 modified: linden/indra/newview/llfloatertools.cpp
282 modified: linden/indra/newview/lltoolbrush.cpp
283 modified: linden/indra/newview/lltoolbrush.h
284 modified: linden/scripts/messages/message_template.msg
285
286
287 * Applied and tweaked last owner in tools window from Emerald viewer.
288
289 modified: linden/indra/newview/llpanelpermissions.cpp
290 modified: linden/indra/newview/llpanelpermissions.h
291 modified: linden/indra/newview/skins/default/xui/en-us/floater_tools.xml
292
293
2942009-09-06 McCabe Maxsted <hakushakukun@gmail.com>
295
296 * Applied sit anywhere feature from Emerald viewer.
297
298 modified: linden/indra/newview/llviewermenu.cpp
299 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
300
301
302 * Applied phantom avatar feature from Emerald viewer.
303
304 modified: linden/indra/newview/llagent.cpp
305 modified: linden/indra/newview/llagent.h
306 modified: linden/indra/newview/llappviewer.cpp
307 modified: linden/indra/newview/llviewermenu.cpp
308 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
309
310
311 * Start fetching inventory at startup.
312
313 modified: linden/indra/newview/llstartup.cpp
314
315
316 * Added Emerald viewer's animation list.
317
318 new file: linden/indra/newview/jcfloater_animation_list.cpp
319 new file: linden/indra/newview/jcfloater_animation_list.h
320 new file: linden/indra/newview/skins/default/xui/en-us/floater_animation_list.xml
321 modified: linden/indra/newview/CMakeLists.txt
322 modified: linden/indra/newview/llviewermenu.cpp
323 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
324
325
326 * Added Emerald viewer's asset browser.
327
328 new file: linden/indra/newview/llfloaterassetbrowser.cpp
329 new file: linden/indra/newview/llfloaterassetbrowser.h
330 new file: linden/indra/newview/skins/default/xui/en-us/floater_asset_browser.xml
331 modified: linden/indra/newview/CMakeLists.txt
332 modified: linden/indra/newview/llfloaterassetbrowser.cpp
333 modified: linden/indra/newview/llviewermenu.cpp
334 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
335
336
337 * Added LLScrollListCtrl::getSelectedIDs().
338
339 modified: linden/indra/llui/llscrolllistctrl.cpp
340 modified: linden/indra/llui/llscrolllistctrl.h
341
342
343 * Fixed reference to missing colors.xml entry.
344
345 modified: linden/indra/newview/jcfloater_animation_list.cpp
346
347
348 * Fixed ground sit menu entry missing check.
349
350 modified: linden/indra/newview/llviewermenu.cpp
351 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
352
353
3542009-09-05 Jacek Antonelli <jacek.antonelli@gmail.com>
355
356 * Converted RLVa menu items to XUI.
357
358 modified: linden/indra/newview/llviewermenu.cpp
359 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
360
361
3622009-09-04 Jacek Antonelli <jacek.antonelli@gmail.com>
363
364 * Applied Kitty Barnett's RLVa 1.0.1h (Restrained Life) patch.
365 Made a few non-functional changes to help it apply.
366
367 modified: linden/indra/llcommon/llchat.h
368 modified: linden/indra/newview/CMakeLists.txt
369 modified: linden/indra/newview/app_settings/settings.xml
370 modified: linden/indra/newview/app_settings/settings_per_account.xml
371 modified: linden/indra/newview/llagent.cpp
372 modified: linden/indra/newview/llagent.h
373 modified: linden/indra/newview/llappviewer.cpp
374 modified: linden/indra/newview/llchatbar.cpp
375 modified: linden/indra/newview/llfloaterabout.cpp
376 modified: linden/indra/newview/llfloateractivespeakers.cpp
377 modified: linden/indra/newview/llfloaterbeacons.cpp
378 modified: linden/indra/newview/llfloaterchat.cpp
379 modified: linden/indra/newview/llfloaterinspect.cpp
380 modified: linden/indra/newview/llfloaterland.cpp
381 modified: linden/indra/newview/llfloaterland.h
382 modified: linden/indra/newview/llfloatermap.cpp
383 modified: linden/indra/newview/llfloatermap.h
384 modified: linden/indra/newview/llfloateropenobject.cpp
385 modified: linden/indra/newview/llfloaterproperties.cpp
386 modified: linden/indra/newview/llfloaterregioninfo.cpp
387 modified: linden/indra/newview/llfloaterregioninfo.h
388 modified: linden/indra/newview/llfloaterreporter.cpp
389 modified: linden/indra/newview/llfloatersettingsdebug.cpp
390 modified: linden/indra/newview/llfloaterwindlight.cpp
391 modified: linden/indra/newview/llfloaterworldmap.cpp
392 modified: linden/indra/newview/llglsandbox.cpp
393 modified: linden/indra/newview/llhoverview.cpp
394 modified: linden/indra/newview/llhudtext.cpp
395 modified: linden/indra/newview/llhudtext.h
396 modified: linden/indra/newview/llimpanel.cpp
397 modified: linden/indra/newview/llimview.cpp
398 modified: linden/indra/newview/llinventorybridge.cpp
399 modified: linden/indra/newview/llinventorymodel.cpp
400 modified: linden/indra/newview/llinventoryview.cpp
401 modified: linden/indra/newview/llinventoryview.h
402 modified: linden/indra/newview/llmaniptranslate.cpp
403 modified: linden/indra/newview/llnetmap.cpp
404 modified: linden/indra/newview/llnotify.cpp
405 modified: linden/indra/newview/lloverlaybar.cpp
406 modified: linden/indra/newview/llpanelavatar.cpp
407 modified: linden/indra/newview/llpanelclassified.cpp
408 modified: linden/indra/newview/llpanelcontents.cpp
409 modified: linden/indra/newview/llpaneldisplay.cpp
410 modified: linden/indra/newview/llpanelinventory.cpp
411 modified: linden/indra/newview/llpanelland.cpp
412 modified: linden/indra/newview/llpanellogin.cpp
413 modified: linden/indra/newview/llpanelobject.cpp
414 modified: linden/indra/newview/llpanelpermissions.cpp
415 modified: linden/indra/newview/llpanelpick.cpp
416 modified: linden/indra/newview/llprefsim.cpp
417 modified: linden/indra/newview/llpreviewscript.cpp
418 modified: linden/indra/newview/llselectmgr.cpp
419 modified: linden/indra/newview/llstartup.cpp
420 modified: linden/indra/newview/llstatusbar.cpp
421 modified: linden/indra/newview/lltoolbar.cpp
422 modified: linden/indra/newview/lltooldraganddrop.cpp
423 modified: linden/indra/newview/lltoolface.cpp
424 modified: linden/indra/newview/lltoolgrab.cpp
425 modified: linden/indra/newview/lltoolpie.cpp
426 modified: linden/indra/newview/lltoolplacer.cpp
427 modified: linden/indra/newview/lltoolselect.cpp
428 modified: linden/indra/newview/lltracker.cpp
429 modified: linden/indra/newview/llviewercontrol.cpp
430 modified: linden/indra/newview/llviewerdisplay.cpp
431 modified: linden/indra/newview/llviewermenu.cpp
432 modified: linden/indra/newview/llviewermessage.cpp
433 modified: linden/indra/newview/llviewerobject.cpp
434 modified: linden/indra/newview/llviewertexteditor.cpp
435 modified: linden/indra/newview/llviewerwindow.cpp
436 modified: linden/indra/newview/llvoavatar.cpp
437 modified: linden/indra/newview/llvovolume.cpp
438 modified: linden/indra/newview/llworldmapview.cpp
439 modified: linden/indra/newview/pipeline.cpp
440 new file: linden/indra/newview/rlvevent.h
441 new file: linden/indra/newview/rlvextensions.cpp
442 new file: linden/indra/newview/rlvextensions.h
443 new file: linden/indra/newview/rlvfloaterbehaviour.cpp
444 new file: linden/indra/newview/rlvfloaterbehaviour.h
445 new file: linden/indra/newview/rlvhandler.cpp
446 new file: linden/indra/newview/rlvhandler.h
447 new file: linden/indra/newview/rlvhelper.cpp
448 new file: linden/indra/newview/rlvhelper.h
449 new file: linden/indra/newview/rlvmultistringsearch.cpp
450 new file: linden/indra/newview/rlvmultistringsearch.h
451 new file: linden/indra/newview/skins/default/xui/en-us/floater_rlv_behaviour.xml
452
453
4542009-09-04 McCabe Maxsted <hakushakukun@gmail.com>
455
456 * Updated GStreamer and Zlib windows libs.
457
458 modified: linden/indra/cmake/CopyWinLibs.cmake
459 modified: linden/install.xml
460
461
462 * Fixed inability to minimize chat history.
463
464 modified: linden/indra/newview/skins/default/xui/en-us/floater_chat_history.xml
465
466
467 * Rebranded startup loading page to Imprudence.
468
469 modified: linden/indra/newview/skins/default/html/en-us/loading/loading.html
470 new file: linden/indra/newview/skins/default/html/en-us/loading/imprudence_loading.png
471
472
473 * Cherry-picked Armin's middle mouse copy branch.
474 * Cherry-picked Armin's double-click tp inworld branch.
475
476
477 * Added 'Go Here' to object pie menu.
478
479 modified: linden/indra/newview/skins/default/xui/en-us/menu_pie_object.xml
480
481
482 * Integrated 1.23's tool floater with link/unlink buttons.
483
484 modified: linden/indra/newview/llfloatertelehub.cpp
485 modified: linden/indra/newview/llfloatertools.cpp
486 modified: linden/indra/newview/llfloatertools.h
487 modified: linden/indra/newview/llviewermenu.cpp
488 modified: linden/indra/newview/skins/default/xui/en-us/floater_tools.xml
489
490
491 * Fixed tree/grass label not hiding.
492
493 modified: linden/indra/newview/llfloatertools.cpp
494
495
4962009-09-03 Jacek Antonelli <jacek.antonelli@gmail.com>
497
498 * Backported 1.23 fix for animation joint assertion crash.
499
500 modified: linden/indra/llcharacter/llkeyframemotion.cpp
501
502
503 * Updated object backup feature to Meerkat's SVN, imported floater.
504
505 modified: linden/indra/newview/primbackup.cpp
506 modified: linden/indra/newview/primbackup.h
507 new file: linden/indra/newview/skins/default/xui/en-us/floater_prim_import.xml
508
509
510 * Imported Meerkat's object backup feature.
511
512 modified: linden/indra/newview/CMakeLists.txt
513 modified: linden/indra/newview/app_settings/settings.xml
514 modified: linden/indra/newview/llviewermenu.cpp
515 modified: linden/indra/newview/llviewerobjectlist.cpp
516 new file: linden/indra/newview/primbackup.cpp
517 new file: linden/indra/newview/primbackup.h
518 modified: linden/indra/newview/skins/default/xui/en-us/menu_pie_object.xml
519 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
520
521
522 * Updated some python scripts to not use deprecated modules.
523
524 modified: linden/indra/lib/python/indra/base/lluuid.py
525 modified: linden/indra/lib/python/indra/ipc/llmessage.py
526 modified: linden/scripts/install.py
527
528
5292009-08-29 McCabe Maxsted <hakushakukun@gmail.com>
530
531 * Fixed OpenAL CMake error
532
533 modified: linden/indra/cmake/OPENAL.cmake
534
535
536 * Fixed CMake not finding GLib on windows.
537
538 modified: linden/indra/cmake/GStreamer.cmake
539
540
12009-08-12 McCabe Maxsted <hakushakukun@gmail.com> 5412009-08-12 McCabe Maxsted <hakushakukun@gmail.com>
2 542
3 * Added basic radar to the minimap. 543 * Added basic radar to the minimap.