aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/ChangeLog.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog.txt')
-rw-r--r--ChangeLog.txt304
1 files changed, 245 insertions, 59 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt
index c3311bb..3ad4e9c 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -3,6 +3,219 @@
3 * Updated Imprudence to be based on SL 1.22.11. 3 * Updated Imprudence to be based on SL 1.22.11.
4 4
5 5
6
7=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
8=- 1.1.0 -=
9=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
10
11
122009-06-06 Jacek Antonelli <jacek.antonelli@gmail.com>
13
14 * Updated version/copyright info for Mac version.
15
16 modified: linden/indra/newview/English.lproj/InfoPlist.strings
17 modified: linden/indra/newview/Info-Imprudence.plist
18
19
20 * Set version to 1.1.0 (not RC).
21
22 modified: linden/indra/llcommon/llversionviewer.h
23
24
25 * Improved regex and formatting in build_version.py.
26 Handles empty test version strings better.
27
28 modified: linden/scripts/build_version.py
29
30
31 * Pie menu for HUD and Attachment should use "Attachment Touch".
32
33 modified: linden/indra/newview/skins/default/xui/en-us/menu_pie_attachment.xml
34 modified: linden/indra/newview/skins/default/xui/en-us/menu_hud_attachment.xml
35
36
37 * Fixed "Take" on the object pie menu not working.
38
39 modified: linden/indra/newview/skins/default/xui/en-us/menu_pie_object.xml:
40
41
42
432009-06-05 McCabe Maxsted <hakushakukun@gmail.com>
44
45 * linden/indra/newview/llfloatersnapshot.cpp:
46 Fixed high res checkbox not hiding.
47
48
49 * linden/indra/newview/llselectmgr.cpp:
50 Redid pie menus based on feedback from VWR-8080.
51 * linden/indra/newview/lltoolpie.cpp:
52 Ditto.
53 * linden/indra/newview/skins/default/xui/en-us/menu_pie_attachment.xml:
54 Ditto.
55 * linden/indra/newview/skins/default/xui/en-us/menu_pie_avatar.xml:
56 Ditto.
57 * linden/indra/newview/skins/default/xui/en-us/menu_pie_hud.xml:
58 Ditto.
59 * linden/indra/newview/skins/default/xui/en-us/menu_pie_land.xml:
60 Ditto.
61 * linden/indra/newview/skins/default/xui/en-us/menu_pie_object.xml:
62 Ditto.
63 * linden/indra/newview/skins/default/xui/en-us/menu_pie_self.xml:
64 Ditto.
65
66
67 * linden/indra/newview/llviewernetwork.cpp:
68 Menu bar now only changes color for Aditi.
69
70
712009-06-01 Jacek Antonelli <jacek.antonelli@gmail.com>
72
73 * Mute in Profile window triggers confirmation dialog too.
74
75 modified: linden/indra/newview/llpanelavatar.cpp
76
77
78 * Added confirmation dialogs for Mute from pie menu.
79 Dialog is for muting avatars and objects from the pie menu only.
80
81 modified: linden/indra/newview/llmutelist.cpp
82 modified: linden/indra/newview/llmutelist.h
83 modified: linden/indra/newview/llviewermenu.cpp
84 modified: linden/indra/newview/skins/default/xui/en-us/alerts.xml
85
86
872009-05-31 Jacek Antonelli <jacek.antonelli@gmail.com>
88
89 * Added a confirmation dialog for Take Off All Clothes.
90
91 modified: linden/indra/newview/llagent.cpp
92 modified: linden/indra/newview/llagent.h
93 modified: linden/indra/newview/skins/default/xui/en-us/alerts.xml
94
95
962009-05-25 Jacek Antonelli <jacek.antonelli@gmail.com>
97
98 * linden/indra/newview/llinventorybridge.cpp (buildContextMenu):
99 Added a separator between Wear and Restore to Last Position.
100 * linden/indra/newview/skins/default/xui/en-us/menu_inventory.xml:
101 Ditto.
102
103
104 * linden/indra/newview/llinventorybridge.cpp:
105 Restore to Last Position has a confirmation dialog now.
106
107
108 * linden/indra/newview/llinventorybridge.cpp:
109 Added Restore to Last Position confirmation and callback methods.
110 LLItemBridge::restoreToWorldConfirm()
111 LLItemBridge::restoreToWorldCallback()
112 * linden/indra/newview/llinventorybridge.h:
113 Ditto.
114
115
116 * linden/indra/newview/skins/default/xui/en-us/alerts.xml:
117 Added ConfirmRestoreToWorld alert text.
118
119
120 * linden/indra/newview/llpanellogin.cpp:
121 User-initiated Toggle Fullscreen has a confirmation dialog now.
122 That's in the View menu and also Alt+Enter at login screen.
123 * linden/indra/newview/llviewermenu.cpp:
124 Ditto.
125
126
127 * linden/indra/newview/llviewerwindow.cpp:
128 Added Toggle Fullscreen confirmation and callback methods.
129 LLViewerWindow::toggleFullscreenConfirm()
130 LLViewerWindow::toggleFullscreenCallback()
131 * linden/indra/newview/llviewerwindow.h (LLWindowCallbacks):
132 Ditto.
133
134
135 * linden/indra/newview/skins/default/xui/en-us/alerts.xml:
136 Added ConfirmToggleFullscreen alert text.
137
138
1392009-05-24 Jacek Antonelli <jacek.antonelli@gmail.com>
140
141 * linden/indra/newview/llfloaterworldmap.cpp:
142 User-initiated Teleport Home has confirmation dialog.
143 That's in the World menu and on the world map.
144 * linden/indra/newview/llviewermenu.cpp:
145 Ditto.
146
147
148 * linden/indra/newview/llagent.cpp:
149 Added Teleport Home confirmation and callback methods.
150 LLAgent::teleportHomeConfirm()
151 LLAgent::teleportHomeCallback()
152 * linden/indra/newview/llagent.h:
153 Ditto.
154
155
156 * linden/indra/newview/llagent.cpp:
157 Moved LLAgent::teleportHome() definition.
158 Was in llagent.h for no good reason, now in llagent.cpp.
159 * linden/indra/newview/llagent.h:
160 Ditto.
161
162
163 * linden/indra/newview/skins/default/xui/en-us/alerts.xml:
164 Added ConfirmTeleportHome alert text.
165
166
1672009-05-18 Jacek Antonelli <jacek.antonelli@gmail.com>
168
169 * linden/indra/newview/viewer_manifest.py:
170 Changed the list of installed Mac gstreamer plugins.
171
172 Commented out libgstqtwrapper.so, since it causes issues with
173 MP3s (and perhaps other types).
174
175 Added:
176 libgstfilter.so
177 libgstmultifile.so
178 libgststereo.so
179 libgstvideobalance.so
180 libgstvideobox.so
181 libgstvideocrop.so
182 libgstvideoflip.so
183 libgstvideomixer.so
184 libgstvideorate.so
185 libgstvideosignal.so
186
187
1882009-05-16 Jacek Antonelli <jacek.antonelli@gmail.com>
189
190 * linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml:
191 Reverted Ctrl-D shortcut back to Edit > Duplicate.
192 No longer World > Create Landmark Here.
193
194
1952009-05-02 Jacek Antonelli <jacek.antonelli@gmail.com>
196
197 * linden/indra/newview/viewer_manifest.py:
198 Added libgstqtwrapper.so to Mac manifest.
199
200
2012009-04-28 McCabe Maxsted <hakushakukun@gmail.com>
202
203 * linden/install.xml:
204 Fixed gstreamer plugins windows library.
205
206
207 * linden/indra/cmake/CopyWinLibs.cmake:
208 Updated copy_win_libs for 1.1 RC3.
209
210
2112009-04-27 Armin Weatherwax <email@unknown.com>
212
213 * linden/indra/newview/llchatbar.cpp:
214 Applied Armin's gesture manager patch.
215 * linden/indra/newview/skins/default/xui/en-us/panel_chat_bar.xml:
216 Ditto.
217
218
62009-04-20 Jacek Antonelli <jacek.antonelli@gmail.com> 2192009-04-20 Jacek Antonelli <jacek.antonelli@gmail.com>
7 220
8 * linden/indra/llaudio/audioengine_openal.cpp: 221 * linden/indra/llaudio/audioengine_openal.cpp:
@@ -28,6 +241,7 @@
28 * linden/indra/llmedia/llmediaimplgstreamer.h: 241 * linden/indra/llmedia/llmediaimplgstreamer.h:
29 LLMediaImplGStreamer::startPlay() is protected, LLGstPlayThread friend. 242 LLMediaImplGStreamer::startPlay() is protected, LLGstPlayThread friend.
30 243
244
31 * linden/indra/llmedia/llmediaimplgstreamer.cpp: 245 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
32 Removed redundant play() from LLMediaImplGStreamer::navigateTo(). 246 Removed redundant play() from LLMediaImplGStreamer::navigateTo().
33 247
@@ -40,6 +254,20 @@
40 Removed some useless code from LLMediaImplGStreamer::startPlay(). 254 Removed some useless code from LLMediaImplGStreamer::startPlay().
41 255
42 256
2572009-04-17 McCabe Maxsted <hakushakukun@gmail.com>
258
259 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
260 GST_PLUGIN_PATH should only search plugin directories for Windows.
261
262
263 * linden/install.xml:
264 Removed 'https' from install.xml.
265 Updated Windows GStreamer plugin url.
266 Updated Windows GLib url.
267 Updated Windows GStreamer url.
268 Updated Windows libpng url.
269
270
432009-04-10 Jacek Antonelli <jacek.antonelli@gmail.com> 2712009-04-10 Jacek Antonelli <jacek.antonelli@gmail.com>
44 272
45 * linden/indra/newview/viewer_manifest.py: 273 * linden/indra/newview/viewer_manifest.py:
@@ -59,6 +287,7 @@
59 Removed pango, commented out libopenal, added libxml2. 287 Removed pango, commented out libopenal, added libxml2.
60 288
61 289
290
622009-04-06 Jacek Antonelli <jacek.antonelli@gmail.com> 2912009-04-06 Jacek Antonelli <jacek.antonelli@gmail.com>
63 292
64 * linden/indra/llmedia/llmediaimplgstreamer.cpp: 293 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
@@ -203,9 +432,7 @@
203 Moved Windows GST_PLUGIN_PATH setup to LLMediaImplGStreamer. 432 Moved Windows GST_PLUGIN_PATH setup to LLMediaImplGStreamer.
204 LLAppViewer::gst_plugin_path --> 433 LLAppViewer::gst_plugin_path -->
205 LLMediaImplGStreamer::set_gst_plugin_path 434 LLMediaImplGStreamer::set_gst_plugin_path
206 435 * linden/indra/llmedia/llmediaimplgstreamer.h:
207
208 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
209 Ditto. 436 Ditto.
210 * linden/indra/newview/llappviewer.h: 437 * linden/indra/newview/llappviewer.h:
211 Ditto. 438 Ditto.
@@ -246,7 +473,7 @@
246 * linden/indra/llmedia/llmediaimplgstreamer_syms_rawv.inc: 473 * linden/indra/llmedia/llmediaimplgstreamer_syms_rawv.inc:
247 Ditto. 474 Ditto.
248 475
249 476
250 * linden/indra/llmedia/llmediaimplgstreamer.cpp: 477 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
251 Removed all that llgst and symbol grabbing silliness. 478 Removed all that llgst and symbol grabbing silliness.
252 Some symbols require gstreamer >= 0.10.11. 479 Some symbols require gstreamer >= 0.10.11.
@@ -260,34 +487,6 @@
260 Link with some gstreamer core libs on Linux. 487 Link with some gstreamer core libs on Linux.
261 488
262 489
2632009-03-22 McCabe Maxsted <hakushakukun@gmail.com>
264
265 * linden/indra/newview/llappviewer.cpp:
266 Removed slviewer-0-v12160-LostConnectionOnLogin.patch.
267
268 * linden/indra/newview/app_settings/settings.xml:
269 Removed slviewer-0-v12160-RememberStatsPosAndSize.patch.
270 * linden/indra/newview/lldebugview.cpp:
271 Ditto.
272 * linden/indra/newview/llfloaterstats.cpp:
273 Ditto.
274
275 * linden/indra/newview/llfloaterurldisplay.cpp:
276 Removed slviewer-0-v12160-VisitedLandmarks.patch.
277 * linden/indra/newview/llinventorybridge.cpp:
278 Ditto.
279 * linden/indra/newview/llpanelinventory.cpp:
280 Ditto.
281 * linden/indra/newview/llpanelplace.cpp:
282 Ditto.
283 * linden/indra/newview/llpanelplace.h:
284 Ditto.
285 * linden/indra/newview/llpreviewlandmark.cpp:
286 Ditto.
287 * linden/indra/newview/llviewermessage.cpp:
288 Ditto.
289
290
2912009-03-16 McCabe Maxsted <hakushakukun@gmail.com> 4902009-03-16 McCabe Maxsted <hakushakukun@gmail.com>
292 491
293 * linden/indra/llmedia/llmediaimplgstreamer.cpp: 492 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
@@ -327,12 +526,15 @@
327 * linden/indra/cmake/OPENAL.cmake: 526 * linden/indra/cmake/OPENAL.cmake:
328 Removed redundant/unnecessary OpenAL lib names and paths. 527 Removed redundant/unnecessary OpenAL lib names and paths.
329 528
529
330 * linden/indra/newview/viewer_manifest.py: 530 * linden/indra/newview/viewer_manifest.py:
331 Added Mac gstreamer plugins to viewer manifest. 531 Added Mac gstreamer plugins to viewer manifest.
332 532
533
333 * linden/indra/llaudio/CMakeLists.txt: 534 * linden/indra/llaudio/CMakeLists.txt:
334 LLAudio's CMakeLists should include OPENAL. 535 LLAudio's CMakeLists should include OPENAL.
335 536
537
336 * linden/indra/cmake/LLMedia.cmake: 538 * linden/indra/cmake/LLMedia.cmake:
337 Removed Quicktime-related cmake code. 539 Removed Quicktime-related cmake code.
338 * linden/indra/cmake/LLMedia.cmake: 540 * linden/indra/cmake/LLMedia.cmake:
@@ -354,6 +556,7 @@
354 * linden/indra/newview/viewer_manifest.py: 556 * linden/indra/newview/viewer_manifest.py:
355 Manifest includes openal and gstreamer libs in Mac package. 557 Manifest includes openal and gstreamer libs in Mac package.
356 558
559
357 * linden/indra/newview/CMakeLists.txt: 560 * linden/indra/newview/CMakeLists.txt:
358 Mac app icon will be called viewer.icns instead of secondlife.icns. 561 Mac app icon will be called viewer.icns instead of secondlife.icns.
359 * linden/indra/newview/Info-Imprudence.plist: 562 * linden/indra/newview/Info-Imprudence.plist:
@@ -385,40 +588,16 @@
385 * linden/indra/llimagej2coj/llimagej2coj.cpp: 588 * linden/indra/llimagej2coj/llimagej2coj.cpp:
386 Backported fix for VWR-4070 from 1.22. 589 Backported fix for VWR-4070 from 1.22.
387 590
591
388 * linden/indra/llaudio/audioengine.cpp: 592 * linden/indra/llaudio/audioengine.cpp:
389 Applied patch by Zwagoth Klaar for muting sounds before decoding. 593 Applied patch by Zwagoth Klaar for muting sounds before decoding.
390 * linden/indra/newview/llviewermessage.cpp: 594 * linden/indra/newview/llviewermessage.cpp:
391 Ditto. 595 Ditto.
392 596
597
393 * linden/indra/llmessage/llhttpclient.cpp: 598 * linden/indra/llmessage/llhttpclient.cpp:
394 Applied memleak patch from VWR-9400 by Henri and Carjay. 599 Applied memleak patch from VWR-9400 by Henri and Carjay.
395 600
396 * linden/indra/newview/app_settings/settings.xml:
397 Applied remember stats position and size patch
398 from Latif Khalifa (VWR-9540).
399 * linden/indra/newview/lldebugview.cpp:
400 Ditto.
401 * linden/indra/newview/llfloaterstats.cpp:
402 Ditto.
403
404 * linden/indra/newview/llappviewer.cpp:
405 Backported fix for VWR-8783, original patch by Gigs Taggart.
406
407 * linden/indra/newview/llfloaterurldisplay.cpp:
408 Applied patch to correct landmark colors not changing
409 (VWR-7896) by Zi Ree.
410 * linden/indra/newview/llinventorybridge.cpp:
411 Ditto.
412 * linden/indra/newview/llpanelinventory.cpp:
413 Ditto.
414 * linden/indra/newview/llpanelplace.cpp:
415 Ditto.
416 * linden/indra/newview/llpanelplace.h:
417 Ditto.
418 * linden/indra/newview/llpreviewlandmark.cpp:
419 Ditto.
420 * linden/indra/newview/llviewermessage.cpp:
421 Ditto.
422 601
423 * linden/indra/newview/llvoavatar.cpp: 602 * linden/indra/newview/llvoavatar.cpp:
424 Use std::string for nametags, removed bizarre name stacking option. 603 Use std::string for nametags, removed bizarre name stacking option.
@@ -427,7 +606,7 @@
4272009-03-01 McCabe Maxsted <hakushakukun@gmail.com> 6062009-03-01 McCabe Maxsted <hakushakukun@gmail.com>
428 607
429 * linden/indra/newview/llfloaterchat.cpp: 608 * linden/indra/newview/llfloaterchat.cpp:
430 Backported fix for VWR-6744 (No way to hide IMs in chat console). 609 Backported fix for VWR-3060 (No way to hide IMs in chat console).
431 * linden/indra/newview/skins/default/xui/en-us/panel_preferences_im.xml: 610 * linden/indra/newview/skins/default/xui/en-us/panel_preferences_im.xml:
432 Ditto. 611 Ditto.
433 612
@@ -447,27 +626,34 @@
447 * linden/indra/newview/skins/silver/xui/en-us/panel_media_controls.xml: 626 * linden/indra/newview/skins/silver/xui/en-us/panel_media_controls.xml:
448 Ditto. 627 Ditto.
449 628
629
450 * linden/indra/newview/llfilepicker.cpp: 630 * linden/indra/newview/llfilepicker.cpp:
451 Applied patch for VWR-5575 (crash in the file picker dealing 631 Applied patch for VWR-5575 (crash in the file picker dealing
452 with accented characters and bad locale) by Alissa Sabre. 632 with accented characters and bad locale) by Alissa Sabre.
453 633
634
454 * linden/indra/newview/pipeline.cpp: 635 * linden/indra/newview/pipeline.cpp:
455 Backported possible crash fix while changing graphics settings from 1.22. 636 Backported possible crash fix while changing graphics settings from 1.22.
456 637
638
457 * linden/indra/llui/llfloater.cpp: 639 * linden/indra/llui/llfloater.cpp:
458 Backported possible crash fix in llfloater.cpp from 1.22. 640 Backported possible crash fix in llfloater.cpp from 1.22.
459 641
642
460 * linden/indra/newview/lldrawable.cpp: 643 * linden/indra/newview/lldrawable.cpp:
461 Backported fix for VWR-3871 (prim position appears to be off) from 1.22. 644 Backported fix for VWR-3871 (prim position appears to be off) from 1.22.
462 645
646
463 * linden/indra/newview/llcompilequeue.cpp: 647 * linden/indra/newview/llcompilequeue.cpp:
464 Backported fix for SVC-2771 (script resetting can fail) from 1.22. 648 Backported fix for SVC-2771 (script resetting can fail) from 1.22.
465 * linden/indra/newview/llviewermenu.cpp: 649 * linden/indra/newview/llviewermenu.cpp:
466 Ditto. 650 Ditto.
467 651
652
468 * linden/indra/llcharacter/llbvhloader.cpp: 653 * linden/indra/llcharacter/llbvhloader.cpp:
469 Backported fix for VWR-996 (wrong visualisation of animations) from 1.22. 654 Backported fix for VWR-996 (wrong visualisation of animations) from 1.22.
470 655
656
471 * linden/indra/newview/app_settings/keywords.ini: 657 * linden/indra/newview/app_settings/keywords.ini:
472 Applied my patch for VWR-8454 (PARCEL_FLAG_ALLOW_CREATE_GROUP_OBJECTS 658 Applied my patch for VWR-8454 (PARCEL_FLAG_ALLOW_CREATE_GROUP_OBJECTS
473 not highlighted in script editor). 659 not highlighted in script editor).