aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/ChangeLog.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--ChangeLog.txt127
1 files changed, 127 insertions, 0 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt
index f99ebae..6fd7771 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -1,3 +1,19 @@
12009-04-06 Jacek Antonelli <jacek.antonelli@gmail.com>
2
3 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
4 Don't use LL_ERRS, it makes the viewer abort!
5
6
7 * linden/indra/llcommon/llerror.cpp:
8 Made LogLock mutex less likely to fail, hopefully.
9
10
11 * linden/indra/llcommon/llthread.cpp:
12 Converted BOOLs to bools in llthread.
13 * linden/indra/llcommon/llthread.h:
14 Ditto.
15
16
12009-04-05 Jacek Antonelli <jacek.antonelli@gmail.com> 172009-04-05 Jacek Antonelli <jacek.antonelli@gmail.com>
2 18
3 * linden/indra/llmedia/llmediaimplgstreamer.cpp: 19 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
@@ -63,12 +79,42 @@
63 Added LLMediaBase::EDebugLevel and setDebugLevel prototype. 79 Added LLMediaBase::EDebugLevel and setDebugLevel prototype.
64 80
65 81
822009-03-30 Jacek Antonelli <jacek.antonelli@gmail.com>
83
84 * linden/indra/newview/viewer_manifest.py:
85 Added libgstdecodebin.so plugin to Mac manifest.
86
87
662009-03-30 McCabe Maxsted <hakushakukun@gmail.com> 882009-03-30 McCabe Maxsted <hakushakukun@gmail.com>
67 89
68 * linden/indra/llmedia/llmediaimplgstreamer.cpp: 90 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
69 Cleaned up logic for bad streams. 91 Cleaned up logic for bad streams.
70 92
71 93
942009-03-29 Jacek Antonelli <jacek.antonelli@gmail.com>
95
96 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
97 set_gst_plugin_path now sets GST_PLUGIN_SYSTEM_PATH="".
98 This prevents GStreamer from looking for system-installed plugins,
99 which can have conflicts with our packaged ones.
100
101
102 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
103 Improved set_gst_plugin_path, now sets path on Mac too.
104
105
106 * linden/indra/cmake/GStreamer.cmake:
107 Using OpenAL framework on Mac after all. Maybe.
108
109
110 * linden/indra/cmake/GStreamer.cmake:
111 Tweaked the list of linked-in gstreamer libs for Mac.
112
113
114 * linden/indra/newview/viewer_manifest.py:
115 Removed the "2.0.0" named glib libs. Only using "2.0" now.
116
117
722009-03-29 McCabe Maxsted <hakushakukun@gmail.com> 1182009-03-29 McCabe Maxsted <hakushakukun@gmail.com>
73 119
74 * linden/indra/llmedia/llmediaimplgstreamer.cpp: 120 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
@@ -110,6 +156,12 @@
110 Print out the plugins gstreamer finds, for debugging. 156 Print out the plugins gstreamer finds, for debugging.
111 157
112 158
1592009-03-27 Jacek Antonelli <jacek.antonelli@gmail.com>
160
161 * linden/indra/newview/app_settings/settings.xml:
162 Changed the login splash screen URL.
163
164
1132009-03-27 McCabe Maxsted <hakushakukun@gmail.com> 1652009-03-27 McCabe Maxsted <hakushakukun@gmail.com>
114 166
115 * linden/indra/llmedia/llmediaimplgstreamer.cpp: 167 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
@@ -187,12 +239,86 @@
187 Ditto. 239 Ditto.
188 240
189 241
2422009-03-16 Jacek Antonelli <jacek.antonelli@gmail.com>
243
244 * linden/indra/newview/viewer_manifest.py:
245 Symlinks for Mac glib dylibs (2.0.0 -> 2.0).
246
247 * linden/indra/newview/viewer_manifest.py:
248 Added more Mac dylibs to manifest.
249
250
2512009-03-13 Jacek Antonelli <jacek.antonelli@gmail.com>
252
253 * linden/indra/llaudio/audioengine_openal.cpp:
254 Added error checking when generating an OpenAL source.
255
256
2572009-03-12 Jacek Antonelli <jacek.antonelli@gmail.com>
258
259 * linden/indra/cmake/OPENAL.cmake:
260 Don't find specific OpenAL lib locations on Mac/Linux.
261 Linking that way is bad. Just use -lopenal -lalut instead.
262
263
2642009-03-11 Jacek Antonelli <jacek.antonelli@gmail.com>
265
266 * linden/indra/cmake/OPENAL.cmake:
267 Removed redundant/unnecessary OpenAL lib names and paths.
268
269 * linden/indra/newview/viewer_manifest.py:
270 Added Mac gstreamer plugins to viewer manifest.
271
272 * linden/indra/llaudio/CMakeLists.txt:
273 LLAudio's CMakeLists should include OPENAL.
274
275 * linden/indra/cmake/LLMedia.cmake:
276 Removed Quicktime-related cmake code.
277 * linden/indra/cmake/LLMedia.cmake:
278 Ditto.
279 * linden/indra/llmedia/CMakeLists.txt:
280 Ditto.
281 * linden/indra/newview/CMakeLists.txt:
282 Ditto.
283
284
1902009-03-10 McCabe Maxsted <hakushakukun@gmail.com> 2852009-03-10 McCabe Maxsted <hakushakukun@gmail.com>
191 286
192 * linden/indra/llaudio/audioengine.cpp: 287 * linden/indra/llaudio/audioengine.cpp:
193 Changed startinternetstream() a bit to be clearer. 288 Changed startinternetstream() a bit to be clearer.
194 289
195 290
2912009-03-09 Jacek Antonelli <jacek.antonelli@gmail.com>
292
293 * linden/indra/newview/viewer_manifest.py:
294 Manifest includes openal and gstreamer libs in Mac package.
295
296 * linden/indra/newview/CMakeLists.txt:
297 Mac app icon will be called viewer.icns instead of secondlife.icns.
298 * linden/indra/newview/Info-Imprudence.plist:
299 Ditto.
300 * linden/indra/newview/viewer_manifest.py:
301 Ditto.
302
303
3042009-03-08 Jacek Antonelli <jacek.antonelli@gmail.com>
305
306 * linden/indra/llmedia/llmediaimplgstreamer.cpp:
307 Load the proper gstreamer lib type (dylib) on Mac.
308
309
310 * linden/indra/cmake/GStreamer.cmake:
311 Tweaked GStreamer.cmake to work on Mac.
312
313
3142009-03-07 Jacek Antonelli <jacek.antonelli@gmail.com>
315
316 * linden/indra/newview/Info-SecondLife.plist:
317 Moved Info-SecondLife.plist to Info-Imprudence.plist.
318 * linden/indra/newview/viewer_manifest.py:
319 Ditto.
320
321
1962009-03-07 McCabe Maxsted <hakushakukun@gmail.com> 3222009-03-07 McCabe Maxsted <hakushakukun@gmail.com>
197 323
198 * linden/indra/llimagej2coj/llimagej2coj.cpp: 324 * linden/indra/llimagej2coj/llimagej2coj.cpp:
@@ -286,6 +412,7 @@
286 not highlighted in script editor). 412 not highlighted in script editor).
287 413
288 414
415
289=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- 416=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
290=- 1.1.0 RC2 -= 417=- 1.1.0 RC2 -=
291=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- 418=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-