aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/ChangeLog.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--ChangeLog.txt162
1 files changed, 161 insertions, 1 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt
index 99d82c9..bb88684 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -1,3 +1,109 @@
12009-09-08 McCabe Maxsted <hakushakukun@gmail.com>
2
3 * Created my own version of Emerald's chat channel tool.
4
5 modified: linden/indra/newview/app_settings/settings.xml
6 modified: linden/indra/newview/llchatbar.cpp
7 modified: linden/indra/newview/llchatbar.h
8 modified: linden/indra/newview/llfloaterchat.cpp
9 modified: linden/indra/newview/llfloaterchat.h
10 modified: linden/indra/newview/llprefschat.cpp
11 modified: linden/indra/newview/llprefsim.cpp
12 modified: linden/indra/newview/skins/default/xui/en-us/panel_chat_bar.xml
13 modified: linden/indra/newview/skins/default/xui/en-us/panel_preferences_chat.xml
14 modified: linden/indra/newview/skins/default/xui/en-us/floater_chat_history.xml
15
16
17 * New chat channel preference should change only on apply.
18
19 modified: linden/indra/newview/llprefschat.cpp
20 modified: linden/indra/newview/skins/default/xui/en-us/panel_preferences_chat.xml
21
22
23 * Commented out permissions button
24 (todo: backport this if there's time).
25
26 modified: linden/indra/newview/skins/default/xui/en-us/floater_tools.xml
27
28
292009-09-07 McCabe Maxsted <hakushakukun@gmail.com>
30
31 * Fixed tool brush size.
32
33 modified: linden/indra/newview/app_settings/settings.xml
34 modified: linden/indra/newview/llfloatertools.cpp
35 modified: linden/indra/newview/lltoolbrush.cpp
36 modified: linden/indra/newview/lltoolbrush.h
37 modified: linden/scripts/messages/message_template.msg
38
39
40 * Applied and tweaked last owner in tools window from Emerald viewer.
41
42 modified: linden/indra/newview/llpanelpermissions.cpp
43 modified: linden/indra/newview/llpanelpermissions.h
44 modified: linden/indra/newview/skins/default/xui/en-us/floater_tools.xml
45
46
472009-09-06 McCabe Maxsted <hakushakukun@gmail.com>
48
49 * Applied sit anywhere feature from Emerald viewer.
50
51 modified: linden/indra/newview/llviewermenu.cpp
52 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
53
54
55 * Applied phantom avatar feature from Emerald viewer.
56
57 modified: linden/indra/newview/llagent.cpp
58 modified: linden/indra/newview/llagent.h
59 modified: linden/indra/newview/llappviewer.cpp
60 modified: linden/indra/newview/llviewermenu.cpp
61 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
62
63
64 * Start fetching inventory at startup.
65
66 modified: linden/indra/newview/llstartup.cpp
67
68
69 * Added Emerald viewer's animation list.
70
71 new file: linden/indra/newview/jcfloater_animation_list.cpp
72 new file: linden/indra/newview/jcfloater_animation_list.h
73 new file: linden/indra/newview/skins/default/xui/en-us/floater_animation_list.xml
74 modified: linden/indra/newview/CMakeLists.txt
75 modified: linden/indra/newview/llviewermenu.cpp
76 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
77
78
79 * Added Emerald viewer's asset browser.
80
81 new file: linden/indra/newview/llfloaterassetbrowser.cpp
82 new file: linden/indra/newview/llfloaterassetbrowser.h
83 new file: linden/indra/newview/skins/default/xui/en-us/floater_asset_browser.xml
84 modified: linden/indra/newview/CMakeLists.txt
85 modified: linden/indra/newview/llfloaterassetbrowser.cpp
86 modified: linden/indra/newview/llviewermenu.cpp
87 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
88
89
90 * Added LLScrollListCtrl::getSelectedIDs().
91
92 modified: linden/indra/llui/llscrolllistctrl.cpp
93 modified: linden/indra/llui/llscrolllistctrl.h
94
95
96 * Fixed reference to missing colors.xml entry.
97
98 modified: linden/indra/newview/jcfloater_animation_list.cpp
99
100
101 * Fixed ground sit menu entry missing check.
102
103 modified: linden/indra/newview/llviewermenu.cpp
104 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
105
106
12009-09-05 Jacek Antonelli <jacek.antonelli@gmail.com> 1072009-09-05 Jacek Antonelli <jacek.antonelli@gmail.com>
2 108
3 * Converted RLVa menu items to XUI. 109 * Converted RLVa menu items to XUI.
@@ -98,6 +204,48 @@
98 new file: linden/indra/newview/skins/default/xui/en-us/floater_rlv_behaviour.xml 204 new file: linden/indra/newview/skins/default/xui/en-us/floater_rlv_behaviour.xml
99 205
100 206
2072009-09-04 McCabe Maxsted <hakushakukun@gmail.com>
208
209 * Updated GStreamer and Zlib windows libs.
210
211 modified: linden/indra/cmake/CopyWinLibs.cmake
212 modified: linden/install.xml
213
214
215 * Fixed inability to minimize chat history.
216
217 modified: linden/indra/newview/skins/default/xui/en-us/floater_chat_history.xml
218
219
220 * Rebranded startup loading page to Imprudence.
221
222 modified: linden/indra/newview/skins/default/html/en-us/loading/loading.html
223 new file: linden/indra/newview/skins/default/html/en-us/loading/imprudence_loading.png
224
225
226 * Cherry-picked Armin's middle mouse copy branch.
227 * Cherry-picked Armin's double-click tp inworld branch.
228
229
230 * Added 'Go Here' to object pie menu.
231
232 modified: linden/indra/newview/skins/default/xui/en-us/menu_pie_object.xml
233
234
235 * Integrated 1.23's tool floater with link/unlink buttons.
236
237 modified: linden/indra/newview/llfloatertelehub.cpp
238 modified: linden/indra/newview/llfloatertools.cpp
239 modified: linden/indra/newview/llfloatertools.h
240 modified: linden/indra/newview/llviewermenu.cpp
241 modified: linden/indra/newview/skins/default/xui/en-us/floater_tools.xml
242
243
244 * Fixed tree/grass label not hiding.
245
246 modified: linden/indra/newview/llfloatertools.cpp
247
248
1012009-09-03 Jacek Antonelli <jacek.antonelli@gmail.com> 2492009-09-03 Jacek Antonelli <jacek.antonelli@gmail.com>
102 250
103 * Backported 1.23 fix for animation joint assertion crash. 251 * Backported 1.23 fix for animation joint assertion crash.
@@ -130,7 +278,19 @@
130 modified: linden/indra/lib/python/indra/ipc/llmessage.py 278 modified: linden/indra/lib/python/indra/ipc/llmessage.py
131 modified: linden/scripts/install.py 279 modified: linden/scripts/install.py
132 280
133 281
2822009-08-29 McCabe Maxsted <hakushakukun@gmail.com>
283
284 * Fixed OpenAL CMake error
285
286 modified: linden/indra/cmake/OPENAL.cmake
287
288
289 * Fixed CMake not finding GLib on windows.
290
291 modified: linden/indra/cmake/GStreamer.cmake
292
293
1342009-06-14 McCabe Maxsted <hakushakukun@gmail.com> 2942009-06-14 McCabe Maxsted <hakushakukun@gmail.com>
135 295
136 * Added IM preference for showing IMs in either main or local chat. 296 * Added IM preference for showing IMs in either main or local chat.