diff options
-rw-r--r-- | ChangeLog.txt | 73 | ||||
-rw-r--r-- | linden/indra/cmake/GStreamer.cmake | 39 | ||||
-rw-r--r-- | linden/indra/cmake/LLMedia.cmake | 2 | ||||
-rw-r--r-- | linden/indra/cmake/OPENAL.cmake | 30 | ||||
-rw-r--r-- | linden/indra/cmake/QuickTime.cmake | 49 | ||||
-rw-r--r-- | linden/indra/llaudio/CMakeLists.txt | 1 | ||||
-rw-r--r-- | linden/indra/llaudio/audioengine_openal.cpp | 11 | ||||
-rw-r--r-- | linden/indra/llmedia/CMakeLists.txt | 13 | ||||
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 5 | ||||
-rw-r--r-- | linden/indra/newview/Info-Imprudence.plist (renamed from linden/indra/newview/Info-SecondLife.plist) | 2 | ||||
-rwxr-xr-x | linden/indra/newview/viewer_manifest.py | 119 |
11 files changed, 240 insertions, 104 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt index 59c780c..88cb72f 100644 --- a/ChangeLog.txt +++ b/ChangeLog.txt | |||
@@ -29,6 +29,79 @@ | |||
29 | Link with some gstreamer core libs on Linux. | 29 | Link with some gstreamer core libs on Linux. |
30 | 30 | ||
31 | 31 | ||
32 | 2009-03-16 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
33 | |||
34 | * linden/indra/newview/viewer_manifest.py: | ||
35 | Symlinks for Mac glib dylibs (2.0.0 -> 2.0). | ||
36 | |||
37 | * linden/indra/newview/viewer_manifest.py: | ||
38 | Added more Mac dylibs to manifest. | ||
39 | |||
40 | |||
41 | 2009-03-13 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
42 | |||
43 | * linden/indra/llaudio/audioengine_openal.cpp: | ||
44 | Added error checking when generating an OpenAL source. | ||
45 | |||
46 | |||
47 | 2009-03-12 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
48 | |||
49 | * linden/indra/cmake/OPENAL.cmake: | ||
50 | Don't find specific OpenAL lib locations on Mac/Linux. | ||
51 | Linking that way is bad. Just use -lopenal -lalut instead. | ||
52 | |||
53 | |||
54 | 2009-03-11 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
55 | |||
56 | * linden/indra/cmake/OPENAL.cmake: | ||
57 | Removed redundant/unnecessary OpenAL lib names and paths. | ||
58 | |||
59 | * linden/indra/newview/viewer_manifest.py: | ||
60 | Added Mac gstreamer plugins to viewer manifest. | ||
61 | |||
62 | * linden/indra/llaudio/CMakeLists.txt: | ||
63 | LLAudio's CMakeLists should include OPENAL. | ||
64 | |||
65 | * linden/indra/cmake/LLMedia.cmake: | ||
66 | Removed Quicktime-related cmake code. | ||
67 | * linden/indra/cmake/LLMedia.cmake: | ||
68 | Ditto. | ||
69 | * linden/indra/llmedia/CMakeLists.txt: | ||
70 | Ditto. | ||
71 | * linden/indra/newview/CMakeLists.txt: | ||
72 | Ditto. | ||
73 | |||
74 | |||
75 | 2009-03-09 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
76 | |||
77 | * linden/indra/newview/viewer_manifest.py: | ||
78 | Manifest includes openal and gstreamer libs in Mac package. | ||
79 | |||
80 | * linden/indra/newview/CMakeLists.txt: | ||
81 | Mac app icon will be called viewer.icns instead of secondlife.icns. | ||
82 | * linden/indra/newview/Info-Imprudence.plist: | ||
83 | Ditto. | ||
84 | * linden/indra/newview/viewer_manifest.py: | ||
85 | Ditto. | ||
86 | |||
87 | 2009-03-08 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
88 | |||
89 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
90 | Load the proper gstreamer lib type (dylib) on Mac. | ||
91 | |||
92 | |||
93 | * linden/indra/cmake/GStreamer.cmake: | ||
94 | Tweaked GStreamer.cmake to work on Mac. | ||
95 | |||
96 | |||
97 | 2009-03-07 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
98 | |||
99 | * linden/indra/newview/Info-SecondLife.plist: | ||
100 | Moved Info-SecondLife.plist to Info-Imprudence.plist. | ||
101 | * linden/indra/newview/viewer_manifest.py: | ||
102 | Ditto. | ||
103 | |||
104 | |||
32 | =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- | 105 | =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- |
33 | =- 1.1.0 RC2 -= | 106 | =- 1.1.0 RC2 -= |
34 | =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- | 107 | =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- |
diff --git a/linden/indra/cmake/GStreamer.cmake b/linden/indra/cmake/GStreamer.cmake index 7b380a8..f790e19 100644 --- a/linden/indra/cmake/GStreamer.cmake +++ b/linden/indra/cmake/GStreamer.cmake | |||
@@ -62,18 +62,33 @@ else (WINDOWS) | |||
62 | ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/libxml2 | 62 | ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/libxml2 |
63 | ) | 63 | ) |
64 | 64 | ||
65 | set(GSTREAMER_LIBRARIES | 65 | if (DARWIN) |
66 | gstvideo-0.10 | 66 | |
67 | gstaudio-0.10 | 67 | set(GSTREAMER_LIBRARIES |
68 | gstbase-0.10 | 68 | xml2 |
69 | gstreamer-0.10 | 69 | glib-2.0 |
70 | gobject-2.0 | 70 | gobject-2.0 |
71 | gmodule-2.0 | 71 | gmodule-2.0 |
72 | dl | 72 | gthread-2.0 |
73 | gthread-2.0 | 73 | gstreamer-0.10 |
74 | rt | 74 | ) |
75 | glib-2.0 | 75 | |
76 | ) | 76 | else (DARWIN) |
77 | |||
78 | set(GSTREAMER_LIBRARIES | ||
79 | gstvideo-0.10 | ||
80 | gstaudio-0.10 | ||
81 | gstbase-0.10 | ||
82 | gstreamer-0.10 | ||
83 | gobject-2.0 | ||
84 | gmodule-2.0 | ||
85 | dl | ||
86 | gthread-2.0 | ||
87 | rt | ||
88 | glib-2.0 | ||
89 | ) | ||
90 | |||
91 | endif (DARWIN) | ||
77 | 92 | ||
78 | endif (WINDOWS) | 93 | endif (WINDOWS) |
79 | 94 | ||
diff --git a/linden/indra/cmake/LLMedia.cmake b/linden/indra/cmake/LLMedia.cmake index b7bf11c..8a36a69 100644 --- a/linden/indra/cmake/LLMedia.cmake +++ b/linden/indra/cmake/LLMedia.cmake | |||
@@ -1,7 +1,6 @@ | |||
1 | # -*- cmake -*- | 1 | # -*- cmake -*- |
2 | 2 | ||
3 | include(GStreamer) | 3 | include(GStreamer) |
4 | include(QuickTime) | ||
5 | 4 | ||
6 | set(LLMEDIA_INCLUDE_DIRS | 5 | set(LLMEDIA_INCLUDE_DIRS |
7 | ${LIBS_OPEN_DIR}/llmedia | 6 | ${LIBS_OPEN_DIR}/llmedia |
@@ -11,5 +10,4 @@ set(LLMEDIA_LIBRARIES | |||
11 | llmedia | 10 | llmedia |
12 | ${GSTREAMER_LIBRARIES} | 11 | ${GSTREAMER_LIBRARIES} |
13 | ${GSTREAMER_PLUGINS_BASE_LIBRARIES} | 12 | ${GSTREAMER_PLUGINS_BASE_LIBRARIES} |
14 | ${QUICKTIME_LIBRARY} | ||
15 | ) | 13 | ) |
diff --git a/linden/indra/cmake/OPENAL.cmake b/linden/indra/cmake/OPENAL.cmake index 5e71f66..11dcdc7 100644 --- a/linden/indra/cmake/OPENAL.cmake +++ b/linden/indra/cmake/OPENAL.cmake | |||
@@ -10,16 +10,12 @@ if (OPENAL) | |||
10 | # OPENAL_LIB | 10 | # OPENAL_LIB |
11 | 11 | ||
12 | if (WINDOWS) | 12 | if (WINDOWS) |
13 | find_library(OPENAL_LIB | 13 | find_library(OPENAL_LIB |
14 | NAMES openal openal32 OpenAL OpenAL32 wrap_oal | 14 | NAMES openal32 |
15 | PATHS ${CMAKE_SOURCE_DIR}/../libraries/i686-win32/lib/release | 15 | PATHS ${CMAKE_SOURCE_DIR}/../libraries/i686-win32/lib/release |
16 | ) | 16 | ) |
17 | |||
18 | else (WINDOWS) | 17 | else (WINDOWS) |
19 | find_library(OPENAL_LIB | 18 | set(OPENAL_LIB openal) |
20 | NAMES openal openal32 OpenAL OpenAL32 wrap_oal | ||
21 | PATHS ${ARCH_PREBUILT_DIRS_RELEASE} | ||
22 | ) | ||
23 | endif (WINDOWS) | 19 | endif (WINDOWS) |
24 | 20 | ||
25 | if (NOT OPENAL_LIB) | 21 | if (NOT OPENAL_LIB) |
@@ -34,7 +30,7 @@ if (OPENAL) | |||
34 | 30 | ||
35 | find_path(OPENAL_INCLUDE_DIR | 31 | find_path(OPENAL_INCLUDE_DIR |
36 | NAMES al.h | 32 | NAMES al.h |
37 | PATHS ${LIBS_PREBUILT_DIR}/include/AL /usr/include/AL | 33 | PATHS ${LIBS_PREBUILT_DIR}/include/AL |
38 | ) | 34 | ) |
39 | 35 | ||
40 | if (NOT OPENAL_INCLUDE_DIR) | 36 | if (NOT OPENAL_INCLUDE_DIR) |
@@ -49,15 +45,11 @@ if (OPENAL) | |||
49 | 45 | ||
50 | if (WINDOWS) | 46 | if (WINDOWS) |
51 | find_library(ALUT_LIB | 47 | find_library(ALUT_LIB |
52 | NAMES alut freealut | 48 | NAMES alut freealut |
53 | PATHS ${CMAKE_SOURCE_DIR}/../libraries/i686-win32/lib/release | 49 | PATHS ${CMAKE_SOURCE_DIR}/../libraries/i686-win32/lib/release |
54 | ) | 50 | ) |
55 | |||
56 | else (WINDOWS) | 51 | else (WINDOWS) |
57 | find_library(ALUT_LIB | 52 | set(ALUT_LIB alut) |
58 | NAMES alut freealut | ||
59 | PATHS ${ARCH_PREBUILT_DIRS_RELEASE} | ||
60 | ) | ||
61 | endif (WINDOWS) | 53 | endif (WINDOWS) |
62 | 54 | ||
63 | if (NOT ALUT_LIB) | 55 | if (NOT ALUT_LIB) |
@@ -72,7 +64,7 @@ if (OPENAL) | |||
72 | 64 | ||
73 | find_path(ALUT_INCLUDE_DIR | 65 | find_path(ALUT_INCLUDE_DIR |
74 | NAMES alut.h | 66 | NAMES alut.h |
75 | PATHS ${LIBS_PREBUILT_DIR}/include/AL /usr/include/AL | 67 | PATHS ${LIBS_PREBUILT_DIR}/include/AL |
76 | ) | 68 | ) |
77 | 69 | ||
78 | if (NOT ALUT_INCLUDE_DIR) | 70 | if (NOT ALUT_INCLUDE_DIR) |
diff --git a/linden/indra/cmake/QuickTime.cmake b/linden/indra/cmake/QuickTime.cmake deleted file mode 100644 index 4352709..0000000 --- a/linden/indra/cmake/QuickTime.cmake +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | if(INSTALL_PROPRIETARY) | ||
4 | include(Prebuilt) | ||
5 | use_prebuilt_binary(quicktime) | ||
6 | endif(INSTALL_PROPRIETARY) | ||
7 | |||
8 | if (DARWIN) | ||
9 | include(CMakeFindFrameworks) | ||
10 | find_library(QUICKTIME_LIBRARY QuickTime) | ||
11 | elseif (WINDOWS) | ||
12 | set(QUICKTIME_SDK_DIR "$ENV{PROGRAMFILES}/QuickTime SDK" | ||
13 | CACHE PATH "Location of the QuickTime SDK.") | ||
14 | |||
15 | find_library(DEBUG_QUICKTIME_LIBRARY qtmlclient | ||
16 | PATHS | ||
17 | ${ARCH_PREBUILT_DIRS_DEBUG} | ||
18 | "${QUICKTIME_SDK_DIR}\\libraries" | ||
19 | ) | ||
20 | |||
21 | find_library(RELEASE_QUICKTIME_LIBRARY qtmlclient | ||
22 | PATHS | ||
23 | ${ARCH_PREBUILT_DIRS_RELEASE} | ||
24 | "${QUICKTIME_SDK_DIR}\\libraries" | ||
25 | ) | ||
26 | |||
27 | if (DEBUG_QUICKTIME_LIBRARY AND RELEASE_QUICKTIME_LIBRARY) | ||
28 | set(QUICKTIME_LIBRARY | ||
29 | optimized ${RELEASE_QUICKTIME_LIBRARY} | ||
30 | debug ${DEBUG_QUICKTIME_LIBRARY} | ||
31 | ) | ||
32 | |||
33 | endif (DEBUG_QUICKTIME_LIBRARY AND RELEASE_QUICKTIME_LIBRARY) | ||
34 | |||
35 | include_directories( | ||
36 | ${LIBS_PREBUILT_DIR}/${LL_ARCH_DIR}/include/quicktime | ||
37 | "${QUICKTIME_SDK_DIR}\\CIncludes" | ||
38 | ) | ||
39 | endif (DARWIN) | ||
40 | |||
41 | mark_as_advanced(QUICKTIME_LIBRARY) | ||
42 | |||
43 | if (QUICKTIME_LIBRARY) | ||
44 | set(QUICKTIME ON CACHE BOOL "Build with QuickTime streaming media support.") | ||
45 | endif (QUICKTIME_LIBRARY) | ||
46 | |||
47 | if (QUICKTIME) | ||
48 | add_definitions(-DLL_QUICKTIME_ENABLED=1) | ||
49 | endif (QUICKTIME) | ||
diff --git a/linden/indra/llaudio/CMakeLists.txt b/linden/indra/llaudio/CMakeLists.txt index aa15a9d..8a26e54 100644 --- a/linden/indra/llaudio/CMakeLists.txt +++ b/linden/indra/llaudio/CMakeLists.txt | |||
@@ -4,6 +4,7 @@ project(llaudio) | |||
4 | 4 | ||
5 | include(00-Common) | 5 | include(00-Common) |
6 | include(Audio) | 6 | include(Audio) |
7 | include(OPENAL) | ||
7 | include(FMOD) | 8 | include(FMOD) |
8 | include(LLCommon) | 9 | include(LLCommon) |
9 | include(LLMath) | 10 | include(LLMath) |
diff --git a/linden/indra/llaudio/audioengine_openal.cpp b/linden/indra/llaudio/audioengine_openal.cpp index 8f836a6..6d9a242 100644 --- a/linden/indra/llaudio/audioengine_openal.cpp +++ b/linden/indra/llaudio/audioengine_openal.cpp | |||
@@ -172,6 +172,17 @@ LLAudioChannelOpenAL::LLAudioChannelOpenAL() | |||
172 | mLastSamplePos(0) | 172 | mLastSamplePos(0) |
173 | { | 173 | { |
174 | alGenSources(1, &mALSource); | 174 | alGenSources(1, &mALSource); |
175 | |||
176 | if( mALSource == AL_NONE ) | ||
177 | { | ||
178 | ALenum error = alGetError(); | ||
179 | if( error == AL_NO_ERROR ) | ||
180 | { | ||
181 | LL_WARNS("OpenAL") << "LLAudioChannelOpenAL::LLAudioChannelOpenAL() Could not generate mALSource, but no error is indicated!" << LL_ENDL; | ||
182 | } | ||
183 | LL_WARNS("OpenAL") << "LLAudioChannelOpenAL::LLAudioChannelOpenAL() Could not generate mALSource: (" << error << ") " << alGetString( error ) << LL_ENDL; | ||
184 | } | ||
185 | |||
175 | } | 186 | } |
176 | 187 | ||
177 | LLAudioChannelOpenAL::~LLAudioChannelOpenAL() | 188 | LLAudioChannelOpenAL::~LLAudioChannelOpenAL() |
diff --git a/linden/indra/llmedia/CMakeLists.txt b/linden/indra/llmedia/CMakeLists.txt index 0440153..cd4167a 100644 --- a/linden/indra/llmedia/CMakeLists.txt +++ b/linden/indra/llmedia/CMakeLists.txt | |||
@@ -63,19 +63,6 @@ if (MOZLIB) | |||
63 | list(APPEND llmedia_HEADER_FILES llmediaimplllmozlib.h) | 63 | list(APPEND llmedia_HEADER_FILES llmediaimplllmozlib.h) |
64 | endif (MOZLIB) | 64 | endif (MOZLIB) |
65 | 65 | ||
66 | if (QUICKTIME) | ||
67 | list(APPEND llmedia_SOURCE_FILES llmediaimplquicktime.cpp) | ||
68 | list(APPEND llmedia_HEADER_FILES llmediaimplquicktime.h) | ||
69 | |||
70 | # We use a bunch of deprecated system APIs. | ||
71 | if (DARWIN) | ||
72 | set_source_files_properties( | ||
73 | llmediaimplquicktime.cpp PROPERTIES | ||
74 | COMPILE_FLAGS -Wno-deprecated-declarations | ||
75 | ) | ||
76 | endif (DARWIN) | ||
77 | endif (QUICKTIME) | ||
78 | |||
79 | set_source_files_properties(${llmedia_HEADER_FILES} | 66 | set_source_files_properties(${llmedia_HEADER_FILES} |
80 | PROPERTIES HEADER_FILE_ONLY TRUE) | 67 | PROPERTIES HEADER_FILE_ONLY TRUE) |
81 | 68 | ||
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index 1e48d28..f971f97 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -849,7 +849,7 @@ if (DARWIN) | |||
849 | 849 | ||
850 | # Add resource files to the project. | 850 | # Add resource files to the project. |
851 | set(viewer_RESOURCE_FILES | 851 | set(viewer_RESOURCE_FILES |
852 | secondlife.icns | 852 | viewer.icns |
853 | macview.r | 853 | macview.r |
854 | gpu_table.txt | 854 | gpu_table.txt |
855 | Info-Imprudence.plist | 855 | Info-Imprudence.plist |
@@ -1393,7 +1393,6 @@ target_link_libraries(imprudence-bin | |||
1393 | ${SMARTHEAP_LIBRARY} | 1393 | ${SMARTHEAP_LIBRARY} |
1394 | ${UI_LIBRARIES} | 1394 | ${UI_LIBRARIES} |
1395 | ${NDOF_LIBRARY} | 1395 | ${NDOF_LIBRARY} |
1396 | ${QUICKTIME_LIBRARY} | ||
1397 | ${WINDOWS_LIBRARIES} | 1396 | ${WINDOWS_LIBRARIES} |
1398 | ${XMLRPCEPI_LIBRARIES} | 1397 | ${XMLRPCEPI_LIBRARIES} |
1399 | ${ZLIB_LIBRARIES} | 1398 | ${ZLIB_LIBRARIES} |
@@ -1447,7 +1446,7 @@ if (DARWIN) | |||
1447 | PROPERTIES | 1446 | PROPERTIES |
1448 | OUTPUT_NAME "${product}" | 1447 | OUTPUT_NAME "${product}" |
1449 | MACOSX_BUNDLE_INFO_STRING "info string - localize me" | 1448 | MACOSX_BUNDLE_INFO_STRING "info string - localize me" |
1450 | MACOSX_BUNDLE_ICON_FILE "secondlife.icns" | 1449 | MACOSX_BUNDLE_ICON_FILE "viewer.icns" |
1451 | MACOSX_BUNDLE_GUI_IDENTIFIER "Imprudence" | 1450 | MACOSX_BUNDLE_GUI_IDENTIFIER "Imprudence" |
1452 | MACOSX_BUNDLE_LONG_VERSION_STRING "ververver" | 1451 | MACOSX_BUNDLE_LONG_VERSION_STRING "ververver" |
1453 | MACOSX_BUNDLE_BUNDLE_NAME "Imprudence" | 1452 | MACOSX_BUNDLE_BUNDLE_NAME "Imprudence" |
diff --git a/linden/indra/newview/Info-SecondLife.plist b/linden/indra/newview/Info-Imprudence.plist index 32bba70..357d171 100644 --- a/linden/indra/newview/Info-SecondLife.plist +++ b/linden/indra/newview/Info-Imprudence.plist | |||
@@ -7,7 +7,7 @@ | |||
7 | <key>CFBundleExecutable</key> | 7 | <key>CFBundleExecutable</key> |
8 | <string>Imprudence</string> | 8 | <string>Imprudence</string> |
9 | <key>CFBundleIconFile</key> | 9 | <key>CFBundleIconFile</key> |
10 | <string>secondlife.icns</string> | 10 | <string>viewer.icns</string> |
11 | <key>CFBundleIdentifier</key> | 11 | <key>CFBundleIdentifier</key> |
12 | <string>com.secondlife.indra.viewer</string> | 12 | <string>com.secondlife.indra.viewer</string> |
13 | <key>CFBundleInfoDictionaryVersion</key> | 13 | <key>CFBundleInfoDictionaryVersion</key> |
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py index 3583726..637f07a 100755 --- a/linden/indra/newview/viewer_manifest.py +++ b/linden/indra/newview/viewer_manifest.py | |||
@@ -403,10 +403,57 @@ class DarwinManifest(ViewerManifest): | |||
403 | # <bundle>/Contents/MacOS/ | 403 | # <bundle>/Contents/MacOS/ |
404 | self.contents_of_tar(self.args['source']+'/mozilla-universal-darwin.tgz', 'MacOS') | 404 | self.contents_of_tar(self.args['source']+'/mozilla-universal-darwin.tgz', 'MacOS') |
405 | 405 | ||
406 | self.path("Info-SecondLife.plist", dst="Info.plist") | 406 | self.path("Info-Imprudence.plist", dst="Info.plist") |
407 | 407 | ||
408 | # copy additional libs in <bundle>/Contents/MacOS/ | 408 | # copy additional libs in <bundle>/Contents/MacOS/ |
409 | self.path("../../libraries/universal-darwin/lib_release/libndofdev.dylib", dst="MacOS/libndofdev.dylib") | 409 | if self.prefix(src="../../libraries/universal-darwin/lib_release", dst="MacOS/"): |
410 | |||
411 | self.path("libndofdev.dylib") | ||
412 | |||
413 | self.path("libopenal.1.dylib") | ||
414 | self.path("libalut.0.dylib") | ||
415 | |||
416 | self.path("libglib-2.0.0.dylib") | ||
417 | self.path("libgmodule-2.0.0.dylib") | ||
418 | self.path("libgobject-2.0.0.dylib") | ||
419 | self.path("libgthread-2.0.0.dylib") | ||
420 | |||
421 | # Symlinks to satisfy different name dependencies. | ||
422 | self.path("libglib-2.0.dylib") | ||
423 | self.path("libgmodule-2.0.dylib") | ||
424 | self.path("libgobject-2.0.dylib") | ||
425 | self.path("libgthread-2.0.dylib") | ||
426 | |||
427 | self.path("libgstreamer-0.10.dylib") | ||
428 | self.path("libgstapp-0.10.dylib") | ||
429 | self.path("libgstaudio-0.10.dylib") | ||
430 | self.path("libgstbase-0.10.dylib") | ||
431 | self.path("libgstcdda-0.10.dylib") | ||
432 | self.path("libgstcontroller-0.10.dylib") | ||
433 | self.path("libgstdataprotocol-0.10.dylib") | ||
434 | self.path("libgstfft-0.10.dylib") | ||
435 | self.path("libgstinterfaces-0.10.dylib") | ||
436 | self.path("libgstnet-0.10.dylib") | ||
437 | self.path("libgstnetbuffer-0.10.dylib") | ||
438 | self.path("libgstpbutils-0.10.dylib") | ||
439 | self.path("libgstriff-0.10.dylib") | ||
440 | self.path("libgstrtp-0.10.dylib") | ||
441 | self.path("libgstrtsp-0.10.dylib") | ||
442 | self.path("libgstsdp-0.10.dylib") | ||
443 | self.path("libgsttag-0.10.dylib") | ||
444 | self.path("libgstvideo-0.10.dylib") | ||
445 | |||
446 | self.path("libintl.3.dylib") | ||
447 | self.path("libjpeg.62.dylib") | ||
448 | self.path("libogg.0.dylib") | ||
449 | self.path("liboil-0.3.0.dylib") | ||
450 | self.path("libpango-1.0.0.dylib") | ||
451 | self.path("libpangoft2-1.0.0.dylib") | ||
452 | self.path("libtheora.0.dylib") | ||
453 | self.path("libvorbis.0.dylib") | ||
454 | self.path("libvorbisenc.2.dylib") | ||
455 | |||
456 | self.end_prefix("../../libraries/universal-darwin/lib_release") | ||
410 | 457 | ||
411 | # replace the default theme with our custom theme (so scrollbars work). | 458 | # replace the default theme with our custom theme (so scrollbars work). |
412 | if self.prefix(src="mozilla-theme", dst="MacOS/chrome"): | 459 | if self.prefix(src="mozilla-theme", dst="MacOS/chrome"): |
@@ -432,7 +479,7 @@ class DarwinManifest(ViewerManifest): | |||
432 | self.path("featuretable_mac.txt") | 479 | self.path("featuretable_mac.txt") |
433 | self.path("SecondLife.nib") | 480 | self.path("SecondLife.nib") |
434 | 481 | ||
435 | self.path("secondlife.icns") | 482 | self.path("viewer.icns") |
436 | 483 | ||
437 | # Translations | 484 | # Translations |
438 | self.path("English.lproj") | 485 | self.path("English.lproj") |
@@ -441,9 +488,71 @@ class DarwinManifest(ViewerManifest): | |||
441 | self.path("Korean.lproj") | 488 | self.path("Korean.lproj") |
442 | 489 | ||
443 | 490 | ||
491 | if self.prefix(src="../../libraries/universal-darwin/lib_release/gstreamer-plugins", dst="lib/gstreamer-plugins"): | ||
492 | self.path("libgstaacparse.so") | ||
493 | self.path("libgstadder.so") | ||
494 | self.path("libgstaiffparse.so") | ||
495 | self.path("libgstamrparse.so") | ||
496 | self.path("libgstapp.so") | ||
497 | self.path("libgstaudioconvert.so") | ||
498 | self.path("libgstaudiorate.so") | ||
499 | self.path("libgstaudioresample.so") | ||
500 | self.path("libgstautodetect.so") | ||
501 | self.path("libgstavi.so") | ||
502 | self.path("libgstcoreelements.so") | ||
503 | self.path("libgstcoreindexers.so") | ||
504 | self.path("libgstdebug.so") | ||
505 | self.path("libgstdecodebin2.so") | ||
506 | self.path("libgstdeinterlace2.so") | ||
507 | self.path("libgstequalizer.so") | ||
508 | self.path("libgstffmpeg.so") | ||
509 | self.path("libgstffmpegcolorspace.so") | ||
510 | self.path("libgstffmpegscale.so") | ||
511 | self.path("libgstflac.so") | ||
512 | self.path("libgstflv.so") | ||
513 | self.path("libgstgdp.so") | ||
514 | self.path("libgsth264parse.so") | ||
515 | self.path("libgsticydemux.so") | ||
516 | self.path("libgstid3demux.so") | ||
517 | self.path("libgstinterleave.so") | ||
518 | self.path("libgstjpeg.so") | ||
519 | self.path("libgstlevel.so") | ||
520 | self.path("libgstmetadata.so") | ||
521 | self.path("libgstmpeg4videoparse.so") | ||
522 | self.path("libgstmpegdemux.so") | ||
523 | self.path("libgstmpegvideoparse.so") | ||
524 | self.path("libgstmultipart.so") | ||
525 | self.path("libgstneonhttpsrc.so") | ||
526 | self.path("libgstogg.so") | ||
527 | self.path("libgstosxaudio.so") | ||
528 | self.path("libgstosxvideosink.so") | ||
529 | self.path("libgstpango.so") | ||
530 | self.path("libgstplaybin.so") | ||
531 | self.path("libgstpng.so") | ||
532 | self.path("libgstpostproc.so") | ||
533 | self.path("libgstqtdemux.so") | ||
534 | self.path("libgstqueue2.so") | ||
535 | self.path("libgstreal.so") | ||
536 | self.path("libgstrtp.so") | ||
537 | self.path("libgstrtpmanager.so") | ||
538 | self.path("libgstrtsp.so") | ||
539 | self.path("libgstsdpelem.so") | ||
540 | self.path("libgstselector.so") | ||
541 | self.path("libgsttcp.so") | ||
542 | self.path("libgsttheora.so") | ||
543 | self.path("libgsttypefindfunctions.so") | ||
544 | self.path("libgstudp.so") | ||
545 | self.path("libgstvideoscale.so") | ||
546 | self.path("libgstvolume.so") | ||
547 | self.path("libgstvorbis.so") | ||
548 | self.path("libgstwavparse.so") | ||
549 | |||
550 | self.end_prefix("../../libraries/universal-darwin/lib_release/gstreamer-plugins") | ||
551 | |||
552 | |||
444 | # SLVoice and vivox lols | 553 | # SLVoice and vivox lols |
445 | self.path("vivox-runtime/universal-darwin/libalut.dylib", "libalut.dylib") | 554 | #self.path("vivox-runtime/universal-darwin/libalut.dylib", "libalut.dylib") |
446 | self.path("vivox-runtime/universal-darwin/libopenal.dylib", "libopenal.dylib") | 555 | #self.path("vivox-runtime/universal-darwin/libopenal.dylib", "libopenal.dylib") |
447 | #self.path("vivox-runtime/universal-darwin/libortp.dylib", "libortp.dylib") | 556 | #self.path("vivox-runtime/universal-darwin/libortp.dylib", "libortp.dylib") |
448 | #self.path("vivox-runtime/universal-darwin/libvivoxsdk.dylib", "libvivoxsdk.dylib") | 557 | #self.path("vivox-runtime/universal-darwin/libvivoxsdk.dylib", "libvivoxsdk.dylib") |
449 | #self.path("vivox-runtime/universal-darwin/SLVoice", "SLVoice") | 558 | #self.path("vivox-runtime/universal-darwin/SLVoice", "SLVoice") |