aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--linden/doc/contributions.txt1
-rw-r--r--linden/indra/linux_crash_logger/CMakeLists.txt2
-rw-r--r--linden/indra/newview/CMakeLists.txt2
3 files changed, 3 insertions, 2 deletions
diff --git a/linden/doc/contributions.txt b/linden/doc/contributions.txt
index c7e3794..c1c3ec3 100644
--- a/linden/doc/contributions.txt
+++ b/linden/doc/contributions.txt
@@ -43,6 +43,7 @@ Aleric Inglewood
43 VWR-10759 43 VWR-10759
44 VWR-10837 44 VWR-10837
45 VWR-13996 45 VWR-13996
46 VWR-14426
46 SNOW-84 47 SNOW-84
47 SNOW-86 48 SNOW-86
48 SNOW-103 49 SNOW-103
diff --git a/linden/indra/linux_crash_logger/CMakeLists.txt b/linden/indra/linux_crash_logger/CMakeLists.txt
index 6f6754e..4b19e28 100644
--- a/linden/indra/linux_crash_logger/CMakeLists.txt
+++ b/linden/indra/linux_crash_logger/CMakeLists.txt
@@ -38,7 +38,7 @@ list(APPEND linux_crash_logger_SOURCE_FILES
38 ${linux_crash_logger_HEADER_FILES} 38 ${linux_crash_logger_HEADER_FILES}
39 ) 39 )
40 40
41list(APPEND CMAKE_EXE_LINKER_FLAGS -Wl,--as-needed) 41set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed")
42 42
43add_executable(linux-crash-logger ${linux_crash_logger_SOURCE_FILES}) 43add_executable(linux-crash-logger ${linux_crash_logger_SOURCE_FILES})
44 44
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 901cfeb..dc0cf69 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -992,7 +992,7 @@ endif (DARWIN)
992 992
993if (LINUX) 993if (LINUX)
994 LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp) 994 LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp)
995 LIST(APPEND CMAKE_EXE_LINKER_FLAGS -Wl,--as-needed) 995 SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed")
996 996
997 set(viewer_LIBRARIES 997 set(viewer_LIBRARIES
998 Xinerama 998 Xinerama