diff options
Diffstat (limited to '')
-rw-r--r-- | linden/indra/CMakeLists.txt | 6 | ||||
-rw-r--r-- | linden/indra/libotr/CMakeLists.txt | 7 |
2 files changed, 9 insertions, 4 deletions
diff --git a/linden/indra/CMakeLists.txt b/linden/indra/CMakeLists.txt index e3643d3..de5dee8 100644 --- a/linden/indra/CMakeLists.txt +++ b/linden/indra/CMakeLists.txt | |||
@@ -46,8 +46,10 @@ endif (WINDOWS) | |||
46 | # if off will use the systems libotr.so but won't be fully compatible with windows version | 46 | # if off will use the systems libotr.so but won't be fully compatible with windows version |
47 | set(STATIC_LIBOTR_ETC 1) | 47 | set(STATIC_LIBOTR_ETC 1) |
48 | 48 | ||
49 | add_subdirectory(${LIBS_OPEN_PREFIX}libgpg-error) | 49 | if (NOT WINDOWS) |
50 | add_subdirectory(${LIBS_OPEN_PREFIX}libgcrypt) | 50 | add_subdirectory(${LIBS_OPEN_PREFIX}libgpg-error) |
51 | add_subdirectory(${LIBS_OPEN_PREFIX}libgcrypt) | ||
52 | endif (NOT WINDOWS) | ||
51 | # [/$PLOTR$] | 53 | # [/$PLOTR$] |
52 | 54 | ||
53 | add_subdirectory(${LIBS_OPEN_PREFIX}llaudio) | 55 | add_subdirectory(${LIBS_OPEN_PREFIX}llaudio) |
diff --git a/linden/indra/libotr/CMakeLists.txt b/linden/indra/libotr/CMakeLists.txt index f0561d8..282535f 100644 --- a/linden/indra/libotr/CMakeLists.txt +++ b/linden/indra/libotr/CMakeLists.txt | |||
@@ -66,6 +66,9 @@ target_link_libraries(libotr | |||
66 | 66 | ||
67 | # Not sure if either or both are needed, does not seem to hurt. | 67 | # Not sure if either or both are needed, does not seem to hurt. |
68 | # Still does not make things build in the right sequence. sigh | 68 | # Still does not make things build in the right sequence. sigh |
69 | add_dependencies(libotr EP_libgcrpt) | 69 | if (NOT WINDOWS) |
70 | add_dependencies(libotr libgcrypt) | 70 | add_dependencies(libotr EP_libgcrpt) |
71 | else (NOT WINDOWS) | ||
72 | add_dependencies(libotr libgcrypt) | ||
73 | endif (NOT WINDOWS) | ||
71 | 74 | ||