diff options
author | McCabe Maxsted | 2010-07-19 12:42:49 -0700 |
---|---|---|
committer | McCabe Maxsted | 2010-07-19 12:42:49 -0700 |
commit | 8524a4228667cf0250e1e2b9cda259c5fbbc5d4c (patch) | |
tree | 9e0a3aadf39780f70f5f740d7e2f78290331fc62 /linden | |
parent | Changed version to Weekly: 2010-07-17 (diff) | |
download | meta-impy-8524a4228667cf0250e1e2b9cda259c5fbbc5d4c.zip meta-impy-8524a4228667cf0250e1e2b9cda259c5fbbc5d4c.tar.gz meta-impy-8524a4228667cf0250e1e2b9cda259c5fbbc5d4c.tar.bz2 meta-impy-8524a4228667cf0250e1e2b9cda259c5fbbc5d4c.tar.xz |
Added area search to the advanced menu, port from Emerald by Henri Beauchamp
Diffstat (limited to 'linden')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 3 | ||||
-rw-r--r-- | linden/indra/newview/app_settings/settings.xml | 16 | ||||
-rw-r--r-- | linden/indra/newview/llselectmgr.cpp | 15 | ||||
-rw-r--r-- | linden/indra/newview/llselectmgr.h | 2 | ||||
-rw-r--r-- | linden/indra/newview/llstartup.cpp | 2 | ||||
-rw-r--r-- | linden/indra/newview/llviewermenu.cpp | 12 | ||||
-rw-r--r-- | linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml | 6 |
7 files changed, 54 insertions, 2 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index ab0159f..1668609 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -75,6 +75,7 @@ set(viewer_SOURCE_FILES | |||
75 | hippoLimits.cpp | 75 | hippoLimits.cpp |
76 | hippoRestRequest.cpp | 76 | hippoRestRequest.cpp |
77 | jcfloater_animation_list.cpp | 77 | jcfloater_animation_list.cpp |
78 | jcfloaterareasearch.cpp | ||
78 | llagent.cpp | 79 | llagent.cpp |
79 | llagentaccess.cpp | 80 | llagentaccess.cpp |
80 | llagentdata.cpp | 81 | llagentdata.cpp |
@@ -504,6 +505,7 @@ set(viewer_HEADER_FILES | |||
504 | hippoLimits.h | 505 | hippoLimits.h |
505 | hippoRestRequest.h | 506 | hippoRestRequest.h |
506 | jcfloater_animation_list.h | 507 | jcfloater_animation_list.h |
508 | jcfloaterareasearch.h | ||
507 | llagent.h | 509 | llagent.h |
508 | llagentaccess.h | 510 | llagentaccess.h |
509 | llagentdata.h | 511 | llagentdata.h |
@@ -1097,6 +1099,7 @@ set(viewer_XUI_FILES | |||
1097 | skins/default/xui/en-us/floater_animation_list.xml | 1099 | skins/default/xui/en-us/floater_animation_list.xml |
1098 | skins/default/xui/en-us/floater_animation_preview.xml | 1100 | skins/default/xui/en-us/floater_animation_preview.xml |
1099 | skins/default/xui/en-us/floater_ao.xml | 1101 | skins/default/xui/en-us/floater_ao.xml |
1102 | skins/default/xui/en-us/floater_area_search.xml | ||
1100 | skins/default/xui/en-us/floater_asset_browser.xml | 1103 | skins/default/xui/en-us/floater_asset_browser.xml |
1101 | skins/default/xui/en-us/floater_auction.xml | 1104 | skins/default/xui/en-us/floater_auction.xml |
1102 | skins/default/xui/en-us/floater_audio_volume.xml | 1105 | skins/default/xui/en-us/floater_audio_volume.xml |
diff --git a/linden/indra/newview/app_settings/settings.xml b/linden/indra/newview/app_settings/settings.xml index 6fd76ac..0225218 100644 --- a/linden/indra/newview/app_settings/settings.xml +++ b/linden/indra/newview/app_settings/settings.xml | |||
@@ -163,6 +163,22 @@ | |||
163 | <integer>0</integer> | 163 | <integer>0</integer> |
164 | </array> | 164 | </array> |
165 | </map> | 165 | </map> |
166 | <key>FloaterAreaSearchRect</key> | ||
167 | <map> | ||
168 | <key>Comment</key> | ||
169 | <string>Rectangle for the area search floater</string> | ||
170 | <key>Persist</key> | ||
171 | <integer>1</integer> | ||
172 | <key>Type</key> | ||
173 | <string>Rect</string> | ||
174 | <key>Value</key> | ||
175 | <array> | ||
176 | <integer>0</integer> | ||
177 | <integer>400</integer> | ||
178 | <integer>200</integer> | ||
179 | <integer>0</integer> | ||
180 | </array> | ||
181 | </map> | ||
166 | <key>FloaterGroupTitlesRect</key> | 182 | <key>FloaterGroupTitlesRect</key> |
167 | <map> | 183 | <map> |
168 | <key>Comment</key> | 184 | <key>Comment</key> |
diff --git a/linden/indra/newview/llselectmgr.cpp b/linden/indra/newview/llselectmgr.cpp index 01f41ef..8064245 100644 --- a/linden/indra/newview/llselectmgr.cpp +++ b/linden/indra/newview/llselectmgr.cpp | |||
@@ -123,6 +123,7 @@ LLColor4 LLSelectMgr::sHighlightInspectColor; | |||
123 | LLColor4 LLSelectMgr::sHighlightParentColor; | 123 | LLColor4 LLSelectMgr::sHighlightParentColor; |
124 | LLColor4 LLSelectMgr::sHighlightChildColor; | 124 | LLColor4 LLSelectMgr::sHighlightChildColor; |
125 | LLColor4 LLSelectMgr::sContextSilhouetteColor; | 125 | LLColor4 LLSelectMgr::sContextSilhouetteColor; |
126 | std::set<LLUUID> LLSelectMgr::sObjectPropertiesFamilyRequests; | ||
126 | 127 | ||
127 | static LLObjectSelection *get_null_object_selection(); | 128 | static LLObjectSelection *get_null_object_selection(); |
128 | template<> | 129 | template<> |
@@ -4228,6 +4229,10 @@ void LLSelectMgr::sendListToRegions(const std::string& message_name, | |||
4228 | 4229 | ||
4229 | void LLSelectMgr::requestObjectPropertiesFamily(LLViewerObject* object) | 4230 | void LLSelectMgr::requestObjectPropertiesFamily(LLViewerObject* object) |
4230 | { | 4231 | { |
4232 | // Remember that we asked the properties of this object. | ||
4233 | sObjectPropertiesFamilyRequests.insert(object->mID); | ||
4234 | //llinfos << "Registered an ObjectPropertiesFamily request for object " << object->mID << llendl; | ||
4235 | |||
4231 | LLMessageSystem* msg = gMessageSystem; | 4236 | LLMessageSystem* msg = gMessageSystem; |
4232 | 4237 | ||
4233 | msg->newMessageFast(_PREHASH_RequestObjectPropertiesFamily); | 4238 | msg->newMessageFast(_PREHASH_RequestObjectPropertiesFamily); |
@@ -4419,6 +4424,15 @@ void LLSelectMgr::processObjectProperties(LLMessageSystem* msg, void** user_data | |||
4419 | void LLSelectMgr::processObjectPropertiesFamily(LLMessageSystem* msg, void** user_data) | 4424 | void LLSelectMgr::processObjectPropertiesFamily(LLMessageSystem* msg, void** user_data) |
4420 | { | 4425 | { |
4421 | LLUUID id; | 4426 | LLUUID id; |
4427 | msg->getUUIDFast(_PREHASH_ObjectData, _PREHASH_ObjectID, id); | ||
4428 | if (sObjectPropertiesFamilyRequests.count(id) == 0) | ||
4429 | { | ||
4430 | // This reply is not for us. | ||
4431 | return; | ||
4432 | } | ||
4433 | // We got the reply, so remove the object from the list of pending requests | ||
4434 | sObjectPropertiesFamilyRequests.erase(id); | ||
4435 | //llinfos << "Got ObjectPropertiesFamily reply for object " << id << llendl; | ||
4422 | 4436 | ||
4423 | U32 request_flags; | 4437 | U32 request_flags; |
4424 | LLUUID creator_id; | 4438 | LLUUID creator_id; |
@@ -4430,7 +4444,6 @@ void LLSelectMgr::processObjectPropertiesFamily(LLMessageSystem* msg, void** use | |||
4430 | LLCategory category; | 4444 | LLCategory category; |
4431 | 4445 | ||
4432 | msg->getU32Fast(_PREHASH_ObjectData, _PREHASH_RequestFlags, request_flags ); | 4446 | msg->getU32Fast(_PREHASH_ObjectData, _PREHASH_RequestFlags, request_flags ); |
4433 | msg->getUUIDFast(_PREHASH_ObjectData, _PREHASH_ObjectID, id ); | ||
4434 | msg->getUUIDFast(_PREHASH_ObjectData, _PREHASH_OwnerID, owner_id ); | 4447 | msg->getUUIDFast(_PREHASH_ObjectData, _PREHASH_OwnerID, owner_id ); |
4435 | msg->getUUIDFast(_PREHASH_ObjectData, _PREHASH_GroupID, group_id ); | 4448 | msg->getUUIDFast(_PREHASH_ObjectData, _PREHASH_GroupID, group_id ); |
4436 | msg->getU32Fast(_PREHASH_ObjectData, _PREHASH_BaseMask, base_mask ); | 4449 | msg->getU32Fast(_PREHASH_ObjectData, _PREHASH_BaseMask, base_mask ); |
diff --git a/linden/indra/newview/llselectmgr.h b/linden/indra/newview/llselectmgr.h index 8165394..6278049 100644 --- a/linden/indra/newview/llselectmgr.h +++ b/linden/indra/newview/llselectmgr.h | |||
@@ -719,6 +719,8 @@ private: | |||
719 | BOOL mForceSelection; | 719 | BOOL mForceSelection; |
720 | 720 | ||
721 | LLAnimPauseRequest mPauseRequest; | 721 | LLAnimPauseRequest mPauseRequest; |
722 | |||
723 | static std::set<LLUUID> sObjectPropertiesFamilyRequests; | ||
722 | }; | 724 | }; |
723 | 725 | ||
724 | // Utilities | 726 | // Utilities |
diff --git a/linden/indra/newview/llstartup.cpp b/linden/indra/newview/llstartup.cpp index baa19e7..3161980 100644 --- a/linden/indra/newview/llstartup.cpp +++ b/linden/indra/newview/llstartup.cpp | |||
@@ -187,6 +187,7 @@ | |||
187 | #include "viewerversion.h" | 187 | #include "viewerversion.h" |
188 | 188 | ||
189 | #include "jcfloater_animation_list.h" | 189 | #include "jcfloater_animation_list.h" |
190 | #include "jcfloaterareasearch.h" | ||
190 | 191 | ||
191 | #if LL_LIBXUL_ENABLED | 192 | #if LL_LIBXUL_ENABLED |
192 | #include "llmozlib.h" | 193 | #include "llmozlib.h" |
@@ -3287,6 +3288,7 @@ void pass_processObjectPropertiesFamily(LLMessageSystem *msg, void**) | |||
3287 | // send it to 'observers' | 3288 | // send it to 'observers' |
3288 | LLSelectMgr::processObjectPropertiesFamily(msg,0); | 3289 | LLSelectMgr::processObjectPropertiesFamily(msg,0); |
3289 | JCFloaterAnimList::processObjectPropertiesFamily(msg,0); | 3290 | JCFloaterAnimList::processObjectPropertiesFamily(msg,0); |
3291 | JCFloaterAreaSearch::processObjectPropertiesFamily(msg, NULL); | ||
3290 | } | 3292 | } |
3291 | 3293 | ||
3292 | void register_viewer_callbacks(LLMessageSystem* msg) | 3294 | void register_viewer_callbacks(LLMessageSystem* msg) |
diff --git a/linden/indra/newview/llviewermenu.cpp b/linden/indra/newview/llviewermenu.cpp index a95c3c6..6a7a818 100644 --- a/linden/indra/newview/llviewermenu.cpp +++ b/linden/indra/newview/llviewermenu.cpp | |||
@@ -65,6 +65,8 @@ | |||
65 | // newview includes | 65 | // newview includes |
66 | #include "llagent.h" | 66 | #include "llagent.h" |
67 | 67 | ||
68 | #include "jcfloaterareasearch.h" | ||
69 | |||
68 | #include "llagentpilot.h" | 70 | #include "llagentpilot.h" |
69 | #include "llbox.h" | 71 | #include "llbox.h" |
70 | #include "llcallingcard.h" | 72 | #include "llcallingcard.h" |
@@ -5880,6 +5882,10 @@ class LLShowFloater : public view_listener_t | |||
5880 | { | 5882 | { |
5881 | LLFloaterRegionInfo::showInstance(); | 5883 | LLFloaterRegionInfo::showInstance(); |
5882 | } | 5884 | } |
5885 | else if (floater_name == "areasearch") | ||
5886 | { | ||
5887 | JCFloaterAreaSearch::toggle(); | ||
5888 | } | ||
5883 | else if (floater_name == "grid options") | 5889 | else if (floater_name == "grid options") |
5884 | { | 5890 | { |
5885 | LLFloaterBuildOptions::show(NULL); | 5891 | LLFloaterBuildOptions::show(NULL); |
@@ -6007,6 +6013,12 @@ class LLFloaterVisible : public view_listener_t | |||
6007 | LLInventoryView* iv = LLInventoryView::getActiveInventory(); | 6013 | LLInventoryView* iv = LLInventoryView::getActiveInventory(); |
6008 | new_value = (NULL != iv && TRUE == iv->getVisible()); | 6014 | new_value = (NULL != iv && TRUE == iv->getVisible()); |
6009 | } | 6015 | } |
6016 | else if (floater_name == "areasearch") | ||
6017 | { | ||
6018 | JCFloaterAreaSearch* instn = JCFloaterAreaSearch::getInstance(); | ||
6019 | if (!instn) new_value = false; | ||
6020 | else new_value = instn->getVisible(); | ||
6021 | } | ||
6010 | gMenuHolder->findControl(control_name)->setValue(new_value); | 6022 | gMenuHolder->findControl(control_name)->setValue(new_value); |
6011 | return true; | 6023 | return true; |
6012 | } | 6024 | } |
diff --git a/linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml b/linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml index a02d033..e2c2874 100644 --- a/linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml +++ b/linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml | |||
@@ -914,7 +914,7 @@ | |||
914 | userdata="capabilities" /> | 914 | userdata="capabilities" /> |
915 | </menu_item_call> | 915 | </menu_item_call> |
916 | 916 | ||
917 | </menu> | 917 | </menu> |
918 | 918 | ||
919 | 919 | ||
920 | <menu_item_call name="Reload personal setting overrides" | 920 | <menu_item_call name="Reload personal setting overrides" |
@@ -979,6 +979,10 @@ | |||
979 | <on_click function="ShowFloater" userdata="animation list" /> | 979 | <on_click function="ShowFloater" userdata="animation list" /> |
980 | <on_check function="FloaterVisible" userdata="animation list" /> | 980 | <on_check function="FloaterVisible" userdata="animation list" /> |
981 | </menu_item_check> | 981 | </menu_item_check> |
982 | <menu_item_check label="Area Object Search" name="Area Object Search" shortcut="control|shift|A"> | ||
983 | <on_click function="ShowFloater" userdata="areasearch" /> | ||
984 | <on_check function="FloaterVisible" userdata="areasearch" /> | ||
985 | </menu_item_check> | ||
982 | <menu_item_check label="Asset Browser" name="asset browser" | 986 | <menu_item_check label="Asset Browser" name="asset browser" |
983 | shortcut="alt|shift|a"> | 987 | shortcut="alt|shift|a"> |
984 | <on_click function="Advanced.ToggleAssetBrowser" userdata="" /> | 988 | <on_click function="Advanced.ToggleAssetBrowser" userdata="" /> |