diff options
author | Armin Weatherwax | 2009-12-13 20:32:30 +0100 |
---|---|---|
committer | Armin Weatherwax | 2009-12-13 20:32:30 +0100 |
commit | 72cd31c80efd41d87ffc21141438cff66c806b3c (patch) | |
tree | c33e836871aac1db70633b92a8480b6774003b35 /linden/indra | |
parent | don't let the voice client spam about ParcelVoiceInfoRequest capability (SNOW... (diff) | |
parent | Added Imprudence VC80 .config files to the repo (diff) | |
download | meta-impy-72cd31c80efd41d87ffc21141438cff66c806b3c.zip meta-impy-72cd31c80efd41d87ffc21141438cff66c806b3c.tar.gz meta-impy-72cd31c80efd41d87ffc21141438cff66c806b3c.tar.bz2 meta-impy-72cd31c80efd41d87ffc21141438cff66c806b3c.tar.xz |
Merge branch 'next' of git://github.com/jacek/imprudence into next
Diffstat (limited to 'linden/indra')
23 files changed, 82 insertions, 26 deletions
diff --git a/linden/indra/cmake/Boost.cmake b/linden/indra/cmake/Boost.cmake index 50b8eff..a84a09f 100644 --- a/linden/indra/cmake/Boost.cmake +++ b/linden/indra/cmake/Boost.cmake | |||
@@ -16,17 +16,7 @@ else (STANDALONE) | |||
16 | 16 | ||
17 | if (WINDOWS) | 17 | if (WINDOWS) |
18 | set(BOOST_VERSION 1_36) | 18 | set(BOOST_VERSION 1_36) |
19 | if (MSVC71) | 19 | if (MSVC80) |
20 | set(BOOST_PROGRAM_OPTIONS_LIBRARY | ||
21 | optimized libboost_program_options-vc71-mt-${BOOST_VERSION} | ||
22 | debug libboost_program_options-vc71-mt-gd-${BOOST_VERSION}) | ||
23 | set(BOOST_REGEX_LIBRARY | ||
24 | optimized libboost_regex-vc71-mt-${BOOST_VERSION} | ||
25 | debug libboost_regex-vc71-mt-gd-${BOOST_VERSION}) | ||
26 | set(BOOST_SIGNALS_LIBRARY | ||
27 | optimized libboost_signals-vc71-mt-${BOOST_VERSION} | ||
28 | debug libboost_signals-vc71-mt-gd-${BOOST_VERSION}) | ||
29 | elseif (MSVC80) | ||
30 | set(BOOST_PROGRAM_OPTIONS_LIBRARY | 20 | set(BOOST_PROGRAM_OPTIONS_LIBRARY |
31 | optimized libboost_program_options-vc80-mt-${BOOST_VERSION} | 21 | optimized libboost_program_options-vc80-mt-${BOOST_VERSION} |
32 | debug libboost_program_options-vc80-mt-gd-${BOOST_VERSION}) | 22 | debug libboost_program_options-vc80-mt-gd-${BOOST_VERSION}) |
@@ -46,7 +36,7 @@ else (STANDALONE) | |||
46 | set(BOOST_SIGNALS_LIBRARY | 36 | set(BOOST_SIGNALS_LIBRARY |
47 | optimized libboost_signals-vc90-mt-${BOOST_VERSION} | 37 | optimized libboost_signals-vc90-mt-${BOOST_VERSION} |
48 | debug libboost_signals-vc90-mt-gd-${BOOST_VERSION}) | 38 | debug libboost_signals-vc90-mt-gd-${BOOST_VERSION}) |
49 | endif (MSVC71) | 39 | endif (MSVC80) |
50 | elseif (DARWIN) | 40 | elseif (DARWIN) |
51 | set(BOOST_PROGRAM_OPTIONS_LIBRARY boost_program_options-mt) | 41 | set(BOOST_PROGRAM_OPTIONS_LIBRARY boost_program_options-mt) |
52 | set(BOOST_REGEX_LIBRARY boost_regex-mt) | 42 | set(BOOST_REGEX_LIBRARY boost_regex-mt) |
diff --git a/linden/indra/cmake/CopyWinLibs.cmake b/linden/indra/cmake/CopyWinLibs.cmake index 52f000f..add94dd 100644 --- a/linden/indra/cmake/CopyWinLibs.cmake +++ b/linden/indra/cmake/CopyWinLibs.cmake | |||
@@ -1,7 +1,7 @@ | |||
1 | # -*- cmake -*- | 1 | # -*- cmake -*- |
2 | 2 | ||
3 | # The copy_win_libs folder contains file lists and a script used to | 3 | # The copy_win_libs folder contains file lists and a script used to |
4 | # copy dlls, exes and such needed to run the SecondLife from within | 4 | # copy dlls, exes and such needed to run Imprudence from within |
5 | # VisualStudio. | 5 | # VisualStudio. |
6 | 6 | ||
7 | include(CMakeCopyIfDifferent) | 7 | include(CMakeCopyIfDifferent) |
@@ -62,7 +62,6 @@ set(debug_files | |||
62 | libogg-0.dll | 62 | libogg-0.dll |
63 | liboil-0.3-0.dll | 63 | liboil-0.3-0.dll |
64 | libopenjpeg-2.dll | 64 | libopenjpeg-2.dll |
65 | libpng12-0.dll | ||
66 | libschroedinger-1.0-0.dll | 65 | libschroedinger-1.0-0.dll |
67 | libspeex-1.dll | 66 | libspeex-1.dll |
68 | libtheora-0.dll | 67 | libtheora-0.dll |
@@ -137,7 +136,6 @@ set(release_files | |||
137 | libogg-0.dll | 136 | libogg-0.dll |
138 | liboil-0.3-0.dll | 137 | liboil-0.3-0.dll |
139 | libopenjpeg-2.dll | 138 | libopenjpeg-2.dll |
140 | libpng12-0.dll | ||
141 | libschroedinger-1.0-0.dll | 139 | libschroedinger-1.0-0.dll |
142 | libspeex-1.dll | 140 | libspeex-1.dll |
143 | libtheora-0.dll | 141 | libtheora-0.dll |
@@ -198,7 +196,7 @@ if (MSVC80) | |||
198 | ARGS | 196 | ARGS |
199 | ${CMAKE_CURRENT_SOURCE_DIR}/build_win32_appConfig.py | 197 | ${CMAKE_CURRENT_SOURCE_DIR}/build_win32_appConfig.py |
200 | ${CMAKE_CURRENT_BINARY_DIR}/Debug/Microsoft.VC80.DebugCRT.manifest | 198 | ${CMAKE_CURRENT_BINARY_DIR}/Debug/Microsoft.VC80.DebugCRT.manifest |
201 | ${CMAKE_CURRENT_SOURCE_DIR}/SecondLifeDebug.exe.config | 199 | ${CMAKE_CURRENT_SOURCE_DIR}/ImprudenceDebug.exe.config |
202 | ${debug_appconfig_file} | 200 | ${debug_appconfig_file} |
203 | DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/Debug/Microsoft.VC80.DebugCRT.manifest | 201 | DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/Debug/Microsoft.VC80.DebugCRT.manifest |
204 | COMMENT "Creating debug app config file" | 202 | COMMENT "Creating debug app config file" |
@@ -243,7 +241,7 @@ if (MSVC80) | |||
243 | ARGS | 241 | ARGS |
244 | ${CMAKE_CURRENT_SOURCE_DIR}/build_win32_appConfig.py | 242 | ${CMAKE_CURRENT_SOURCE_DIR}/build_win32_appConfig.py |
245 | ${CMAKE_CURRENT_BINARY_DIR}/Release/Microsoft.VC80.CRT.manifest | 243 | ${CMAKE_CURRENT_BINARY_DIR}/Release/Microsoft.VC80.CRT.manifest |
246 | ${CMAKE_CURRENT_SOURCE_DIR}/SecondLife.exe.config | 244 | ${CMAKE_CURRENT_SOURCE_DIR}/Imprudence.exe.config |
247 | ${release_appconfig_file} | 245 | ${release_appconfig_file} |
248 | DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/Release/Microsoft.VC80.CRT.manifest | 246 | DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/Release/Microsoft.VC80.CRT.manifest |
249 | COMMENT "Creating release app config file" | 247 | COMMENT "Creating release app config file" |
@@ -256,7 +254,7 @@ if (MSVC80) | |||
256 | ARGS | 254 | ARGS |
257 | ${CMAKE_CURRENT_SOURCE_DIR}/build_win32_appConfig.py | 255 | ${CMAKE_CURRENT_SOURCE_DIR}/build_win32_appConfig.py |
258 | ${CMAKE_CURRENT_BINARY_DIR}/RelWithDebInfo/Microsoft.VC80.CRT.manifest | 256 | ${CMAKE_CURRENT_BINARY_DIR}/RelWithDebInfo/Microsoft.VC80.CRT.manifest |
259 | ${CMAKE_CURRENT_SOURCE_DIR}/SecondLife.exe.config | 257 | ${CMAKE_CURRENT_SOURCE_DIR}/Imprudence.exe.config |
260 | ${relwithdebinfo_appconfig_file} | 258 | ${relwithdebinfo_appconfig_file} |
261 | DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/RelWithDebInfo/Microsoft.VC80.CRT.manifest | 259 | DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/RelWithDebInfo/Microsoft.VC80.CRT.manifest |
262 | COMMENT "Creating relwithdebinfo app config file" | 260 | COMMENT "Creating relwithdebinfo app config file" |
diff --git a/linden/indra/cmake/Variables.cmake b/linden/indra/cmake/Variables.cmake index 8f33a95..5d4dffe 100644 --- a/linden/indra/cmake/Variables.cmake +++ b/linden/indra/cmake/Variables.cmake | |||
@@ -82,7 +82,7 @@ set(VIEWER ON CACHE BOOL "Build Second Life viewer.") | |||
82 | set(VIEWER_CHANNEL "Imprudence" CACHE STRING "Viewer Channel Name") | 82 | set(VIEWER_CHANNEL "Imprudence" CACHE STRING "Viewer Channel Name") |
83 | set(VIEWER_LOGIN_CHANNEL ${VIEWER_CHANNEL} CACHE STRING "Fake login channel for A/B Testing") | 83 | set(VIEWER_LOGIN_CHANNEL ${VIEWER_CHANNEL} CACHE STRING "Fake login channel for A/B Testing") |
84 | 84 | ||
85 | set(STANDALONE OFF CACHE BOOL "Do not use Linden-supplied prebuilt libraries.") | 85 | set(STANDALONE OFF CACHE BOOL "Do not use Imprudence-supplied prebuilt libraries.") |
86 | 86 | ||
87 | if (NOT STANDALONE AND EXISTS ${CMAKE_SOURCE_DIR}/llphysics) | 87 | if (NOT STANDALONE AND EXISTS ${CMAKE_SOURCE_DIR}/llphysics) |
88 | set(SERVER ON CACHE BOOL "Build Second Life server software.") | 88 | set(SERVER ON CACHE BOOL "Build Second Life server software.") |
diff --git a/linden/indra/cmake/ViewerArtwork.cmake b/linden/indra/cmake/ViewerArtwork.cmake new file mode 100644 index 0000000..f01109a --- /dev/null +++ b/linden/indra/cmake/ViewerArtwork.cmake | |||
@@ -0,0 +1,14 @@ | |||
1 | # -*- cmake -*- | ||
2 | # | ||
3 | # Download viewer artwork even when using standalone | ||
4 | |||
5 | include(Variables) | ||
6 | include(Prebuilt) | ||
7 | |||
8 | if (NOT STANDALONE) | ||
9 | use_prebuilt_binary(artwork) | ||
10 | else (NOT STANDALONE) | ||
11 | set(STANDALONE OFF) | ||
12 | use_prebuilt_binary(artwork) | ||
13 | set(STANDALONE ON) | ||
14 | endif (NOT STANDALONE) | ||
diff --git a/linden/indra/develop.py b/linden/indra/develop.py index 8d432fc..7e7350e 100755 --- a/linden/indra/develop.py +++ b/linden/indra/develop.py | |||
@@ -460,11 +460,16 @@ class WindowsSetup(PlatformSetup): | |||
460 | 'vc90' : { | 460 | 'vc90' : { |
461 | 'gen' : r'Visual Studio 9 2008', | 461 | 'gen' : r'Visual Studio 9 2008', |
462 | 'ver' : r'9.0' | 462 | 'ver' : r'9.0' |
463 | }, | ||
464 | 'vc100' : { | ||
465 | 'gen' : r'Visual Studio 10', | ||
466 | 'ver' : r'10.0' | ||
463 | } | 467 | } |
464 | } | 468 | } |
465 | gens['vs2003'] = gens['vc71'] | 469 | gens['vs2003'] = gens['vc71'] |
466 | gens['vs2005'] = gens['vc80'] | 470 | gens['vs2005'] = gens['vc80'] |
467 | gens['vs2008'] = gens['vc90'] | 471 | gens['vs2008'] = gens['vc90'] |
472 | gens['vs2010'] = gens['vc100'] | ||
468 | 473 | ||
469 | search_path = r'C:\windows' | 474 | search_path = r'C:\windows' |
470 | exe_suffixes = ('.exe', '.bat', '.com') | 475 | exe_suffixes = ('.exe', '.bat', '.com') |
@@ -476,14 +481,14 @@ class WindowsSetup(PlatformSetup): | |||
476 | 481 | ||
477 | def _get_generator(self): | 482 | def _get_generator(self): |
478 | if self._generator is None: | 483 | if self._generator is None: |
479 | for version in 'vc80 vc90 vc71'.split(): | 484 | for version in 'vc80 vc90 vc100 vc71'.split(): |
480 | if self.find_visual_studio(version): | 485 | if self.find_visual_studio(version): |
481 | self._generator = version | 486 | self._generator = version |
482 | print 'Building with ', self.gens[version]['gen'] | 487 | print 'Building with ', self.gens[version]['gen'] |
483 | break | 488 | break |
484 | else: | 489 | else: |
485 | print >> sys.stderr, 'Cannot find a Visual Studio installation, testing for express editions' | 490 | print >> sys.stderr, 'Cannot find a Visual Studio installation, testing for express editions' |
486 | for version in 'vc80 vc90 vc71'.split(): | 491 | for version in 'vc80 vc90 vc100 vc71'.split(): |
487 | if self.find_visual_studio_express(version): | 492 | if self.find_visual_studio_express(version): |
488 | self._generator = version | 493 | self._generator = version |
489 | print 'Building with ', self.gens[version]['gen'] , "Express edition" | 494 | print 'Building with ', self.gens[version]['gen'] , "Express edition" |
diff --git a/linden/indra/llaudio/CMakeLists.txt b/linden/indra/llaudio/CMakeLists.txt index 70041e7..0a668f9 100644 --- a/linden/indra/llaudio/CMakeLists.txt +++ b/linden/indra/llaudio/CMakeLists.txt | |||
@@ -2,6 +2,7 @@ | |||
2 | 2 | ||
3 | project(llaudio) | 3 | project(llaudio) |
4 | 4 | ||
5 | # Current starting point for CMake. Seems rather arbitrary - MC | ||
5 | include(00-Common) | 6 | include(00-Common) |
6 | include(Audio) | 7 | include(Audio) |
7 | include(OPENAL) | 8 | include(OPENAL) |
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index 197857b..cafe004 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -35,6 +35,7 @@ include(GooglePerfTools) | |||
35 | include(TemplateCheck) | 35 | include(TemplateCheck) |
36 | include(UI) | 36 | include(UI) |
37 | include(UnixInstall) | 37 | include(UnixInstall) |
38 | include(ViewerArtwork) | ||
38 | include(ViewerMiscLibs) | 39 | include(ViewerMiscLibs) |
39 | 40 | ||
40 | if (WINDOWS) | 41 | if (WINDOWS) |
@@ -976,7 +977,7 @@ if (WINDOWS) | |||
976 | res/arrowcopmulti.cur | 977 | res/arrowcopmulti.cur |
977 | res/arrowdrag.cur | 978 | res/arrowdrag.cur |
978 | res/circleandline.cur | 979 | res/circleandline.cur |
979 | res/icon1.ico | 980 | res/imp_icon.ico |
980 | res/imprudence_icon.png | 981 | res/imprudence_icon.png |
981 | res/llarrow.cur | 982 | res/llarrow.cur |
982 | res/llarrowdrag.cur | 983 | res/llarrowdrag.cur |
@@ -997,7 +998,6 @@ if (WINDOWS) | |||
997 | res/lltooltranslate.cur | 998 | res/lltooltranslate.cur |
998 | res/lltoolzoomin.cur | 999 | res/lltoolzoomin.cur |
999 | res/lltoolzoomout.cur | 1000 | res/lltoolzoomout.cur |
1000 | res/ll_icon.ico | ||
1001 | res/resource.h | 1001 | res/resource.h |
1002 | res/toolbuy.cur | 1002 | res/toolbuy.cur |
1003 | res/toolopen.cur | 1003 | res/toolopen.cur |
diff --git a/linden/indra/newview/Imprudence.exe.config b/linden/indra/newview/Imprudence.exe.config new file mode 100644 index 0000000..293a9ba --- /dev/null +++ b/linden/indra/newview/Imprudence.exe.config | |||
@@ -0,0 +1,20 @@ | |||
1 | <configuration> | ||
2 | |||
3 | <windows> | ||
4 | |||
5 | <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1"> | ||
6 | |||
7 | <dependentAssembly> | ||
8 | |||
9 | <assemblyIdentity type="win32" name="Microsoft.VC80.CRT" processorArchitecture="x86" publicKeyToken="1fc8b3b9a1e18e3b"></assemblyIdentity> | ||
10 | |||
11 | <bindingRedirect oldVersion="8.0.41204.256-" newVersion="0.0.0.0"/> | ||
12 | |||
13 | </dependentAssembly> | ||
14 | |||
15 | </assemblyBinding> | ||
16 | |||
17 | </windows> | ||
18 | |||
19 | </configuration> | ||
20 | |||
diff --git a/linden/indra/newview/ImprudenceDebug.exe.config b/linden/indra/newview/ImprudenceDebug.exe.config new file mode 100644 index 0000000..04d0e00 --- /dev/null +++ b/linden/indra/newview/ImprudenceDebug.exe.config | |||
@@ -0,0 +1,20 @@ | |||
1 | <configuration> | ||
2 | |||
3 | <windows> | ||
4 | |||
5 | <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1"> | ||
6 | |||
7 | <dependentAssembly> | ||
8 | |||
9 | <assemblyIdentity type="win32" name="Microsoft.VC80.DebugCRT" processorArchitecture="x86" publicKeyToken="1fc8b3b9a1e18e3b"></assemblyIdentity> | ||
10 | |||
11 | <bindingRedirect oldVersion="8.0.41204.256-" newVersion="0.0.0.0"/> | ||
12 | |||
13 | </dependentAssembly> | ||
14 | |||
15 | </assemblyBinding> | ||
16 | |||
17 | </windows> | ||
18 | |||
19 | </configuration> | ||
20 | |||
diff --git a/linden/indra/newview/res-sdl/imprudence_icon.BMP b/linden/indra/newview/res-sdl/imprudence_icon.BMP deleted file mode 100644 index c3f4887..0000000 --- a/linden/indra/newview/res-sdl/imprudence_icon.BMP +++ /dev/null | |||
Binary files differ | |||
diff --git a/linden/indra/newview/res/imprudence_icon.png b/linden/indra/newview/res/imprudence_icon.png deleted file mode 100644 index 8795fa7..0000000 --- a/linden/indra/newview/res/imprudence_icon.png +++ /dev/null | |||
Binary files differ | |||
diff --git a/linden/indra/newview/res/viewerRes.rc b/linden/indra/newview/res/viewerRes.rc index 5e57841..18d8d55 100644 --- a/linden/indra/newview/res/viewerRes.rc +++ b/linden/indra/newview/res/viewerRes.rc | |||
@@ -61,8 +61,8 @@ END | |||
61 | 61 | ||
62 | // Icon with lowest ID value placed first to ensure application icon | 62 | // Icon with lowest ID value placed first to ensure application icon |
63 | // remains consistent on all systems. | 63 | // remains consistent on all systems. |
64 | IDI_LL_ICON ICON "ll_icon.ico" | 64 | IDI_LL_ICON ICON "imp_icon.ico" |
65 | IDI_LCD_LL_ICON ICON "icon1.ico" | 65 | //IDI_LCD_LL_ICON ICON "icon1.ico" |
66 | 66 | ||
67 | ///////////////////////////////////////////////////////////////////////////// | 67 | ///////////////////////////////////////////////////////////////////////////// |
68 | // | 68 | // |
@@ -74,7 +74,7 @@ STYLE DS_SETFONT | DS_MODALFRAME | DS_CENTER | WS_POPUP | WS_VISIBLE | |||
74 | FONT 8, "MS Sans Serif" | 74 | FONT 8, "MS Sans Serif" |
75 | BEGIN | 75 | BEGIN |
76 | ICON IDI_LL_ICON,IDC_STATIC,7,7,20,20 | 76 | ICON IDI_LL_ICON,IDC_STATIC,7,7,20,20 |
77 | LTEXT "Loading Second Life...",666,36,13,91,8 | 77 | LTEXT "Loading Imprudence...",666,36,13,91,8 |
78 | END | 78 | END |
79 | 79 | ||
80 | 80 | ||
diff --git a/linden/indra/newview/skins/default/html/en-us/loading/imprudence_loading.png b/linden/indra/newview/skins/default/html/en-us/loading/imprudence_loading.png deleted file mode 100644 index f9ea7a2..0000000 --- a/linden/indra/newview/skins/default/html/en-us/loading/imprudence_loading.png +++ /dev/null | |||
Binary files differ | |||
diff --git a/linden/indra/newview/skins/default/textures/arrow_left.tga b/linden/indra/newview/skins/default/textures/arrow_left.tga deleted file mode 100644 index 68e6280..0000000 --- a/linden/indra/newview/skins/default/textures/arrow_left.tga +++ /dev/null | |||
Binary files differ | |||
diff --git a/linden/indra/newview/skins/default/textures/arrow_right.tga b/linden/indra/newview/skins/default/textures/arrow_right.tga deleted file mode 100644 index 7a5a30e..0000000 --- a/linden/indra/newview/skins/default/textures/arrow_right.tga +++ /dev/null | |||
Binary files differ | |||
diff --git a/linden/indra/newview/skins/default/textures/map_avatar_32.tga b/linden/indra/newview/skins/default/textures/map_avatar_32.tga deleted file mode 100644 index aebeab4..0000000 --- a/linden/indra/newview/skins/default/textures/map_avatar_32.tga +++ /dev/null | |||
Binary files differ | |||
diff --git a/linden/indra/newview/skins/default/textures/map_avatar_above_32.tga b/linden/indra/newview/skins/default/textures/map_avatar_above_32.tga deleted file mode 100644 index 65bd056..0000000 --- a/linden/indra/newview/skins/default/textures/map_avatar_above_32.tga +++ /dev/null | |||
Binary files differ | |||
diff --git a/linden/indra/newview/skins/default/textures/map_avatar_below_32.tga b/linden/indra/newview/skins/default/textures/map_avatar_below_32.tga deleted file mode 100644 index 496c44b..0000000 --- a/linden/indra/newview/skins/default/textures/map_avatar_below_32.tga +++ /dev/null | |||
Binary files differ | |||
diff --git a/linden/indra/newview/skins/default/textures/map_avatar_you_32.tga b/linden/indra/newview/skins/default/textures/map_avatar_you_32.tga deleted file mode 100644 index 782207e..0000000 --- a/linden/indra/newview/skins/default/textures/map_avatar_you_32.tga +++ /dev/null | |||
Binary files differ | |||
diff --git a/linden/indra/newview/skins/silver/textures/arrow_left.tga b/linden/indra/newview/skins/silver/textures/arrow_left.tga deleted file mode 100644 index 43fbf12..0000000 --- a/linden/indra/newview/skins/silver/textures/arrow_left.tga +++ /dev/null | |||
Binary files differ | |||
diff --git a/linden/indra/newview/skins/silver/textures/arrow_right.tga b/linden/indra/newview/skins/silver/textures/arrow_right.tga deleted file mode 100644 index a92ac9c..0000000 --- a/linden/indra/newview/skins/silver/textures/arrow_right.tga +++ /dev/null | |||
Binary files differ | |||
diff --git a/linden/indra/tools/vstool/VSTool.exe b/linden/indra/tools/vstool/VSTool.exe index 6d1497d..ac1cf44 100755 --- a/linden/indra/tools/vstool/VSTool.exe +++ b/linden/indra/tools/vstool/VSTool.exe | |||
Binary files differ | |||
diff --git a/linden/indra/tools/vstool/main.cs b/linden/indra/tools/vstool/main.cs index 5c41c91..4c33141 100644 --- a/linden/indra/tools/vstool/main.cs +++ b/linden/indra/tools/vstool/main.cs | |||
@@ -550,6 +550,10 @@ namespace VSTool | |||
550 | case "10.00": | 550 | case "10.00": |
551 | version = "VC90"; | 551 | version = "VC90"; |
552 | break; | 552 | break; |
553 | |||
554 | case "11.00": | ||
555 | version = "VC100"; | ||
556 | break; | ||
553 | default: | 557 | default: |
554 | throw new ApplicationException("Unknown .sln version: " + format); | 558 | throw new ApplicationException("Unknown .sln version: " + format); |
555 | } | 559 | } |
@@ -585,6 +589,10 @@ namespace VSTool | |||
585 | case "VC90": | 589 | case "VC90": |
586 | progid = "VisualStudio.DTE.9.0"; | 590 | progid = "VisualStudio.DTE.9.0"; |
587 | break; | 591 | break; |
592 | |||
593 | case "VC100": | ||
594 | progid = "VisualStudio.DTE.10.0"; | ||
595 | break; | ||
588 | default: | 596 | default: |
589 | throw new ApplicationException("Can't handle VS version: " + version); | 597 | throw new ApplicationException("Can't handle VS version: " + version); |
590 | } | 598 | } |