diff options
author | Jacek Antonelli | 2009-03-11 17:46:33 -0500 |
---|---|---|
committer | Jacek Antonelli | 2009-03-11 17:46:33 -0500 |
commit | 2ab904cf8765c339acca3979f6acc0ed4d5e1604 (patch) | |
tree | c323a31e76b4dbabefb29fe86f36e0a75d41d761 /linden/indra | |
parent | LLAudio's CMakeLists should include OPENAL (diff) | |
download | meta-impy-2ab904cf8765c339acca3979f6acc0ed4d5e1604.zip meta-impy-2ab904cf8765c339acca3979f6acc0ed4d5e1604.tar.gz meta-impy-2ab904cf8765c339acca3979f6acc0ed4d5e1604.tar.bz2 meta-impy-2ab904cf8765c339acca3979f6acc0ed4d5e1604.tar.xz |
Added Mac gstreamer plugins to viewer manifest
Diffstat (limited to 'linden/indra')
-rwxr-xr-x | linden/indra/newview/viewer_manifest.py | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py index 259249a..1d81ebd 100755 --- a/linden/indra/newview/viewer_manifest.py +++ b/linden/indra/newview/viewer_manifest.py | |||
@@ -473,6 +473,68 @@ class DarwinManifest(ViewerManifest): | |||
473 | self.path("Korean.lproj") | 473 | self.path("Korean.lproj") |
474 | 474 | ||
475 | 475 | ||
476 | if self.prefix(src="../../libraries/universal-darwin/lib_release/gstreamer-plugins", dst="lib/gstreamer-plugins"): | ||
477 | self.path("libgstaacparse.so") | ||
478 | self.path("libgstadder.so") | ||
479 | self.path("libgstaiffparse.so") | ||
480 | self.path("libgstamrparse.so") | ||
481 | self.path("libgstapp.so") | ||
482 | self.path("libgstaudioconvert.so") | ||
483 | self.path("libgstaudiorate.so") | ||
484 | self.path("libgstaudioresample.so") | ||
485 | self.path("libgstautodetect.so") | ||
486 | self.path("libgstavi.so") | ||
487 | self.path("libgstcoreelements.so") | ||
488 | self.path("libgstcoreindexers.so") | ||
489 | self.path("libgstdebug.so") | ||
490 | self.path("libgstdecodebin2.so") | ||
491 | self.path("libgstdeinterlace2.so") | ||
492 | self.path("libgstequalizer.so") | ||
493 | self.path("libgstffmpeg.so") | ||
494 | self.path("libgstffmpegcolorspace.so") | ||
495 | self.path("libgstffmpegscale.so") | ||
496 | self.path("libgstflac.so") | ||
497 | self.path("libgstflv.so") | ||
498 | self.path("libgstgdp.so") | ||
499 | self.path("libgsth264parse.so") | ||
500 | self.path("libgsticydemux.so") | ||
501 | self.path("libgstid3demux.so") | ||
502 | self.path("libgstinterleave.so") | ||
503 | self.path("libgstjpeg.so") | ||
504 | self.path("libgstlevel.so") | ||
505 | self.path("libgstmetadata.so") | ||
506 | self.path("libgstmpeg4videoparse.so") | ||
507 | self.path("libgstmpegdemux.so") | ||
508 | self.path("libgstmpegvideoparse.so") | ||
509 | self.path("libgstmultipart.so") | ||
510 | self.path("libgstneonhttpsrc.so") | ||
511 | self.path("libgstogg.so") | ||
512 | self.path("libgstosxaudio.so") | ||
513 | self.path("libgstosxvideosink.so") | ||
514 | self.path("libgstpango.so") | ||
515 | self.path("libgstplaybin.so") | ||
516 | self.path("libgstpng.so") | ||
517 | self.path("libgstpostproc.so") | ||
518 | self.path("libgstqtdemux.so") | ||
519 | self.path("libgstqueue2.so") | ||
520 | self.path("libgstreal.so") | ||
521 | self.path("libgstrtp.so") | ||
522 | self.path("libgstrtpmanager.so") | ||
523 | self.path("libgstrtsp.so") | ||
524 | self.path("libgstsdpelem.so") | ||
525 | self.path("libgstselector.so") | ||
526 | self.path("libgsttcp.so") | ||
527 | self.path("libgsttheora.so") | ||
528 | self.path("libgsttypefindfunctions.so") | ||
529 | self.path("libgstudp.so") | ||
530 | self.path("libgstvideoscale.so") | ||
531 | self.path("libgstvolume.so") | ||
532 | self.path("libgstvorbis.so") | ||
533 | self.path("libgstwavparse.so") | ||
534 | |||
535 | self.end_prefix("../../libraries/universal-darwin/lib_release/gstreamer-plugins") | ||
536 | |||
537 | |||
476 | # SLVoice and vivox lols | 538 | # SLVoice and vivox lols |
477 | #self.path("vivox-runtime/universal-darwin/libalut.dylib", "libalut.dylib") | 539 | #self.path("vivox-runtime/universal-darwin/libalut.dylib", "libalut.dylib") |
478 | #self.path("vivox-runtime/universal-darwin/libopenal.dylib", "libopenal.dylib") | 540 | #self.path("vivox-runtime/universal-darwin/libopenal.dylib", "libopenal.dylib") |