diff options
author | Jay Threeth | 2011-04-03 12:50:34 -0700 |
---|---|---|
committer | Jay Threeth | 2011-04-03 12:50:34 -0700 |
commit | 1d7e736cc29ffcbf994f585def6ea6a82be480ae (patch) | |
tree | 72d67b08789eca6302d8dc8e7eb5888e3b2bf747 /linden/indra | |
parent | checkpoint, non functional (diff) | |
download | meta-impy-1d7e736cc29ffcbf994f585def6ea6a82be480ae.zip meta-impy-1d7e736cc29ffcbf994f585def6ea6a82be480ae.tar.gz meta-impy-1d7e736cc29ffcbf994f585def6ea6a82be480ae.tar.bz2 meta-impy-1d7e736cc29ffcbf994f585def6ea6a82be480ae.tar.xz |
last of the hand diff merges
Diffstat (limited to '')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 48 | ||||
-rw-r--r-- | linden/indra/newview/llprefsadvanced.h | 4 |
2 files changed, 52 insertions, 0 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index f4c3755..299164d 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -42,6 +42,16 @@ if (WINDOWS) | |||
42 | include(CopyWinLibs) | 42 | include(CopyWinLibs) |
43 | endif (WINDOWS) | 43 | endif (WINDOWS) |
44 | 44 | ||
45 | # [$PLOTR$] | ||
46 | include(libgcrypt) | ||
47 | include(libgpg-error) | ||
48 | include(libotr) | ||
49 | |||
50 | if (DARWIN OR LINUX) | ||
51 | include(libotrb) | ||
52 | endif (DARWIN OR LINUX) | ||
53 | # [/$PLOTR$] | ||
54 | |||
45 | include_directories( | 55 | include_directories( |
46 | ${DBUSGLIB_INCLUDE_DIRS} | 56 | ${DBUSGLIB_INCLUDE_DIRS} |
47 | ${HUNSPELL_INCLUDE_DIR} | 57 | ${HUNSPELL_INCLUDE_DIR} |
@@ -65,6 +75,21 @@ include_directories( | |||
65 | ${LSCRIPT_INCLUDE_DIRS}/lscript_compile | 75 | ${LSCRIPT_INCLUDE_DIRS}/lscript_compile |
66 | ) | 76 | ) |
67 | 77 | ||
78 | # [$PLOTR$] | ||
79 | if (WINDOWS) | ||
80 | include_directories( | ||
81 | ../gpg.vs/inc.vs | ||
82 | ../gpg.vs/libgpg-error-1.1.vs/custom | ||
83 | ../gpg.vs/libgcrypt-1.2.2.vs/custom | ||
84 | ) | ||
85 | endif (WINDOWS) | ||
86 | include_directories( | ||
87 | ../libgpg-error/libgpg-error-1.0/src | ||
88 | ../libgcrypt/libgcrypt-1.2.2/src | ||
89 | ../libotr/libotr-3.2.0/src | ||
90 | ) | ||
91 | # [/$PLOTR$] | ||
92 | |||
68 | set(viewer_SOURCE_FILES | 93 | set(viewer_SOURCE_FILES |
69 | lggautocorrectfloater.cpp | 94 | lggautocorrectfloater.cpp |
70 | lggautocorrect.cpp | 95 | lggautocorrect.cpp |
@@ -505,6 +530,11 @@ set(viewer_SOURCE_FILES | |||
505 | wlfloaterwindlightsend.cpp | 530 | wlfloaterwindlightsend.cpp |
506 | wlretrievesettings.cpp | 531 | wlretrievesettings.cpp |
507 | wlsettingsmanager.cpp | 532 | wlsettingsmanager.cpp |
533 | # [/$PLOTR$] | ||
534 | otr_wrapper.cpp | ||
535 | otr_floater_smp_dialog.cpp | ||
536 | otr_floater_smp_progress.cpp | ||
537 | # [/$PLOTR$] | ||
508 | ) | 538 | ) |
509 | 539 | ||
510 | set(VIEWER_BINARY_NAME "meta-impy-bin" CACHE STRING | 540 | set(VIEWER_BINARY_NAME "meta-impy-bin" CACHE STRING |
@@ -976,6 +1006,11 @@ set(viewer_HEADER_FILES | |||
976 | wlfloaterwindlightsend.h | 1006 | wlfloaterwindlightsend.h |
977 | wlretrievesettings.h | 1007 | wlretrievesettings.h |
978 | wlsettingsmanager.h | 1008 | wlsettingsmanager.h |
1009 | # [$PLOTR$] | ||
1010 | otr_wrapper.h | ||
1011 | otr_floater_smp_dialog.h | ||
1012 | otr_floater_smp_progress.h | ||
1013 | # [/$PLOTR$] | ||
979 | ) | 1014 | ) |
980 | 1015 | ||
981 | source_group("CMake Rules" FILES ViewerInstall.cmake) | 1016 | source_group("CMake Rules" FILES ViewerInstall.cmake) |
@@ -1382,7 +1417,20 @@ if (WINDOWS) | |||
1382 | endif (PACKAGE) | 1417 | endif (PACKAGE) |
1383 | endif (WINDOWS) | 1418 | endif (WINDOWS) |
1384 | 1419 | ||
1420 | # [$PLOTR$] | ||
1421 | if (WINDOWS) | ||
1422 | set(otr_link_libs ${LIBGPG-ERROR_LIBRARIES} | ||
1423 | ${LIBGCRYPT_LIBRARIES} | ||
1424 | ${LIBOTR_LIBRARIES} | ||
1425 | ) | ||
1426 | else (WINDOWS) | ||
1427 | set(otr_link_libs ${OTR_LIBRARY} | ||
1428 | ) | ||
1429 | endif (WINDOWS) | ||
1430 | # [/$PLOTR$] | ||
1431 | |||
1385 | target_link_libraries(${VIEWER_BINARY_NAME} | 1432 | target_link_libraries(${VIEWER_BINARY_NAME} |
1433 | ${otr_link_libs} | ||
1386 | ${LLAUDIO_LIBRARIES} | 1434 | ${LLAUDIO_LIBRARIES} |
1387 | ${LLCHARACTER_LIBRARIES} | 1435 | ${LLCHARACTER_LIBRARIES} |
1388 | ${LLIMAGE_LIBRARIES} | 1436 | ${LLIMAGE_LIBRARIES} |
diff --git a/linden/indra/newview/llprefsadvanced.h b/linden/indra/newview/llprefsadvanced.h index 84a7854..9dfe617 100644 --- a/linden/indra/newview/llprefsadvanced.h +++ b/linden/indra/newview/llprefsadvanced.h | |||
@@ -62,6 +62,10 @@ private: | |||
62 | static void onSpellBaseComboBoxCommit(LLUICtrl* ctrl, void* userdata); | 62 | static void onSpellBaseComboBoxCommit(LLUICtrl* ctrl, void* userdata); |
63 | static void onAutoCorrectButton(void * data); | 63 | static void onAutoCorrectButton(void * data); |
64 | 64 | ||
65 | #if USE_OTR // [$PLOTR$] | ||
66 | static void onClickOtrHelp(void* data); | ||
67 | #endif // USE_OTR // [/$PLOTR$] | ||
68 | |||
65 | protected: | 69 | protected: |
66 | void initHelpBtn(const std::string& name, const std::string& xml_alert); | 70 | void initHelpBtn(const std::string& name, const std::string& xml_alert); |
67 | static void onClickHelp(void* data); | 71 | static void onClickHelp(void* data); |