aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview
diff options
context:
space:
mode:
authorJacek Antonelli2010-03-07 19:20:40 -0600
committerJacek Antonelli2010-03-13 01:29:24 -0600
commitf1756949176ee999bae594c33d8b10a9f574fb7e (patch)
tree8427940ee9e12660fbb5c07a90718982021fbfd6 /linden/indra/newview
parentFixed a possible crash related to ShowLookAt targets. (diff)
downloadmeta-impy-f1756949176ee999bae594c33d8b10a9f574fb7e.zip
meta-impy-f1756949176ee999bae594c33d8b10a9f574fb7e.tar.gz
meta-impy-f1756949176ee999bae594c33d8b10a9f574fb7e.tar.bz2
meta-impy-f1756949176ee999bae594c33d8b10a9f574fb7e.tar.xz
ChangeLog.txt is now generated from the Git log at compile time.
It is no longer version controlled and should not be editted manually. Put '@nochangelog' in commit messages to omit them from the log. See linden/scripts/make_changelog.py for more information.
Diffstat (limited to '')
-rw-r--r--linden/indra/newview/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 464bb83..514811d 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -1384,6 +1384,14 @@ check_message_template(${VIEWER_BINARY_NAME})
1384set(PACKAGE OFF CACHE BOOL 1384set(PACKAGE OFF CACHE BOOL
1385 "Add a package target that builds an installer package.") 1385 "Add a package target that builds an installer package.")
1386 1386
1387
1388add_custom_target(
1389 ChangeLog ALL
1390 COMMAND ${PYTHON_EXECUTABLE} ${SCRIPTS_DIR}/make_changelog.py
1391 COMMENT "Generating ChangeLog.txt."
1392 )
1393
1394
1387if (WINDOWS) 1395if (WINDOWS)
1388 if(MSVC71) 1396 if(MSVC71)
1389 set(release_flags "/MAP:Release/${VIEWER_BINARY_NAME}.map /MAPINFO:LINES") 1397 set(release_flags "/MAP:Release/${VIEWER_BINARY_NAME}.map /MAPINFO:LINES")