diff options
author | Armin Weatherwax | 2009-06-08 11:10:27 +0200 |
---|---|---|
committer | McCabe Maxsted | 2009-09-04 11:34:24 -0700 |
commit | 3f0082a9dda60432b8b759e09f19b495d9d5275c (patch) | |
tree | 989f5e10f9b9891ec7718b5ee2406582b6c0e352 /linden/indra/newview/llviewertexteditor.h | |
parent | Rebranded startup loading page to Imprudence (diff) | |
download | meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.zip meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.tar.gz meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.tar.bz2 meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.tar.xz |
Linux middle mouse button paste/primary selection support and gtk clipboard handler (fixes crashbug using synergy mouse-keyboard-clipboard-sharing over lan)
modified: linden/doc/contributions.txt
modified: linden/indra/llui/llclipboard.cpp
modified: linden/indra/llui/llclipboard.h
modified: linden/indra/llui/llfloater.cpp
modified: linden/indra/llui/llfloater.h
modified: linden/indra/llui/lllineeditor.cpp
modified: linden/indra/llui/lllineeditor.h
modified: linden/indra/llui/lltexteditor.cpp
modified: linden/indra/llui/lltexteditor.h
modified: linden/indra/llui/llview.cpp
modified: linden/indra/llui/llview.h
modified: linden/indra/llwindow/CMakeLists.txt
new file: linden/indra/llwindow/llmousehandler.cpp
modified: linden/indra/llwindow/llmousehandler.h
modified: linden/indra/llwindow/llwindow.cpp
modified: linden/indra/llwindow/llwindow.h
modified: linden/indra/llwindow/llwindowsdl.cpp
modified: linden/indra/llwindow/llwindowsdl.h
modified: linden/indra/newview/lltool.cpp
modified: linden/indra/newview/lltool.h
modified: linden/indra/newview/llviewertexteditor.cpp
modified: linden/indra/newview/llviewertexteditor.h
modified: linden/indra/newview/llviewerwindow.cpp
modified: linden/indra/newview/llviewerwindow.h
(cherry picked from commit 594f4830922f4294dda432fa748935adffaeed8f)
Diffstat (limited to '')
-rw-r--r-- | linden/indra/newview/llviewertexteditor.h | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/linden/indra/newview/llviewertexteditor.h b/linden/indra/newview/llviewertexteditor.h index 4cd5850..062808a 100644 --- a/linden/indra/newview/llviewertexteditor.h +++ b/linden/indra/newview/llviewertexteditor.h | |||
@@ -58,6 +58,8 @@ public: | |||
58 | // mousehandler overrides | 58 | // mousehandler overrides |
59 | virtual BOOL handleMouseDown(S32 x, S32 y, MASK mask); | 59 | virtual BOOL handleMouseDown(S32 x, S32 y, MASK mask); |
60 | virtual BOOL handleMouseUp(S32 x, S32 y, MASK mask); | 60 | virtual BOOL handleMouseUp(S32 x, S32 y, MASK mask); |
61 | virtual BOOL handleMiddleMouseDown(S32 x, S32 y, MASK mask); | ||
62 | virtual BOOL handleMiddleMouseUp(S32 x, S32 y, MASK mask); | ||
61 | virtual BOOL handleRightMouseDown(S32 x, S32 y, MASK mask); | 63 | virtual BOOL handleRightMouseDown(S32 x, S32 y, MASK mask); |
62 | virtual BOOL handleHover(S32 x, S32 y, MASK mask); | 64 | virtual BOOL handleHover(S32 x, S32 y, MASK mask); |
63 | virtual BOOL handleDoubleClick(S32 x, S32 y, MASK mask ); | 65 | virtual BOOL handleDoubleClick(S32 x, S32 y, MASK mask ); |