aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/llviewerobject.cpp
diff options
context:
space:
mode:
authorRobin Cornelius2010-10-10 21:53:54 +0100
committerRobin Cornelius2010-10-10 21:53:54 +0100
commitc0034c520c6e61b64822e276316651ec6912bd98 (patch)
tree910442027b6a2c1406d80ca93949755b54badf5c /linden/indra/newview/llviewerobject.cpp
parentUse all those cores for compile (diff)
parentThickbrick Sleaford, Soft Linden: STORM-164 make gcc-4.4 happy about llvosky.h (diff)
downloadmeta-impy-c0034c520c6e61b64822e276316651ec6912bd98.zip
meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.gz
meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.bz2
meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.xz
Merge branch 'mccabe-plugins' into plugins_merge
Conflicts: linden/doc/contributions.txt linden/indra/cmake/GStreamer.cmake linden/indra/cmake/LLMedia.cmake linden/indra/cmake/OPENAL.cmake linden/indra/llmedia/CMakeLists.txt linden/indra/llprimitive/material_codes.h linden/indra/newview/chatbar_as_cmdline.cpp linden/indra/newview/llappviewer.cpp linden/indra/newview/llfloatertos.cpp linden/indra/newview/llstartup.cpp linden/indra/newview/llviewerwindow.cpp linden/indra/newview/llvoavatar.cpp linden/indra/newview/pipeline.cpp linden/indra/newview/pipeline.h linden/indra/newview/viewer_manifest.py linden/install.xml
Diffstat (limited to '')
-rw-r--r--linden/indra/newview/llviewerobject.cpp37
1 files changed, 30 insertions, 7 deletions
diff --git a/linden/indra/newview/llviewerobject.cpp b/linden/indra/newview/llviewerobject.cpp
index cbd0472..bd5abe2 100644
--- a/linden/indra/newview/llviewerobject.cpp
+++ b/linden/indra/newview/llviewerobject.cpp
@@ -34,7 +34,7 @@
34 34
35#include "llviewerobject.h" 35#include "llviewerobject.h"
36 36
37#include "audioengine.h" 37#include "llaudioengine.h"
38#include "imageids.h" 38#include "imageids.h"
39#include "indra_constants.h" 39#include "indra_constants.h"
40#include "llmath.h" 40#include "llmath.h"
@@ -2787,6 +2787,11 @@ BOOL LLViewerObject::updateGeometry(LLDrawable *drawable)
2787 return TRUE; 2787 return TRUE;
2788} 2788}
2789 2789
2790void LLViewerObject::updateGL()
2791{
2792
2793}
2794
2790void LLViewerObject::updateFaceSize(S32 idx) 2795void LLViewerObject::updateFaceSize(S32 idx)
2791{ 2796{
2792 2797
@@ -2891,7 +2896,7 @@ F32 LLViewerObject::getMidScale() const
2891} 2896}
2892 2897
2893 2898
2894void LLViewerObject::updateTextures() 2899void LLViewerObject::updateTextures(LLAgent &agent)
2895{ 2900{
2896} 2901}
2897 2902
@@ -3736,6 +3741,7 @@ S32 LLViewerObject::setTEColor(const U8 te, const LLColor4& color)
3736 else if (color != tep->getColor()) 3741 else if (color != tep->getColor())
3737 { 3742 {
3738 retval = LLPrimitive::setTEColor(te, color); 3743 retval = LLPrimitive::setTEColor(te, color);
3744 //setChanged(TEXTURE);
3739 if (mDrawable.notNull() && retval) 3745 if (mDrawable.notNull() && retval)
3740 { 3746 {
3741 // These should only happen on updates which are not the initial update. 3747 // These should only happen on updates which are not the initial update.
@@ -3974,7 +3980,7 @@ LLViewerImage *LLViewerObject::getTEImage(const U8 face) const
3974 } 3980 }
3975 } 3981 }
3976 3982
3977 llerrs << llformat("Requested Image from invalid face: %d/%d",face,getNumTEs()) << llendl; 3983 llwarns << llformat("Requested Image from invalid face: %d/%d",face,getNumTEs()) << llendl;
3978 3984
3979 return NULL; 3985 return NULL;
3980} 3986}
@@ -4160,6 +4166,11 @@ void LLViewerObject::updateText()
4160 } 4166 }
4161} 4167}
4162 4168
4169LLVOAvatar* LLViewerObject::asAvatar()
4170{
4171 return NULL;
4172}
4173
4163BOOL LLViewerObject::isParticleSource() const 4174BOOL LLViewerObject::isParticleSource() const
4164{ 4175{
4165 return !mPartSourcep.isNull() && !mPartSourcep->isDead(); 4176 return !mPartSourcep.isNull() && !mPartSourcep->isDead();
@@ -4374,7 +4385,14 @@ void LLViewerObject::setAttachedSound(const LLUUID &audio_uuid, const LLUUID& ow
4374 gAudiop->cleanupAudioSource(mAudioSourcep); 4385 gAudiop->cleanupAudioSource(mAudioSourcep);
4375 mAudioSourcep = NULL; 4386 mAudioSourcep = NULL;
4376 } 4387 }
4377 4388/*
4389 if (mAudioSourcep && mAudioSourcep->isMuted() &&
4390 mAudioSourcep->getCurrentData() && mAudioSourcep->getCurrentData()->getID() == audio_uuid)
4391 {
4392 //llinfos << "Already having this sound as muted sound, ignoring" << llendl;
4393 return;
4394 }
4395*/
4378 getAudioSource(owner_id); 4396 getAudioSource(owner_id);
4379 4397
4380 if (mAudioSourcep) 4398 if (mAudioSourcep)
@@ -4468,7 +4486,11 @@ LLViewerObject::ExtraParameter* LLViewerObject::createNewParameterEntry(U16 para
4468 new_block = new LLSculptParams(); 4486 new_block = new LLSculptParams();
4469 break; 4487 break;
4470 } 4488 }
4471 4489 case LLNetworkData::PARAMS_LIGHT_IMAGE:
4490 {
4491 new_block = new LLLightImageParams();
4492 break;
4493 }
4472 default: 4494 default:
4473 { 4495 {
4474 llinfos << "Unknown param type." << llendl; 4496 llinfos << "Unknown param type." << llendl;
@@ -4559,7 +4581,7 @@ bool LLViewerObject::setParameterEntry(U16 param_type, const LLNetworkData& new_
4559bool LLViewerObject::setParameterEntryInUse(U16 param_type, BOOL in_use, bool local_origin) 4581bool LLViewerObject::setParameterEntryInUse(U16 param_type, BOOL in_use, bool local_origin)
4560{ 4582{
4561 ExtraParameter* param = getExtraParameterEntryCreate(param_type); 4583 ExtraParameter* param = getExtraParameterEntryCreate(param_type);
4562 if (param->in_use != in_use) 4584 if (param && param->in_use != in_use)
4563 { 4585 {
4564 param->in_use = in_use; 4586 param->in_use = in_use;
4565 parameterChanged(param_type, param->data, in_use, local_origin); 4587 parameterChanged(param_type, param->data, in_use, local_origin);
@@ -4975,7 +4997,7 @@ U32 LLViewerObject::getPartitionType() const
4975 return LLViewerRegion::PARTITION_NONE; 4997 return LLViewerRegion::PARTITION_NONE;
4976} 4998}
4977 4999
4978void LLViewerObject::dirtySpatialGroup() const 5000void LLViewerObject::dirtySpatialGroup(BOOL priority) const
4979{ 5001{
4980 if (mDrawable) 5002 if (mDrawable)
4981 { 5003 {
@@ -4983,6 +5005,7 @@ void LLViewerObject::dirtySpatialGroup() const
4983 if (group) 5005 if (group)
4984 { 5006 {
4985 group->dirtyGeom(); 5007 group->dirtyGeom();
5008 gPipeline.markRebuild(group, priority);
4986 } 5009 }
4987 } 5010 }
4988} 5011}