diff options
author | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
---|---|---|
committer | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
commit | c0034c520c6e61b64822e276316651ec6912bd98 (patch) | |
tree | 910442027b6a2c1406d80ca93949755b54badf5c /linden/indra/newview/llviewerjointmesh.cpp | |
parent | Use all those cores for compile (diff) | |
parent | Thickbrick Sleaford, Soft Linden: STORM-164 make gcc-4.4 happy about llvosky.h (diff) | |
download | meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.zip meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.gz meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.bz2 meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.xz |
Merge branch 'mccabe-plugins' into plugins_merge
Conflicts:
linden/doc/contributions.txt
linden/indra/cmake/GStreamer.cmake
linden/indra/cmake/LLMedia.cmake
linden/indra/cmake/OPENAL.cmake
linden/indra/llmedia/CMakeLists.txt
linden/indra/llprimitive/material_codes.h
linden/indra/newview/chatbar_as_cmdline.cpp
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llfloatertos.cpp
linden/indra/newview/llstartup.cpp
linden/indra/newview/llviewerwindow.cpp
linden/indra/newview/llvoavatar.cpp
linden/indra/newview/pipeline.cpp
linden/indra/newview/pipeline.h
linden/indra/newview/viewer_manifest.py
linden/install.xml
Diffstat (limited to '')
-rw-r--r-- | linden/indra/newview/llviewerjointmesh.cpp | 10 |
1 files changed, 5 insertions, 5 deletions
diff --git a/linden/indra/newview/llviewerjointmesh.cpp b/linden/indra/newview/llviewerjointmesh.cpp index b6f0daf..dc08bcd 100644 --- a/linden/indra/newview/llviewerjointmesh.cpp +++ b/linden/indra/newview/llviewerjointmesh.cpp | |||
@@ -523,9 +523,9 @@ U32 LLViewerJointMesh::drawShape( F32 pixelArea, BOOL first_pass, BOOL is_dummy) | |||
523 | //---------------------------------------------------------------- | 523 | //---------------------------------------------------------------- |
524 | if (!gRenderForSelect) | 524 | if (!gRenderForSelect) |
525 | { | 525 | { |
526 | if (is_dummy) | 526 | /* if (is_dummy) |
527 | glColor4fv(LLVOAvatar::getDummyColor().mV); | 527 | glColor4fv(LLVOAvatar::getDummyColor().mV); |
528 | else | 528 | else */ |
529 | glColor4fv(mColor.mV); | 529 | glColor4fv(mColor.mV); |
530 | } | 530 | } |
531 | 531 | ||
@@ -557,7 +557,7 @@ U32 LLViewerJointMesh::drawShape( F32 pixelArea, BOOL first_pass, BOOL is_dummy) | |||
557 | { | 557 | { |
558 | if( mLayerSet->hasComposite() ) | 558 | if( mLayerSet->hasComposite() ) |
559 | { | 559 | { |
560 | gGL.getTexUnit(0)->bind(mLayerSet->getComposite()->getTexture()); | 560 | gGL.getTexUnit(0)->bind(mLayerSet->getComposite()->getTexture(), TRUE); // KL SD |
561 | } | 561 | } |
562 | else | 562 | else |
563 | { | 563 | { |
@@ -565,7 +565,7 @@ U32 LLViewerJointMesh::drawShape( F32 pixelArea, BOOL first_pass, BOOL is_dummy) | |||
565 | // Ignore the warning if that's the case. | 565 | // Ignore the warning if that's the case. |
566 | if (!gSavedSettings.getBOOL("RenderUnloadedAvatar")) | 566 | if (!gSavedSettings.getBOOL("RenderUnloadedAvatar")) |
567 | { | 567 | { |
568 | llwarns << "Layerset without composite" << llendl; | 568 | //llwarns << "Layerset without composite" << llendl; |
569 | } | 569 | } |
570 | gGL.getTexUnit(0)->bind(gImageList.getImage(IMG_DEFAULT)); | 570 | gGL.getTexUnit(0)->bind(gImageList.getImage(IMG_DEFAULT)); |
571 | } | 571 | } |
@@ -574,7 +574,7 @@ U32 LLViewerJointMesh::drawShape( F32 pixelArea, BOOL first_pass, BOOL is_dummy) | |||
574 | if ( !is_dummy && mTexture.notNull() ) | 574 | if ( !is_dummy && mTexture.notNull() ) |
575 | { | 575 | { |
576 | old_mode = mTexture->getAddressMode(); | 576 | old_mode = mTexture->getAddressMode(); |
577 | gGL.getTexUnit(0)->bind(mTexture.get()); | 577 | gGL.getTexUnit(0)->bind(mTexture.get(), TRUE); // KL SD |
578 | gGL.getTexUnit(0)->setTextureAddressMode(LLTexUnit::TAM_CLAMP); | 578 | gGL.getTexUnit(0)->setTextureAddressMode(LLTexUnit::TAM_CLAMP); |
579 | } | 579 | } |
580 | else | 580 | else |