diff options
author | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
---|---|---|
committer | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
commit | c0034c520c6e61b64822e276316651ec6912bd98 (patch) | |
tree | 910442027b6a2c1406d80ca93949755b54badf5c /linden/indra/newview/lltoolgun.cpp | |
parent | Use all those cores for compile (diff) | |
parent | Thickbrick Sleaford, Soft Linden: STORM-164 make gcc-4.4 happy about llvosky.h (diff) | |
download | meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.zip meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.gz meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.bz2 meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.xz |
Merge branch 'mccabe-plugins' into plugins_merge
Conflicts:
linden/doc/contributions.txt
linden/indra/cmake/GStreamer.cmake
linden/indra/cmake/LLMedia.cmake
linden/indra/cmake/OPENAL.cmake
linden/indra/llmedia/CMakeLists.txt
linden/indra/llprimitive/material_codes.h
linden/indra/newview/chatbar_as_cmdline.cpp
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llfloatertos.cpp
linden/indra/newview/llstartup.cpp
linden/indra/newview/llviewerwindow.cpp
linden/indra/newview/llvoavatar.cpp
linden/indra/newview/pipeline.cpp
linden/indra/newview/pipeline.h
linden/indra/newview/viewer_manifest.py
linden/install.xml
Diffstat (limited to '')
-rw-r--r-- | linden/indra/newview/lltoolgun.cpp | 7 |
1 files changed, 5 insertions, 2 deletions
diff --git a/linden/indra/newview/lltoolgun.cpp b/linden/indra/newview/lltoolgun.cpp index d21fd49..f7af018 100644 --- a/linden/indra/newview/lltoolgun.cpp +++ b/linden/indra/newview/lltoolgun.cpp | |||
@@ -49,7 +49,8 @@ | |||
49 | #include "lltoolgrab.h" | 49 | #include "lltoolgrab.h" |
50 | 50 | ||
51 | LLToolGun::LLToolGun( LLToolComposite* composite ) | 51 | LLToolGun::LLToolGun( LLToolComposite* composite ) |
52 | : LLTool( std::string("gun"), composite ) | 52 | : LLTool( std::string("gun"), composite ), |
53 | mIsSelected(FALSE) | ||
53 | { | 54 | { |
54 | } | 55 | } |
55 | 56 | ||
@@ -58,6 +59,7 @@ void LLToolGun::handleSelect() | |||
58 | gViewerWindow->hideCursor(); | 59 | gViewerWindow->hideCursor(); |
59 | gViewerWindow->moveCursorToCenter(); | 60 | gViewerWindow->moveCursorToCenter(); |
60 | gViewerWindow->mWindow->setMouseClipping(TRUE); | 61 | gViewerWindow->mWindow->setMouseClipping(TRUE); |
62 | mIsSelected = TRUE; | ||
61 | } | 63 | } |
62 | 64 | ||
63 | void LLToolGun::handleDeselect() | 65 | void LLToolGun::handleDeselect() |
@@ -65,6 +67,7 @@ void LLToolGun::handleDeselect() | |||
65 | gViewerWindow->moveCursorToCenter(); | 67 | gViewerWindow->moveCursorToCenter(); |
66 | gViewerWindow->showCursor(); | 68 | gViewerWindow->showCursor(); |
67 | gViewerWindow->mWindow->setMouseClipping(FALSE); | 69 | gViewerWindow->mWindow->setMouseClipping(FALSE); |
70 | mIsSelected = FALSE; | ||
68 | } | 71 | } |
69 | 72 | ||
70 | BOOL LLToolGun::handleMouseDown(S32 x, S32 y, MASK mask) | 73 | BOOL LLToolGun::handleMouseDown(S32 x, S32 y, MASK mask) |
@@ -77,7 +80,7 @@ BOOL LLToolGun::handleMouseDown(S32 x, S32 y, MASK mask) | |||
77 | 80 | ||
78 | BOOL LLToolGun::handleHover(S32 x, S32 y, MASK mask) | 81 | BOOL LLToolGun::handleHover(S32 x, S32 y, MASK mask) |
79 | { | 82 | { |
80 | if( gAgent.cameraMouselook() ) | 83 | if( gAgent.cameraMouselook() && mIsSelected ) |
81 | { | 84 | { |
82 | const F32 NOMINAL_MOUSE_SENSITIVITY = 0.0025f; | 85 | const F32 NOMINAL_MOUSE_SENSITIVITY = 0.0025f; |
83 | 86 | ||