diff options
author | David Walter Seikel | 2013-08-30 21:42:45 +1000 |
---|---|---|
committer | David Walter Seikel | 2013-08-30 21:42:45 +1000 |
commit | 56a1de48ee43bfacbd3ef2859f392082a26bc814 (patch) | |
tree | 03bd6092dab42985e536b84d2f311a3a12e4edb4 /linden/indra/newview/lltoolfocus.cpp | |
parent | Added a licensing note about gpg.vs, as used to build OTR on Windows. (diff) | |
parent | Merge remote-tracking branch 'origin/next' into WL-refactor (diff) | |
download | meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.zip meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.gz meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.bz2 meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.xz |
Merge remote-tracking branch 'imprudence/next' into next
Unless otherwise stated, Imprudence changes accepted. The three images seem to be the same.
Conflicts:
.gitignore
linden/indra/develop.py
linden/indra/llcommon/llsdserialize_xml.cpp
linden/indra/newview/CMakeLists.txt
Manually combined MOAP, OTR, and WL changes from both.
linden/indra/newview/app_settings/default_grids.xml
Manually merged the grid collection.
Also updated IG info.
linden/indra/newview/hippoupdate.cpp
linden/indra/newview/llettherebelight.cpp
Just used the Imprudence copy.
linden/indra/newview/llviewermessage.cpp
Keep unbranding.
linden/indra/newview/llvoavatar.cpp
Manually merge client tags.
linden/indra/newview/res/viewerRes.rc
Manually merge version from Impy.
linden/indra/newview/skins/dark/colors_base.xml
Keep unbranding.
linden/indra/newview/skins/default/html/unabletoconnect.png
linden/indra/newview/skins/default/textures/icon_top_pick.tga
linden/indra/newview/skins/default/xui/en-us/floater_about.xml
Manual merging of contributors.
linden/indra/newview/skins/gemini/colors_base.xml
Keep unbranding.
linden/indra/newview/skins/gemini/textures/icon_top_pick.tga
linden/indra/newview/viewer_manifest.py
Manually merged boost, gstreamer, OTR, and name.
linden/indra/newview/viewerinfo.cpp
Manually merge the comment.
Diffstat (limited to '')
-rw-r--r-- | linden/indra/newview/lltoolfocus.cpp | 10 |
1 files changed, 0 insertions, 10 deletions
diff --git a/linden/indra/newview/lltoolfocus.cpp b/linden/indra/newview/lltoolfocus.cpp index ae0cd1e..c0dedb6 100644 --- a/linden/indra/newview/lltoolfocus.cpp +++ b/linden/indra/newview/lltoolfocus.cpp | |||
@@ -318,8 +318,6 @@ BOOL LLToolCamera::handleHover(S32 x, S32 y, MASK mask) | |||
318 | S32 dx = gViewerWindow->getCurrentMouseDX(); | 318 | S32 dx = gViewerWindow->getCurrentMouseDX(); |
319 | S32 dy = gViewerWindow->getCurrentMouseDY(); | 319 | S32 dy = gViewerWindow->getCurrentMouseDY(); |
320 | 320 | ||
321 | BOOL moved_outside_slop = FALSE; | ||
322 | |||
323 | if (hasMouseCapture() && mValidClickPoint) | 321 | if (hasMouseCapture() && mValidClickPoint) |
324 | { | 322 | { |
325 | mAccumX += llabs(dx); | 323 | mAccumX += llabs(dx); |
@@ -327,19 +325,11 @@ BOOL LLToolCamera::handleHover(S32 x, S32 y, MASK mask) | |||
327 | 325 | ||
328 | if (mAccumX >= SLOP_RANGE) | 326 | if (mAccumX >= SLOP_RANGE) |
329 | { | 327 | { |
330 | if (!mOutsideSlopX) | ||
331 | { | ||
332 | moved_outside_slop = TRUE; | ||
333 | } | ||
334 | mOutsideSlopX = TRUE; | 328 | mOutsideSlopX = TRUE; |
335 | } | 329 | } |
336 | 330 | ||
337 | if (mAccumY >= SLOP_RANGE) | 331 | if (mAccumY >= SLOP_RANGE) |
338 | { | 332 | { |
339 | if (!mOutsideSlopY) | ||
340 | { | ||
341 | moved_outside_slop = TRUE; | ||
342 | } | ||
343 | mOutsideSlopY = TRUE; | 333 | mOutsideSlopY = TRUE; |
344 | } | 334 | } |
345 | } | 335 | } |