aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/llpanelavatar.h
diff options
context:
space:
mode:
authorRobin Cornelius2010-10-10 21:53:54 +0100
committerRobin Cornelius2010-10-10 21:53:54 +0100
commitc0034c520c6e61b64822e276316651ec6912bd98 (patch)
tree910442027b6a2c1406d80ca93949755b54badf5c /linden/indra/newview/llpanelavatar.h
parentUse all those cores for compile (diff)
parentThickbrick Sleaford, Soft Linden: STORM-164 make gcc-4.4 happy about llvosky.h (diff)
downloadmeta-impy-c0034c520c6e61b64822e276316651ec6912bd98.zip
meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.gz
meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.bz2
meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.xz
Merge branch 'mccabe-plugins' into plugins_merge
Conflicts: linden/doc/contributions.txt linden/indra/cmake/GStreamer.cmake linden/indra/cmake/LLMedia.cmake linden/indra/cmake/OPENAL.cmake linden/indra/llmedia/CMakeLists.txt linden/indra/llprimitive/material_codes.h linden/indra/newview/chatbar_as_cmdline.cpp linden/indra/newview/llappviewer.cpp linden/indra/newview/llfloatertos.cpp linden/indra/newview/llstartup.cpp linden/indra/newview/llviewerwindow.cpp linden/indra/newview/llvoavatar.cpp linden/indra/newview/pipeline.cpp linden/indra/newview/pipeline.h linden/indra/newview/viewer_manifest.py linden/install.xml
Diffstat (limited to '')
-rw-r--r--linden/indra/newview/llpanelavatar.h16
1 files changed, 9 insertions, 7 deletions
diff --git a/linden/indra/newview/llpanelavatar.h b/linden/indra/newview/llpanelavatar.h
index 72a47f5..b687cd8 100644
--- a/linden/indra/newview/llpanelavatar.h
+++ b/linden/indra/newview/llpanelavatar.h
@@ -36,7 +36,7 @@
36#include "llpanel.h" 36#include "llpanel.h"
37#include "v3dmath.h" 37#include "v3dmath.h"
38#include "lluuid.h" 38#include "lluuid.h"
39#include "llwebbrowserctrl.h" 39#include "llmediactrl.h"
40 40
41class LLButton; 41class LLButton;
42class LLCheckBoxCtrl; 42class LLCheckBoxCtrl;
@@ -55,7 +55,7 @@ class LLViewerImage;
55class LLViewerObject; 55class LLViewerObject;
56class LLMessageSystem; 56class LLMessageSystem;
57class LLIconCtrl; 57class LLIconCtrl;
58class LLWebBrowserCtrl; 58class LLMediaCtrl;
59 59
60enum EOnlineStatus 60enum EOnlineStatus
61{ 61{
@@ -137,13 +137,15 @@ private:
137// WARNING! The order of the inheritance here matters!! Do not change. - KLW 137// WARNING! The order of the inheritance here matters!! Do not change. - KLW
138class LLPanelAvatarWeb : 138class LLPanelAvatarWeb :
139 public LLPanelAvatarTab 139 public LLPanelAvatarTab
140 , public LLWebBrowserCtrlObserver 140 , public LLViewerMediaObserver
141{ 141{
142public: 142public:
143 LLPanelAvatarWeb(const std::string& name, const LLRect& rect, LLPanelAvatar* panel_avatar); 143 LLPanelAvatarWeb(const std::string& name, const LLRect& rect, LLPanelAvatar* panel_avatar);
144 /*virtual*/ ~LLPanelAvatarWeb(); 144 /*virtual*/ ~LLPanelAvatarWeb();
145 /*virtual*/ BOOL postBuild(void); 145 /*virtual*/ BOOL postBuild(void);
146 146
147 /*virtual*/ void refresh();
148
147 void enableControls(BOOL own_avatar); 149 void enableControls(BOOL own_avatar);
148 150
149 void setWebURL(std::string url); 151 void setWebURL(std::string url);
@@ -154,13 +156,13 @@ public:
154 static void onCommitURL(LLUICtrl* ctrl, void* data); 156 static void onCommitURL(LLUICtrl* ctrl, void* data);
155 static void onClickWebProfileHelp(void *); 157 static void onClickWebProfileHelp(void *);
156 158
157 // browser observer impls 159 // inherited from LLViewerMediaObserver
158 virtual void onStatusTextChange( const EventType& eventIn ); 160 /*virtual*/ void handleMediaEvent(LLPluginClassMedia* self, EMediaEvent event);
159 virtual void onLocationChange( const EventType& eventIn );
160 161
161private: 162private:
162 std::string mHome; 163 std::string mHome;
163 LLWebBrowserCtrl* mWebBrowser; 164 std::string mNavigateTo;
165 LLMediaCtrl* mWebBrowser;
164}; 166};
165 167
166 168