diff options
author | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
---|---|---|
committer | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
commit | c0034c520c6e61b64822e276316651ec6912bd98 (patch) | |
tree | 910442027b6a2c1406d80ca93949755b54badf5c /linden/indra/newview/llfloaterpreference.cpp | |
parent | Use all those cores for compile (diff) | |
parent | Thickbrick Sleaford, Soft Linden: STORM-164 make gcc-4.4 happy about llvosky.h (diff) | |
download | meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.zip meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.gz meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.bz2 meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.xz |
Merge branch 'mccabe-plugins' into plugins_merge
Conflicts:
linden/doc/contributions.txt
linden/indra/cmake/GStreamer.cmake
linden/indra/cmake/LLMedia.cmake
linden/indra/cmake/OPENAL.cmake
linden/indra/llmedia/CMakeLists.txt
linden/indra/llprimitive/material_codes.h
linden/indra/newview/chatbar_as_cmdline.cpp
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llfloatertos.cpp
linden/indra/newview/llstartup.cpp
linden/indra/newview/llviewerwindow.cpp
linden/indra/newview/llvoavatar.cpp
linden/indra/newview/pipeline.cpp
linden/indra/newview/pipeline.h
linden/indra/newview/viewer_manifest.py
linden/install.xml
Diffstat (limited to '')
-rw-r--r-- | linden/indra/newview/llfloaterpreference.cpp | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/linden/indra/newview/llfloaterpreference.cpp b/linden/indra/newview/llfloaterpreference.cpp index 09336cb..a94f7cf 100644 --- a/linden/indra/newview/llfloaterpreference.cpp +++ b/linden/indra/newview/llfloaterpreference.cpp | |||
@@ -94,7 +94,7 @@ public: | |||
94 | // requires trusted browser | 94 | // requires trusted browser |
95 | LLPreferencesHandler() : LLCommandHandler("preferences", true) { } | 95 | LLPreferencesHandler() : LLCommandHandler("preferences", true) { } |
96 | bool handle(const LLSD& tokens, const LLSD& query_map, | 96 | bool handle(const LLSD& tokens, const LLSD& query_map, |
97 | LLWebBrowserCtrl* web) | 97 | LLMediaCtrl* web) |
98 | { | 98 | { |
99 | LLFloaterPreference::show(NULL); | 99 | LLFloaterPreference::show(NULL); |
100 | return true; | 100 | return true; |
@@ -445,7 +445,7 @@ void LLFloaterPreference::onBtnOK( void* userdata ) | |||
445 | // commit any outstanding text entry | 445 | // commit any outstanding text entry |
446 | if (fp->hasFocus()) | 446 | if (fp->hasFocus()) |
447 | { | 447 | { |
448 | LLUICtrl* cur_focus = gFocusMgr.getKeyboardFocus(); | 448 | LLUICtrl* cur_focus = dynamic_cast<LLUICtrl*>(gFocusMgr.getKeyboardFocus()); |
449 | if (cur_focus->acceptsTextInput()) | 449 | if (cur_focus->acceptsTextInput()) |
450 | { | 450 | { |
451 | cur_focus->onCommit(); | 451 | cur_focus->onCommit(); |
@@ -479,7 +479,7 @@ void LLFloaterPreference::onBtnApply( void* userdata ) | |||
479 | LLFloaterPreference *fp =(LLFloaterPreference *)userdata; | 479 | LLFloaterPreference *fp =(LLFloaterPreference *)userdata; |
480 | if (fp->hasFocus()) | 480 | if (fp->hasFocus()) |
481 | { | 481 | { |
482 | LLUICtrl* cur_focus = gFocusMgr.getKeyboardFocus(); | 482 | LLUICtrl* cur_focus = dynamic_cast<LLUICtrl*>(gFocusMgr.getKeyboardFocus()); |
483 | if (cur_focus->acceptsTextInput()) | 483 | if (cur_focus->acceptsTextInput()) |
484 | { | 484 | { |
485 | cur_focus->onCommit(); | 485 | cur_focus->onCommit(); |
@@ -505,7 +505,7 @@ void LLFloaterPreference::onBtnCancel( void* userdata ) | |||
505 | LLFloaterPreference *fp =(LLFloaterPreference *)userdata; | 505 | LLFloaterPreference *fp =(LLFloaterPreference *)userdata; |
506 | if (fp->hasFocus()) | 506 | if (fp->hasFocus()) |
507 | { | 507 | { |
508 | LLUICtrl* cur_focus = gFocusMgr.getKeyboardFocus(); | 508 | LLUICtrl* cur_focus = dynamic_cast<LLUICtrl*>(gFocusMgr.getKeyboardFocus()); |
509 | if (cur_focus->acceptsTextInput()) | 509 | if (cur_focus->acceptsTextInput()) |
510 | { | 510 | { |
511 | cur_focus->onCommit(); | 511 | cur_focus->onCommit(); |