aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorJacek Antonelli2009-09-09 11:38:26 -0500
committerJacek Antonelli2009-09-09 11:59:42 -0500
commitced5a5f6a0e7d294f9e477409387674fcecc532c (patch)
treee7500de0806009c2955bef6af7103ac60ae1e8e0 /linden/indra/newview/CMakeLists.txt
parentMerge branch 'objectbackup' into next (diff)
parentCommented out permissions button (todo: backport this if there's time) (diff)
downloadmeta-impy-ced5a5f6a0e7d294f9e477409387674fcecc532c.zip
meta-impy-ced5a5f6a0e7d294f9e477409387674fcecc532c.tar.gz
meta-impy-ced5a5f6a0e7d294f9e477409387674fcecc532c.tar.bz2
meta-impy-ced5a5f6a0e7d294f9e477409387674fcecc532c.tar.xz
Merge remote branch 'mccabe/1.2.0-next' into next
Moved "Backup" pie menu item to fit "Go Here" in top-left slot. Conflicts: linden/indra/newview/llviewermenu.cpp linden/indra/newview/skins/default/xui/en-us/menu_pie_object.xml
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r--linden/indra/newview/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index bd38476..f224652 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -61,6 +61,7 @@ include_directories(
61 ) 61 )
62 62
63set(viewer_SOURCE_FILES 63set(viewer_SOURCE_FILES
64 jcfloater_animation_list.cpp
64 llagent.cpp 65 llagent.cpp
65 llagentdata.cpp 66 llagentdata.cpp
66 llagentlanguage.cpp 67 llagentlanguage.cpp
@@ -121,6 +122,7 @@ set(viewer_SOURCE_FILES
121 llfloaterabout.cpp 122 llfloaterabout.cpp
122 llfloateractivespeakers.cpp 123 llfloateractivespeakers.cpp
123 llfloateranimpreview.cpp 124 llfloateranimpreview.cpp
125 llfloaterassetbrowser.cpp
124 llfloaterauction.cpp 126 llfloaterauction.cpp
125 llfloateravatarinfo.cpp 127 llfloateravatarinfo.cpp
126 llfloateravatarpicker.cpp 128 llfloateravatarpicker.cpp
@@ -460,6 +462,7 @@ set(viewer_HEADER_FILES
460 CMakeLists.txt 462 CMakeLists.txt
461 ViewerInstall.cmake 463 ViewerInstall.cmake
462 464
465 jcfloater_animation_list.h
463 llagent.h 466 llagent.h
464 llagentdata.h 467 llagentdata.h
465 llagentlanguage.h 468 llagentlanguage.h
@@ -522,6 +525,7 @@ set(viewer_HEADER_FILES
522 llfloaterabout.h 525 llfloaterabout.h
523 llfloateractivespeakers.h 526 llfloateractivespeakers.h
524 llfloateranimpreview.h 527 llfloateranimpreview.h
528 llfloaterassetbrowser.h
525 llfloaterauction.h 529 llfloaterauction.h
526 llfloateravatarinfo.h 530 llfloateravatarinfo.h
527 llfloateravatarpicker.h 531 llfloateravatarpicker.h
@@ -1036,7 +1040,9 @@ set(viewer_XUI_FILES
1036 skins/default/xui/en-us/floater_about_land.xml 1040 skins/default/xui/en-us/floater_about_land.xml
1037 skins/default/xui/en-us/floater_about.xml 1041 skins/default/xui/en-us/floater_about.xml
1038 skins/default/xui/en-us/floater_active_speakers.xml 1042 skins/default/xui/en-us/floater_active_speakers.xml
1043 skins/default/xui/en-us/floater_animation_list.xml
1039 skins/default/xui/en-us/floater_animation_preview.xml 1044 skins/default/xui/en-us/floater_animation_preview.xml
1045 skins/default/xui/en-us/floater_asset_browser.xml
1040 skins/default/xui/en-us/floater_auction.xml 1046 skins/default/xui/en-us/floater_auction.xml
1041 skins/default/xui/en-us/floater_audio_volume.xml 1047 skins/default/xui/en-us/floater_audio_volume.xml
1042 skins/default/xui/en-us/floater_avatar_picker.xml 1048 skins/default/xui/en-us/floater_avatar_picker.xml
@@ -1398,6 +1404,7 @@ if (WINDOWS)
1398endif (WINDOWS) 1404endif (WINDOWS)
1399 1405
1400target_link_libraries(${VIEWER_BINARY_NAME} 1406target_link_libraries(${VIEWER_BINARY_NAME}
1407 ${NDOF_LIBRARY}
1401 ${LLAUDIO_LIBRARIES} 1408 ${LLAUDIO_LIBRARIES}
1402 ${LLCHARACTER_LIBRARIES} 1409 ${LLCHARACTER_LIBRARIES}
1403 ${LLIMAGE_LIBRARIES} 1410 ${LLIMAGE_LIBRARIES}
@@ -1427,7 +1434,6 @@ target_link_libraries(${VIEWER_BINARY_NAME}
1427 ${SDL_LIBRARY} 1434 ${SDL_LIBRARY}
1428 ${SMARTHEAP_LIBRARY} 1435 ${SMARTHEAP_LIBRARY}
1429 ${UI_LIBRARIES} 1436 ${UI_LIBRARIES}
1430 ${NDOF_LIBRARY}
1431 ${WINDOWS_LIBRARIES} 1437 ${WINDOWS_LIBRARIES}
1432 ${XMLRPCEPI_LIBRARIES} 1438 ${XMLRPCEPI_LIBRARIES}
1433 ${ELFIO_LIBRARIES} 1439 ${ELFIO_LIBRARIES}