diff options
author | Jacek Antonelli | 2008-11-19 12:51:29 -0600 |
---|---|---|
committer | Jacek Antonelli | 2008-11-19 16:55:13 -0600 |
commit | 97e6c15e935666c1b295b7508a182d0da4b481f1 (patch) | |
tree | ef1d5e6a33a71b51a3deadb6de54a67b6a8c7f5e /linden/indra/newview/CMakeLists.txt | |
parent | Changed to Imprudence.exec_marker to match llappviewer.cpp. (diff) | |
download | meta-impy-97e6c15e935666c1b295b7508a182d0da4b481f1.zip meta-impy-97e6c15e935666c1b295b7508a182d0da4b481f1.tar.gz meta-impy-97e6c15e935666c1b295b7508a182d0da4b481f1.tar.bz2 meta-impy-97e6c15e935666c1b295b7508a182d0da4b481f1.tar.xz |
VWR-2662: OpenAL support (patch by Tofu Linden)
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 7 |
1 files changed, 7 insertions, 0 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index ddf6897..4bfbf02 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -8,6 +8,7 @@ include(BuildVersion) | |||
8 | include(DirectX) | 8 | include(DirectX) |
9 | include(ELFIO) | 9 | include(ELFIO) |
10 | include(FMOD) | 10 | include(FMOD) |
11 | include(OPENAL) | ||
11 | include(FindOpenGL) | 12 | include(FindOpenGL) |
12 | include(LLAudio) | 13 | include(LLAudio) |
13 | include(LLCharacter) | 14 | include(LLCharacter) |
@@ -56,6 +57,7 @@ include_directories( | |||
56 | ${LLXML_INCLUDE_DIRS} | 57 | ${LLXML_INCLUDE_DIRS} |
57 | ${LSCRIPT_INCLUDE_DIRS} | 58 | ${LSCRIPT_INCLUDE_DIRS} |
58 | ${LSCRIPT_INCLUDE_DIRS}/lscript_compile | 59 | ${LSCRIPT_INCLUDE_DIRS}/lscript_compile |
60 | ${GSTREAMER_INCLUDE_DIRS} | ||
59 | ) | 61 | ) |
60 | 62 | ||
61 | set(viewer_SOURCE_FILES | 63 | set(viewer_SOURCE_FILES |
@@ -1239,6 +1241,11 @@ set_source_files_properties(${viewer_CHARACTER_FILES} | |||
1239 | 1241 | ||
1240 | list(APPEND viewer_SOURCE_FILES ${viewer_CHARACTER_FILES}) | 1242 | list(APPEND viewer_SOURCE_FILES ${viewer_CHARACTER_FILES}) |
1241 | 1243 | ||
1244 | |||
1245 | if (OPENAL) | ||
1246 | set_source_files_properties(llstartup.cpp PROPERTIES COMPILE_FLAGS -DLL_OPENAL) | ||
1247 | endif (OPENAL) | ||
1248 | |||
1242 | if (FMOD) | 1249 | if (FMOD) |
1243 | set_source_files_properties(llstartup.cpp PROPERTIES COMPILE_FLAGS -DLL_FMOD) | 1250 | set_source_files_properties(llstartup.cpp PROPERTIES COMPILE_FLAGS -DLL_FMOD) |
1244 | 1251 | ||