aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Walter Seikel2011-07-19 01:15:21 +1000
committerDavid Walter Seikel2011-07-19 01:15:21 +1000
commit588a8405b45bf6266141d9c7f3f7e086d00a2012 (patch)
tree89159affe62debd70c4869256dac80cf8e45d469 /linden/indra/newview/CMakeLists.txt
parentAdd the iGrid developmnet grid. (diff)
downloadmeta-impy-588a8405b45bf6266141d9c7f3f7e086d00a2012.zip
meta-impy-588a8405b45bf6266141d9c7f3f7e086d00a2012.tar.gz
meta-impy-588a8405b45bf6266141d9c7f3f7e086d00a2012.tar.bz2
meta-impy-588a8405b45bf6266141d9c7f3f7e086d00a2012.tar.xz
Fix up gcrypt and gpg-error compiling and linking. Much cleaner now,and Windows might work again.
Diffstat (limited to '')
-rw-r--r--linden/indra/newview/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index fa306a5..84efa1e 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -93,8 +93,8 @@ if (WINDOWS)
93 ) 93 )
94endif (WINDOWS) 94endif (WINDOWS)
95include_directories( 95include_directories(
96 ../libgpg-error/libgpg-error-1.0/src 96 ${LIBGPG-ERROR_INCLUDE_DIRS}
97 ../libgcrypt/libgcrypt-1.2.2/src 97 ${LIBGCRYPT_INCLUDE_DIRS}
98 ../libotr/libotr-3.2.0/src 98 ../libotr/libotr-3.2.0/src
99) 99)
100# [/$PLOTR$] 100# [/$PLOTR$]
@@ -1074,8 +1074,8 @@ if (LINUX)
1074 if (STATIC_LIBOTR_ETC) # defined in .../linden/indra/CMakeLists.txt 1074 if (STATIC_LIBOTR_ETC) # defined in .../linden/indra/CMakeLists.txt
1075 set(viewer_LIBRARIES 1075 set(viewer_LIBRARIES
1076 Xinerama 1076 Xinerama
1077 #gpg-error 1077 ${LIBGPG-ERROR_LDBRARIES}
1078 #gcrypt # to build libotr from source and statically link in libgcrypt and libgpg-error 1078 ${LIBGCRYPT-ERROR_LDBRARIES}
1079 ) 1079 )
1080 else (STATIC_LIBOTR_ETC) # below for dynamically linked, unmodified libotr 1080 else (STATIC_LIBOTR_ETC) # below for dynamically linked, unmodified libotr
1081 set(viewer_LIBRARIES 1081 set(viewer_LIBRARIES
@@ -1446,8 +1446,6 @@ if (WINDOWS)
1446else (WINDOWS) 1446else (WINDOWS)
1447 if (STATIC_LIBOTR_ETC) 1447 if (STATIC_LIBOTR_ETC)
1448 set(otr_link_libs ${LIBOTR_LIBRARIES} 1448 set(otr_link_libs ${LIBOTR_LIBRARIES}
1449 ${LIBGCRYPT_LIBRARIES}
1450 ${LIBGPG-ERROR_LIBRARIES}
1451 ) # statically linked libotr, built from source 1449 ) # statically linked libotr, built from source
1452 else (STATIC_LIBOTR_ETC) 1450 else (STATIC_LIBOTR_ETC)
1453 set(otr_link_libs ${OTR_LIBRARY} 1451 set(otr_link_libs ${OTR_LIBRARY}