aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/mac_updater
diff options
context:
space:
mode:
authorJacek Antonelli2008-12-01 17:39:58 -0600
committerJacek Antonelli2008-12-01 17:40:06 -0600
commit7abecb48babe6a6f09bf6692ba55076546cfced9 (patch)
tree8d18a88513fb97adf32c10aae78f4be1984942db /linden/indra/mac_updater
parentSecond Life viewer sources 1.21.6 (diff)
downloadmeta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.zip
meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.tar.gz
meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.tar.bz2
meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.tar.xz
Second Life viewer sources 1.22.0-RC
Diffstat (limited to 'linden/indra/mac_updater')
-rw-r--r--linden/indra/mac_updater/CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/linden/indra/mac_updater/CMakeLists.txt b/linden/indra/mac_updater/CMakeLists.txt
index 3ac5aee..0eac76f 100644
--- a/linden/indra/mac_updater/CMakeLists.txt
+++ b/linden/indra/mac_updater/CMakeLists.txt
@@ -42,7 +42,6 @@ list(APPEND mac_updater_SOURCE_FILES ${mac_updater_HEADER_FILES})
42 42
43 43
44set(mac_updater_RESOURCE_FILES 44set(mac_updater_RESOURCE_FILES
45 Info.plist
46 AutoUpdater.nib/ 45 AutoUpdater.nib/
47 ) 46 )
48set_source_files_properties( 47set_source_files_properties(
@@ -50,19 +49,18 @@ set_source_files_properties(
50 PROPERTIES 49 PROPERTIES
51 HEADER_FILE_ONLY TRUE 50 HEADER_FILE_ONLY TRUE
52 ) 51 )
53set_source_files_properties(
54 Info.plist
55 PROPERTIES
56 MACOSX_PACKAGE_LOCATION . # will it blend? + poppy
57 )
58SOURCE_GROUP("Resources" FILES ${mac_updater_RESOURCE_FILES}) 52SOURCE_GROUP("Resources" FILES ${mac_updater_RESOURCE_FILES})
59list(APPEND mac_updater_SOURCE_FILES ${mac_updater_RESOURCE_FILES}) 53list(APPEND mac_updater_SOURCE_FILES ${mac_updater_RESOURCE_FILES})
60 54
61
62add_executable(mac-updater 55add_executable(mac-updater
63 MACOSX_BUNDLE 56 MACOSX_BUNDLE
64 ${mac_updater_SOURCE_FILES}) 57 ${mac_updater_SOURCE_FILES})
65 58
59set_target_properties(mac-updater
60 PROPERTIES
61 MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist
62 )
63
66target_link_libraries(mac-updater 64target_link_libraries(mac-updater
67 ${LLVFS_LIBRARIES} 65 ${LLVFS_LIBRARIES}
68 ${CURL_LIBRARIES} 66 ${CURL_LIBRARIES}
@@ -79,4 +77,3 @@ add_custom_command(
79 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib 77 ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib
80 ) 78 )
81 79
82