diff options
author | Jacek Antonelli | 2009-06-08 00:41:31 -0500 |
---|---|---|
committer | Jacek Antonelli | 2009-06-08 00:41:31 -0500 |
commit | 0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa (patch) | |
tree | 2c93d38e210832e737d09cff7561373d8d5453b2 /linden/indra/mac_updater/CMakeLists.txt | |
parent | Imprudence 1.1.0 released. (diff) | |
parent | Updated Imprudence to be based on SL 1.22.11. (ChangeLog Entry) (diff) | |
download | meta-impy-0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa.zip meta-impy-0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa.tar.gz meta-impy-0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa.tar.bz2 meta-impy-0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa.tar.xz |
Merge branch 'sl-base-1.22' into next
Conflicts:
linden/indra/newview/English.lproj/InfoPlist.strings
linden/indra/newview/skins/default/xui/en-us/panel_chat_bar.xml
Diffstat (limited to '')
-rw-r--r-- | linden/indra/mac_updater/CMakeLists.txt | 13 |
1 files changed, 5 insertions, 8 deletions
diff --git a/linden/indra/mac_updater/CMakeLists.txt b/linden/indra/mac_updater/CMakeLists.txt index ef87b29..0eac76f 100644 --- a/linden/indra/mac_updater/CMakeLists.txt +++ b/linden/indra/mac_updater/CMakeLists.txt | |||
@@ -42,7 +42,6 @@ list(APPEND mac_updater_SOURCE_FILES ${mac_updater_HEADER_FILES}) | |||
42 | 42 | ||
43 | 43 | ||
44 | set(mac_updater_RESOURCE_FILES | 44 | set(mac_updater_RESOURCE_FILES |
45 | Info.plist | ||
46 | AutoUpdater.nib/ | 45 | AutoUpdater.nib/ |
47 | ) | 46 | ) |
48 | set_source_files_properties( | 47 | set_source_files_properties( |
@@ -50,19 +49,18 @@ set_source_files_properties( | |||
50 | PROPERTIES | 49 | PROPERTIES |
51 | HEADER_FILE_ONLY TRUE | 50 | HEADER_FILE_ONLY TRUE |
52 | ) | 51 | ) |
53 | set_source_files_properties( | ||
54 | Info.plist | ||
55 | PROPERTIES | ||
56 | MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist | ||
57 | ) | ||
58 | SOURCE_GROUP("Resources" FILES ${mac_updater_RESOURCE_FILES}) | 52 | SOURCE_GROUP("Resources" FILES ${mac_updater_RESOURCE_FILES}) |
59 | list(APPEND mac_updater_SOURCE_FILES ${mac_updater_RESOURCE_FILES}) | 53 | list(APPEND mac_updater_SOURCE_FILES ${mac_updater_RESOURCE_FILES}) |
60 | 54 | ||
61 | |||
62 | add_executable(mac-updater | 55 | add_executable(mac-updater |
63 | MACOSX_BUNDLE | 56 | MACOSX_BUNDLE |
64 | ${mac_updater_SOURCE_FILES}) | 57 | ${mac_updater_SOURCE_FILES}) |
65 | 58 | ||
59 | set_target_properties(mac-updater | ||
60 | PROPERTIES | ||
61 | MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist | ||
62 | ) | ||
63 | |||
66 | target_link_libraries(mac-updater | 64 | target_link_libraries(mac-updater |
67 | ${LLVFS_LIBRARIES} | 65 | ${LLVFS_LIBRARIES} |
68 | ${CURL_LIBRARIES} | 66 | ${CURL_LIBRARIES} |
@@ -79,4 +77,3 @@ add_custom_command( | |||
79 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib | 77 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib |
80 | ) | 78 | ) |
81 | 79 | ||
82 | |||