aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llxml
diff options
context:
space:
mode:
authorJacek Antonelli2008-12-01 17:39:58 -0600
committerJacek Antonelli2008-12-01 17:40:06 -0600
commit7abecb48babe6a6f09bf6692ba55076546cfced9 (patch)
tree8d18a88513fb97adf32c10aae78f4be1984942db /linden/indra/llxml
parentSecond Life viewer sources 1.21.6 (diff)
downloadmeta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.zip
meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.tar.gz
meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.tar.bz2
meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.tar.xz
Second Life viewer sources 1.22.0-RC
Diffstat (limited to '')
-rw-r--r--linden/indra/llxml/CMakeLists.txt5
-rw-r--r--linden/indra/llxml/llcontrol.cpp4
2 files changed, 7 insertions, 2 deletions
diff --git a/linden/indra/llxml/CMakeLists.txt b/linden/indra/llxml/CMakeLists.txt
index d86bc0d..9febd97 100644
--- a/linden/indra/llxml/CMakeLists.txt
+++ b/linden/indra/llxml/CMakeLists.txt
@@ -34,3 +34,8 @@ set_source_files_properties(${llxml_HEADER_FILES}
34list(APPEND llxml_SOURCE_FILES ${llxml_HEADER_FILES}) 34list(APPEND llxml_SOURCE_FILES ${llxml_HEADER_FILES})
35 35
36add_library (llxml ${llxml_SOURCE_FILES}) 36add_library (llxml ${llxml_SOURCE_FILES})
37target_link_libraries(
38 llxml
39 ${BOOST_SIGNALS_LIBRARY}
40 ${EXPAT_LIBRARIES}
41 )
diff --git a/linden/indra/llxml/llcontrol.cpp b/linden/indra/llxml/llcontrol.cpp
index 8fa58e8..e7bac77 100644
--- a/linden/indra/llxml/llcontrol.cpp
+++ b/linden/indra/llxml/llcontrol.cpp
@@ -50,9 +50,9 @@
50#include "llsdserialize.h" 50#include "llsdserialize.h"
51 51
52#if LL_RELEASE_WITH_DEBUG_INFO || LL_DEBUG 52#if LL_RELEASE_WITH_DEBUG_INFO || LL_DEBUG
53#define CONTROL_ERRS LL_WARNS("ControlErrors")
54#else
55#define CONTROL_ERRS LL_ERRS("ControlErrors") 53#define CONTROL_ERRS LL_ERRS("ControlErrors")
54#else
55#define CONTROL_ERRS LL_WARNS("ControlErrors")
56#endif 56#endif
57 57
58//this defines the current version of the settings file 58//this defines the current version of the settings file