aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llxml/CMakeLists.txt
diff options
context:
space:
mode:
authorJacek Antonelli2008-09-06 18:24:57 -0500
committerJacek Antonelli2008-09-06 18:25:07 -0500
commit798d367d54a6c6379ad355bd8345fa40e31e7fe9 (patch)
tree1921f1708cd0240648c97bc02df2c2ab5f2fc41e /linden/indra/llxml/CMakeLists.txt
parentSecond Life viewer sources 1.20.15 (diff)
downloadmeta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.zip
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.gz
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.bz2
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.xz
Second Life viewer sources 1.21.0-RC
Diffstat (limited to 'linden/indra/llxml/CMakeLists.txt')
-rw-r--r--linden/indra/llxml/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/linden/indra/llxml/CMakeLists.txt b/linden/indra/llxml/CMakeLists.txt
new file mode 100644
index 0000000..d86bc0d
--- /dev/null
+++ b/linden/indra/llxml/CMakeLists.txt
@@ -0,0 +1,36 @@
1# -*- cmake -*-
2
3project(llxml)
4
5include(00-Common)
6include(LLCommon)
7include(LLMath)
8include(LLXML)
9
10include_directories(
11 ${LLCOMMON_INCLUDE_DIRS}
12 ${LLMATH_INCLUDE_DIRS}
13 )
14
15set(llxml_SOURCE_FILES
16 llcontrol.cpp
17 llxmlnode.cpp
18 llxmlparser.cpp
19 llxmltree.cpp
20 )
21
22set(llxml_HEADER_FILES
23 CMakeLists.txt
24
25 llcontrol.h
26 llxmlnode.h
27 llxmlparser.h
28 llxmltree.h
29 )
30
31set_source_files_properties(${llxml_HEADER_FILES}
32 PROPERTIES HEADER_FILE_ONLY TRUE)
33
34list(APPEND llxml_SOURCE_FILES ${llxml_HEADER_FILES})
35
36add_library (llxml ${llxml_SOURCE_FILES})