aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llwindow/llwindowsdl.h
diff options
context:
space:
mode:
authorArmin Weatherwax2009-06-08 11:10:27 +0200
committerMcCabe Maxsted2009-09-04 11:34:24 -0700
commit3f0082a9dda60432b8b759e09f19b495d9d5275c (patch)
tree989f5e10f9b9891ec7718b5ee2406582b6c0e352 /linden/indra/llwindow/llwindowsdl.h
parentRebranded startup loading page to Imprudence (diff)
downloadmeta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.zip
meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.tar.gz
meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.tar.bz2
meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.tar.xz
Linux middle mouse button paste/primary selection support and gtk clipboard handler (fixes crashbug using synergy mouse-keyboard-clipboard-sharing over lan)
modified: linden/doc/contributions.txt modified: linden/indra/llui/llclipboard.cpp modified: linden/indra/llui/llclipboard.h modified: linden/indra/llui/llfloater.cpp modified: linden/indra/llui/llfloater.h modified: linden/indra/llui/lllineeditor.cpp modified: linden/indra/llui/lllineeditor.h modified: linden/indra/llui/lltexteditor.cpp modified: linden/indra/llui/lltexteditor.h modified: linden/indra/llui/llview.cpp modified: linden/indra/llui/llview.h modified: linden/indra/llwindow/CMakeLists.txt new file: linden/indra/llwindow/llmousehandler.cpp modified: linden/indra/llwindow/llmousehandler.h modified: linden/indra/llwindow/llwindow.cpp modified: linden/indra/llwindow/llwindow.h modified: linden/indra/llwindow/llwindowsdl.cpp modified: linden/indra/llwindow/llwindowsdl.h modified: linden/indra/newview/lltool.cpp modified: linden/indra/newview/lltool.h modified: linden/indra/newview/llviewertexteditor.cpp modified: linden/indra/newview/llviewertexteditor.h modified: linden/indra/newview/llviewerwindow.cpp modified: linden/indra/newview/llviewerwindow.h (cherry picked from commit 594f4830922f4294dda432fa748935adffaeed8f)
Diffstat (limited to '')
-rw-r--r--linden/indra/llwindow/llwindowsdl.h13
1 files changed, 6 insertions, 7 deletions
diff --git a/linden/indra/llwindow/llwindowsdl.h b/linden/indra/llwindow/llwindowsdl.h
index 36baec6..54baf01 100644
--- a/linden/indra/llwindow/llwindowsdl.h
+++ b/linden/indra/llwindow/llwindowsdl.h
@@ -79,9 +79,15 @@ public:
79 /*virtual*/ void captureMouse(); 79 /*virtual*/ void captureMouse();
80 /*virtual*/ void releaseMouse(); 80 /*virtual*/ void releaseMouse();
81 /*virtual*/ void setMouseClipping( BOOL b ); 81 /*virtual*/ void setMouseClipping( BOOL b );
82
82 /*virtual*/ BOOL isClipboardTextAvailable(); 83 /*virtual*/ BOOL isClipboardTextAvailable();
83 /*virtual*/ BOOL pasteTextFromClipboard(LLWString &dst); 84 /*virtual*/ BOOL pasteTextFromClipboard(LLWString &dst);
84 /*virtual*/ BOOL copyTextToClipboard(const LLWString & src); 85 /*virtual*/ BOOL copyTextToClipboard(const LLWString & src);
86
87 /*virtual*/ BOOL isPrimaryTextAvailable();
88 /*virtual*/ BOOL pasteTextFromPrimary(LLWString &dst);
89 /*virtual*/ BOOL copyTextToPrimary(const LLWString & src);
90
85 /*virtual*/ void flashIcon(F32 seconds); 91 /*virtual*/ void flashIcon(F32 seconds);
86 /*virtual*/ F32 getGamma(); 92 /*virtual*/ F32 getGamma();
87 /*virtual*/ BOOL setGamma(const F32 gamma); // Set the gamma 93 /*virtual*/ BOOL setGamma(const F32 gamma); // Set the gamma
@@ -123,7 +129,6 @@ public:
123 // Not great that these are public, but they have to be accessible 129 // Not great that these are public, but they have to be accessible
124 // by non-class code and it's better than making them global. 130 // by non-class code and it's better than making them global.
125#if LL_X11 131#if LL_X11
126 // These are set up by the X11 clipboard initialization code
127 Window mSDL_XWindowID; 132 Window mSDL_XWindowID;
128 Display *mSDL_Display; 133 Display *mSDL_Display;
129#endif 134#endif
@@ -206,12 +211,6 @@ protected:
206 211
207#if LL_X11 212#if LL_X11
208private: 213private:
209 // more X11 clipboard stuff
210 int init_x11clipboard(void);
211 void quit_x11clipboard(void);
212 int is_empty_x11clipboard(void);
213 void put_x11clipboard(int type, int srclen, const char *src);
214 void get_x11clipboard(int type, int *dstlen, char **dst);
215 void x11_set_urgent(BOOL urgent); 214 void x11_set_urgent(BOOL urgent);
216 BOOL mFlashing; 215 BOOL mFlashing;
217 LLTimer mFlashTimer; 216 LLTimer mFlashTimer;