diff options
author | Armin Weatherwax | 2009-06-08 11:10:27 +0200 |
---|---|---|
committer | McCabe Maxsted | 2009-09-04 11:34:24 -0700 |
commit | 3f0082a9dda60432b8b759e09f19b495d9d5275c (patch) | |
tree | 989f5e10f9b9891ec7718b5ee2406582b6c0e352 /linden/indra/llwindow/llwindow.h | |
parent | Rebranded startup loading page to Imprudence (diff) | |
download | meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.zip meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.tar.gz meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.tar.bz2 meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.tar.xz |
Linux middle mouse button paste/primary selection support and gtk clipboard handler (fixes crashbug using synergy mouse-keyboard-clipboard-sharing over lan)
modified: linden/doc/contributions.txt
modified: linden/indra/llui/llclipboard.cpp
modified: linden/indra/llui/llclipboard.h
modified: linden/indra/llui/llfloater.cpp
modified: linden/indra/llui/llfloater.h
modified: linden/indra/llui/lllineeditor.cpp
modified: linden/indra/llui/lllineeditor.h
modified: linden/indra/llui/lltexteditor.cpp
modified: linden/indra/llui/lltexteditor.h
modified: linden/indra/llui/llview.cpp
modified: linden/indra/llui/llview.h
modified: linden/indra/llwindow/CMakeLists.txt
new file: linden/indra/llwindow/llmousehandler.cpp
modified: linden/indra/llwindow/llmousehandler.h
modified: linden/indra/llwindow/llwindow.cpp
modified: linden/indra/llwindow/llwindow.h
modified: linden/indra/llwindow/llwindowsdl.cpp
modified: linden/indra/llwindow/llwindowsdl.h
modified: linden/indra/newview/lltool.cpp
modified: linden/indra/newview/lltool.h
modified: linden/indra/newview/llviewertexteditor.cpp
modified: linden/indra/newview/llviewertexteditor.h
modified: linden/indra/newview/llviewerwindow.cpp
modified: linden/indra/newview/llviewerwindow.h
(cherry picked from commit 594f4830922f4294dda432fa748935adffaeed8f)
Diffstat (limited to '')
-rw-r--r-- | linden/indra/llwindow/llwindow.h | 6 |
1 files changed, 6 insertions, 0 deletions
diff --git a/linden/indra/llwindow/llwindow.h b/linden/indra/llwindow/llwindow.h index ffc117f..821de2f 100644 --- a/linden/indra/llwindow/llwindow.h +++ b/linden/indra/llwindow/llwindow.h | |||
@@ -184,9 +184,15 @@ public: | |||
184 | virtual void captureMouse() = 0; | 184 | virtual void captureMouse() = 0; |
185 | virtual void releaseMouse() = 0; | 185 | virtual void releaseMouse() = 0; |
186 | virtual void setMouseClipping( BOOL b ) = 0; | 186 | virtual void setMouseClipping( BOOL b ) = 0; |
187 | |||
187 | virtual BOOL isClipboardTextAvailable() = 0; | 188 | virtual BOOL isClipboardTextAvailable() = 0; |
188 | virtual BOOL pasteTextFromClipboard(LLWString &dst) = 0; | 189 | virtual BOOL pasteTextFromClipboard(LLWString &dst) = 0; |
189 | virtual BOOL copyTextToClipboard(const LLWString &src) = 0; | 190 | virtual BOOL copyTextToClipboard(const LLWString &src) = 0; |
191 | |||
192 | virtual BOOL isPrimaryTextAvailable(); | ||
193 | virtual BOOL pasteTextFromPrimary(LLWString &dst); | ||
194 | virtual BOOL copyTextToPrimary(const LLWString &src); | ||
195 | |||
190 | virtual void flashIcon(F32 seconds) = 0; | 196 | virtual void flashIcon(F32 seconds) = 0; |
191 | virtual F32 getGamma() = 0; | 197 | virtual F32 getGamma() = 0; |
192 | virtual BOOL setGamma(const F32 gamma) = 0; // Set the gamma | 198 | virtual BOOL setGamma(const F32 gamma) = 0; // Set the gamma |