diff options
author | Armin Weatherwax | 2009-06-08 11:10:27 +0200 |
---|---|---|
committer | McCabe Maxsted | 2009-09-04 11:34:24 -0700 |
commit | 3f0082a9dda60432b8b759e09f19b495d9d5275c (patch) | |
tree | 989f5e10f9b9891ec7718b5ee2406582b6c0e352 /linden/indra/llwindow/llmousehandler.h | |
parent | Rebranded startup loading page to Imprudence (diff) | |
download | meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.zip meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.tar.gz meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.tar.bz2 meta-impy-3f0082a9dda60432b8b759e09f19b495d9d5275c.tar.xz |
Linux middle mouse button paste/primary selection support and gtk clipboard handler (fixes crashbug using synergy mouse-keyboard-clipboard-sharing over lan)
modified: linden/doc/contributions.txt
modified: linden/indra/llui/llclipboard.cpp
modified: linden/indra/llui/llclipboard.h
modified: linden/indra/llui/llfloater.cpp
modified: linden/indra/llui/llfloater.h
modified: linden/indra/llui/lllineeditor.cpp
modified: linden/indra/llui/lllineeditor.h
modified: linden/indra/llui/lltexteditor.cpp
modified: linden/indra/llui/lltexteditor.h
modified: linden/indra/llui/llview.cpp
modified: linden/indra/llui/llview.h
modified: linden/indra/llwindow/CMakeLists.txt
new file: linden/indra/llwindow/llmousehandler.cpp
modified: linden/indra/llwindow/llmousehandler.h
modified: linden/indra/llwindow/llwindow.cpp
modified: linden/indra/llwindow/llwindow.h
modified: linden/indra/llwindow/llwindowsdl.cpp
modified: linden/indra/llwindow/llwindowsdl.h
modified: linden/indra/newview/lltool.cpp
modified: linden/indra/newview/lltool.h
modified: linden/indra/newview/llviewertexteditor.cpp
modified: linden/indra/newview/llviewertexteditor.h
modified: linden/indra/newview/llviewerwindow.cpp
modified: linden/indra/newview/llviewerwindow.h
(cherry picked from commit 594f4830922f4294dda432fa748935adffaeed8f)
Diffstat (limited to '')
-rw-r--r-- | linden/indra/llwindow/llmousehandler.h | 21 |
1 files changed, 16 insertions, 5 deletions
diff --git a/linden/indra/llwindow/llmousehandler.h b/linden/indra/llwindow/llmousehandler.h index dba1fc1..45f837b 100644 --- a/linden/indra/llwindow/llmousehandler.h +++ b/linden/indra/llwindow/llmousehandler.h | |||
@@ -32,9 +32,10 @@ | |||
32 | #ifndef LL_MOUSEHANDLER_H | 32 | #ifndef LL_MOUSEHANDLER_H |
33 | #define LL_MOUSEHANDLER_H | 33 | #define LL_MOUSEHANDLER_H |
34 | 34 | ||
35 | #include "llstring.h" | 35 | #include "linden_common.h" |
36 | #include "llrect.h" | ||
36 | 37 | ||
37 | // Abstract interface. | 38 | // Mostly-abstract interface. |
38 | // Intended for use via multiple inheritance. | 39 | // Intended for use via multiple inheritance. |
39 | // A class may have as many interfaces as it likes, but never needs to inherit one more than once. | 40 | // A class may have as many interfaces as it likes, but never needs to inherit one more than once. |
40 | 41 | ||
@@ -48,13 +49,23 @@ public: | |||
48 | SHOW_IF_NOT_BLOCKED, | 49 | SHOW_IF_NOT_BLOCKED, |
49 | SHOW_ALWAYS, | 50 | SHOW_ALWAYS, |
50 | } EShowToolTip; | 51 | } EShowToolTip; |
52 | typedef enum { | ||
53 | CLICK_LEFT, | ||
54 | CLICK_MIDDLE, | ||
55 | CLICK_RIGHT, | ||
56 | CLICK_DOUBLELEFT | ||
57 | } EClickType; | ||
58 | virtual BOOL handleAnyMouseClick(S32 x, S32 y, MASK mask, EClickType clicktype, BOOL down); | ||
51 | virtual BOOL handleMouseDown(S32 x, S32 y, MASK mask) = 0; | 59 | virtual BOOL handleMouseDown(S32 x, S32 y, MASK mask) = 0; |
52 | virtual BOOL handleMouseUp(S32 x, S32 y, MASK mask) = 0; | 60 | virtual BOOL handleMouseUp(S32 x, S32 y, MASK mask) = 0; |
53 | virtual BOOL handleHover(S32 x, S32 y, MASK mask) = 0; | 61 | virtual BOOL handleMiddleMouseDown(S32 x, S32 y, MASK mask) = 0; |
54 | virtual BOOL handleScrollWheel(S32 x, S32 y, S32 clicks) = 0; | 62 | virtual BOOL handleMiddleMouseUp(S32 x, S32 y, MASK mask) = 0; |
55 | virtual BOOL handleDoubleClick(S32 x, S32 y, MASK mask) = 0; | ||
56 | virtual BOOL handleRightMouseDown(S32 x, S32 y, MASK mask) = 0; | 63 | virtual BOOL handleRightMouseDown(S32 x, S32 y, MASK mask) = 0; |
57 | virtual BOOL handleRightMouseUp(S32 x, S32 y, MASK mask) = 0; | 64 | virtual BOOL handleRightMouseUp(S32 x, S32 y, MASK mask) = 0; |
65 | virtual BOOL handleDoubleClick(S32 x, S32 y, MASK mask) = 0; | ||
66 | |||
67 | virtual BOOL handleHover(S32 x, S32 y, MASK mask) = 0; | ||
68 | virtual BOOL handleScrollWheel(S32 x, S32 y, S32 clicks) = 0; | ||
58 | virtual BOOL handleToolTip(S32 x, S32 y, std::string& msg, LLRect* sticky_rect_screen) = 0; | 69 | virtual BOOL handleToolTip(S32 x, S32 y, std::string& msg, LLRect* sticky_rect_screen) = 0; |
59 | virtual EShowToolTip getShowToolTip() { return SHOW_IF_NOT_BLOCKED; }; | 70 | virtual EShowToolTip getShowToolTip() { return SHOW_IF_NOT_BLOCKED; }; |
60 | virtual const std::string& getName() const = 0; | 71 | virtual const std::string& getName() const = 0; |