diff options
author | Jacek Antonelli | 2008-09-06 18:24:57 -0500 |
---|---|---|
committer | Jacek Antonelli | 2008-09-06 18:25:07 -0500 |
commit | 798d367d54a6c6379ad355bd8345fa40e31e7fe9 (patch) | |
tree | 1921f1708cd0240648c97bc02df2c2ab5f2fc41e /linden/indra/llui/CMakeLists.txt | |
parent | Second Life viewer sources 1.20.15 (diff) | |
download | meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.zip meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.gz meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.bz2 meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.xz |
Second Life viewer sources 1.21.0-RC
Diffstat (limited to 'linden/indra/llui/CMakeLists.txt')
-rw-r--r-- | linden/indra/llui/CMakeLists.txt | 133 |
1 files changed, 133 insertions, 0 deletions
diff --git a/linden/indra/llui/CMakeLists.txt b/linden/indra/llui/CMakeLists.txt new file mode 100644 index 0000000..77efec5 --- /dev/null +++ b/linden/indra/llui/CMakeLists.txt | |||
@@ -0,0 +1,133 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | project(llui) | ||
4 | |||
5 | include(00-Common) | ||
6 | include(LLAudio) | ||
7 | include(LLCommon) | ||
8 | include(LLImage) | ||
9 | include(LLMath) | ||
10 | include(LLMessage) | ||
11 | include(LLRender) | ||
12 | include(LLWindow) | ||
13 | include(LLVFS) | ||
14 | include(LLXML) | ||
15 | |||
16 | include_directories( | ||
17 | ${LLAUDIO_INCLUDE_DIRS} | ||
18 | ${LLCOMMON_INCLUDE_DIRS} | ||
19 | ${LLIMAGE_INCLUDE_DIRS} | ||
20 | ${LLMATH_INCLUDE_DIRS} | ||
21 | ${LLMESSAGE_INCLUDE_DIRS} | ||
22 | ${LLRENDER_INCLUDE_DIRS} | ||
23 | ${LLWINDOW_INCLUDE_DIRS} | ||
24 | ${LLVFS_INCLUDE_DIRS} | ||
25 | ${LLXML_INCLUDE_DIRS} | ||
26 | ) | ||
27 | |||
28 | set(llui_SOURCE_FILES | ||
29 | llalertdialog.cpp | ||
30 | llbutton.cpp | ||
31 | llcheckboxctrl.cpp | ||
32 | llclipboard.cpp | ||
33 | llcombobox.cpp | ||
34 | llctrlselectioninterface.cpp | ||
35 | lldraghandle.cpp | ||
36 | lleditmenuhandler.cpp | ||
37 | llfloater.cpp | ||
38 | llfocusmgr.cpp | ||
39 | lliconctrl.cpp | ||
40 | llkeywords.cpp | ||
41 | lllineeditor.cpp | ||
42 | llmenugl.cpp | ||
43 | llmodaldialog.cpp | ||
44 | llmultislider.cpp | ||
45 | llmultisliderctrl.cpp | ||
46 | llpanel.cpp | ||
47 | llradiogroup.cpp | ||
48 | llresizebar.cpp | ||
49 | llresizehandle.cpp | ||
50 | llresmgr.cpp | ||
51 | llrootview.cpp | ||
52 | llscrollbar.cpp | ||
53 | llscrollcontainer.cpp | ||
54 | llscrollingpanellist.cpp | ||
55 | llscrolllistctrl.cpp | ||
56 | llslider.cpp | ||
57 | llsliderctrl.cpp | ||
58 | llspinctrl.cpp | ||
59 | llstyle.cpp | ||
60 | lltabcontainer.cpp | ||
61 | lltabcontainervertical.cpp | ||
62 | lltextbox.cpp | ||
63 | lltexteditor.cpp | ||
64 | llui.cpp | ||
65 | lluictrl.cpp | ||
66 | lluictrlfactory.cpp | ||
67 | lluistring.cpp | ||
68 | llundo.cpp | ||
69 | llviewborder.cpp | ||
70 | llview.cpp | ||
71 | llviewquery.cpp | ||
72 | ) | ||
73 | |||
74 | set(llui_HEADER_FILES | ||
75 | CMakeLists.txt | ||
76 | |||
77 | llalertdialog.h | ||
78 | llbutton.h | ||
79 | llcallbackmap.h | ||
80 | llcheckboxctrl.h | ||
81 | llclipboard.h | ||
82 | llcombobox.h | ||
83 | llctrlselectioninterface.h | ||
84 | lldraghandle.h | ||
85 | lleditmenuhandler.h | ||
86 | llfloater.h | ||
87 | llfocusmgr.h | ||
88 | llhtmlhelp.h | ||
89 | lliconctrl.h | ||
90 | llkeywords.h | ||
91 | lllineeditor.h | ||
92 | llmemberlistener.h | ||
93 | llmenugl.h | ||
94 | llmodaldialog.h | ||
95 | llmultisliderctrl.h | ||
96 | llmultislider.h | ||
97 | llpanel.h | ||
98 | llradiogroup.h | ||
99 | llresizebar.h | ||
100 | llresizehandle.h | ||
101 | llresmgr.h | ||
102 | llrootview.h | ||
103 | llscrollbar.h | ||
104 | llscrollcontainer.h | ||
105 | llscrollingpanellist.h | ||
106 | llscrolllistctrl.h | ||
107 | llsliderctrl.h | ||
108 | llslider.h | ||
109 | llspinctrl.h | ||
110 | llstyle.h | ||
111 | lltabcontainer.h | ||
112 | lltabcontainervertical.h | ||
113 | lltextbox.h | ||
114 | lltexteditor.h | ||
115 | lluiconstants.h | ||
116 | lluictrlfactory.h | ||
117 | lluictrl.h | ||
118 | lluifwd.h | ||
119 | llui.h | ||
120 | lluistring.h | ||
121 | lluixmltags.h | ||
122 | llundo.h | ||
123 | llviewborder.h | ||
124 | llview.h | ||
125 | llviewquery.h | ||
126 | ) | ||
127 | |||
128 | set_source_files_properties(${llui_HEADER_FILES} | ||
129 | PROPERTIES HEADER_FILE_ONLY TRUE) | ||
130 | |||
131 | list(APPEND llui_SOURCE_FILES ${llui_HEADER_FILES}) | ||
132 | |||
133 | add_library (llui ${llui_SOURCE_FILES}) | ||