diff options
author | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
---|---|---|
committer | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
commit | c0034c520c6e61b64822e276316651ec6912bd98 (patch) | |
tree | 910442027b6a2c1406d80ca93949755b54badf5c /linden/indra/llprimitive/llmaterialtable.cpp | |
parent | Use all those cores for compile (diff) | |
parent | Thickbrick Sleaford, Soft Linden: STORM-164 make gcc-4.4 happy about llvosky.h (diff) | |
download | meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.zip meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.gz meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.bz2 meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.xz |
Merge branch 'mccabe-plugins' into plugins_merge
Conflicts:
linden/doc/contributions.txt
linden/indra/cmake/GStreamer.cmake
linden/indra/cmake/LLMedia.cmake
linden/indra/cmake/OPENAL.cmake
linden/indra/llmedia/CMakeLists.txt
linden/indra/llprimitive/material_codes.h
linden/indra/newview/chatbar_as_cmdline.cpp
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llfloatertos.cpp
linden/indra/newview/llstartup.cpp
linden/indra/newview/llviewerwindow.cpp
linden/indra/newview/llvoavatar.cpp
linden/indra/newview/pipeline.cpp
linden/indra/newview/pipeline.h
linden/indra/newview/viewer_manifest.py
linden/install.xml
Diffstat (limited to '')
-rwxr-xr-x[-rw-r--r--] | linden/indra/llprimitive/llmaterialtable.cpp | 16 |
1 files changed, 15 insertions, 1 deletions
diff --git a/linden/indra/llprimitive/llmaterialtable.cpp b/linden/indra/llprimitive/llmaterialtable.cpp index 92eef96..7dd764e 100644..100755 --- a/linden/indra/llprimitive/llmaterialtable.cpp +++ b/linden/indra/llprimitive/llmaterialtable.cpp | |||
@@ -4,7 +4,7 @@ | |||
4 | * | 4 | * |
5 | * $LicenseInfo:firstyear=2001&license=viewergpl$ | 5 | * $LicenseInfo:firstyear=2001&license=viewergpl$ |
6 | * | 6 | * |
7 | * Copyright (c) 2001-2009, Linden Research, Inc. | 7 | * Copyright (c) 2001-2010, Linden Research, Inc. |
8 | * | 8 | * |
9 | * Second Life Viewer Source Code | 9 | * Second Life Viewer Source Code |
10 | * The source code in this file ("Source Code") is provided by Linden Lab | 10 | * The source code in this file ("Source Code") is provided by Linden Lab |
@@ -102,6 +102,9 @@ F32 const LLMaterialTable::DEFAULT_FRICTION = 0.5f; | |||
102 | F32 const LLMaterialTable::DEFAULT_RESTITUTION = 0.4f; | 102 | F32 const LLMaterialTable::DEFAULT_RESTITUTION = 0.4f; |
103 | 103 | ||
104 | LLMaterialTable::LLMaterialTable() | 104 | LLMaterialTable::LLMaterialTable() |
105 | : mCollisionSoundMatrix(NULL), | ||
106 | mSlidingSoundMatrix(NULL), | ||
107 | mRollingSoundMatrix(NULL) | ||
105 | { | 108 | { |
106 | } | 109 | } |
107 | 110 | ||
@@ -134,6 +137,17 @@ LLMaterialTable::~LLMaterialTable() | |||
134 | mMaterialInfoList.clear(); | 137 | mMaterialInfoList.clear(); |
135 | } | 138 | } |
136 | 139 | ||
140 | void LLMaterialTable::initTableTransNames(std::map<std::string, std::string> namemap) | ||
141 | { | ||
142 | for (info_list_t::iterator iter = mMaterialInfoList.begin(); | ||
143 | iter != mMaterialInfoList.end(); ++iter) | ||
144 | { | ||
145 | LLMaterialInfo *infop = *iter; | ||
146 | std::string name = infop->mName; | ||
147 | infop->mName = namemap[name]; | ||
148 | } | ||
149 | } | ||
150 | |||
137 | void LLMaterialTable::initBasicTable() | 151 | void LLMaterialTable::initBasicTable() |
138 | { | 152 | { |
139 | // *TODO: Translate | 153 | // *TODO: Translate |