diff options
author | Armin Weatherwax | 2011-05-17 09:32:59 +0200 |
---|---|---|
committer | Jacek Antonelli | 2011-05-17 17:40:34 -0500 |
commit | 37922d49b167ba282312d58628e59a60f07b01be (patch) | |
tree | 40545a71e19d825f6463640655f6a679b9a830a5 /linden/indra/llmessage/CMakeLists.txt | |
parent | fix llerrs crash "Vertex buffer destroyed while mapped!" (diff) | |
download | meta-impy-37922d49b167ba282312d58628e59a60f07b01be.zip meta-impy-37922d49b167ba282312d58628e59a60f07b01be.tar.gz meta-impy-37922d49b167ba282312d58628e59a60f07b01be.tar.bz2 meta-impy-37922d49b167ba282312d58628e59a60f07b01be.tar.xz |
also link with ld.gold
thanks to Aleric and Siana for the idea
Diffstat (limited to '')
-rw-r--r-- | linden/indra/llmessage/CMakeLists.txt | 10 |
1 files changed, 9 insertions, 1 deletions
diff --git a/linden/indra/llmessage/CMakeLists.txt b/linden/indra/llmessage/CMakeLists.txt index 0f3e159..88233b9 100644 --- a/linden/indra/llmessage/CMakeLists.txt +++ b/linden/indra/llmessage/CMakeLists.txt | |||
@@ -201,13 +201,21 @@ set_source_files_properties(${llmessage_HEADER_FILES} | |||
201 | list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES}) | 201 | list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES}) |
202 | 202 | ||
203 | add_library (llmessage ${llmessage_SOURCE_FILES}) | 203 | add_library (llmessage ${llmessage_SOURCE_FILES}) |
204 | target_link_libraries( | 204 | set (llmessage_link_LIBRARIES |
205 | llmessage | 205 | llmessage |
206 | ${CURL_LIBRARIES} | 206 | ${CURL_LIBRARIES} |
207 | ${CARES_LIBRARIES} | 207 | ${CARES_LIBRARIES} |
208 | ${OPENSSL_LIBRARIES} | 208 | ${OPENSSL_LIBRARIES} |
209 | ${CRYPTO_LIBRARIES} | 209 | ${CRYPTO_LIBRARIES} |
210 | ${XMLRPCEPI_LIBRARIES} | 210 | ${XMLRPCEPI_LIBRARIES} |
211 | ) | ||
212 | if (LINUX) | ||
213 | list(APPEND llmessage_link_LIBRARIES pthread) | ||
214 | endif (LINUX) | ||
215 | |||
216 | target_link_libraries( | ||
217 | ${llmessage_link_LIBRARIES} | ||
218 | |||
211 | ) | 219 | ) |
212 | 220 | ||
213 | IF (NOT LINUX AND VIEWER) | 221 | IF (NOT LINUX AND VIEWER) |