diff options
author | Jacek Antonelli | 2008-12-01 17:39:58 -0600 |
---|---|---|
committer | Jacek Antonelli | 2008-12-01 17:40:06 -0600 |
commit | 7abecb48babe6a6f09bf6692ba55076546cfced9 (patch) | |
tree | 8d18a88513fb97adf32c10aae78f4be1984942db /linden/indra/llmedia | |
parent | Second Life viewer sources 1.21.6 (diff) | |
download | meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.zip meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.tar.gz meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.tar.bz2 meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.tar.xz |
Second Life viewer sources 1.22.0-RC
Diffstat (limited to 'linden/indra/llmedia')
-rw-r--r-- | linden/indra/llmedia/CMakeLists.txt | 7 | ||||
-rw-r--r-- | linden/indra/llmedia/llmediaimplexample2.cpp | 2 | ||||
-rw-r--r-- | linden/indra/llmedia/llmediaimplgstreamer.cpp | 3 |
3 files changed, 11 insertions, 1 deletions
diff --git a/linden/indra/llmedia/CMakeLists.txt b/linden/indra/llmedia/CMakeLists.txt index 8ef8006..0c892f9 100644 --- a/linden/indra/llmedia/CMakeLists.txt +++ b/linden/indra/llmedia/CMakeLists.txt | |||
@@ -11,6 +11,7 @@ include(LLMedia) | |||
11 | include(LLMessage) | 11 | include(LLMessage) |
12 | include(LLWindow) | 12 | include(LLWindow) |
13 | include(Mozlib) | 13 | include(Mozlib) |
14 | include(QuickTime) | ||
14 | 15 | ||
15 | include_directories( | 16 | include_directories( |
16 | ${GSTREAMER_INCLUDE_DIRS} | 17 | ${GSTREAMER_INCLUDE_DIRS} |
@@ -92,3 +93,9 @@ set_source_files_properties(${llmedia_HEADER_FILES} | |||
92 | list(APPEND llmedia_SOURCE_FILES ${llmedia_HEADER_FILES}) | 93 | list(APPEND llmedia_SOURCE_FILES ${llmedia_HEADER_FILES}) |
93 | 94 | ||
94 | add_library (llmedia ${llmedia_SOURCE_FILES}) | 95 | add_library (llmedia ${llmedia_SOURCE_FILES}) |
96 | target_link_libraries( | ||
97 | llmedia | ||
98 | ${GSTREAMER_LIBRARIES} | ||
99 | ${GSTREAMER_PLUGINS_BASE_LIBRARIES} | ||
100 | ${QUICKTIME_LIBRARY} | ||
101 | ) | ||
diff --git a/linden/indra/llmedia/llmediaimplexample2.cpp b/linden/indra/llmedia/llmediaimplexample2.cpp index 13036f9..dc19f55 100644 --- a/linden/indra/llmedia/llmediaimplexample2.cpp +++ b/linden/indra/llmedia/llmediaimplexample2.cpp | |||
@@ -45,7 +45,7 @@ static LLMediaImplRegister sLLMediaImplExample2Reg( "LLMediaImplExample2", new L | |||
45 | LLMediaImplExample2Maker::LLMediaImplExample2Maker() | 45 | LLMediaImplExample2Maker::LLMediaImplExample2Maker() |
46 | { | 46 | { |
47 | // Register to handle the scheme | 47 | // Register to handle the scheme |
48 | mSchema.push_back( "example2" ); | 48 | mSchema.push_back( "example2." ); |
49 | } | 49 | } |
50 | 50 | ||
51 | /////////////////////////////////////////////////////////////////////////////// | 51 | /////////////////////////////////////////////////////////////////////////////// |
diff --git a/linden/indra/llmedia/llmediaimplgstreamer.cpp b/linden/indra/llmedia/llmediaimplgstreamer.cpp index 51a5bca..b1d36f0 100644 --- a/linden/indra/llmedia/llmediaimplgstreamer.cpp +++ b/linden/indra/llmedia/llmediaimplgstreamer.cpp | |||
@@ -171,6 +171,9 @@ startup ( LLMediaManagerData* init_data ) | |||
171 | static bool done_init = false; | 171 | static bool done_init = false; |
172 | if (!done_init) | 172 | if (!done_init) |
173 | { | 173 | { |
174 | // Init the glib type system - we need it. | ||
175 | g_type_init(); | ||
176 | |||
174 | // Get symbols! | 177 | // Get symbols! |
175 | if (! grab_gst_syms("libgstreamer-0.10.so.0", | 178 | if (! grab_gst_syms("libgstreamer-0.10.so.0", |
176 | "libgstvideo-0.10.so.0", | 179 | "libgstvideo-0.10.so.0", |