diff options
author | Jacek Antonelli | 2009-06-08 00:41:31 -0500 |
---|---|---|
committer | Jacek Antonelli | 2009-06-08 00:41:31 -0500 |
commit | 0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa (patch) | |
tree | 2c93d38e210832e737d09cff7561373d8d5453b2 /linden/indra/llimagej2coj | |
parent | Imprudence 1.1.0 released. (diff) | |
parent | Updated Imprudence to be based on SL 1.22.11. (ChangeLog Entry) (diff) | |
download | meta-impy-0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa.zip meta-impy-0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa.tar.gz meta-impy-0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa.tar.bz2 meta-impy-0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa.tar.xz |
Merge branch 'sl-base-1.22' into next
Conflicts:
linden/indra/newview/English.lproj/InfoPlist.strings
linden/indra/newview/skins/default/xui/en-us/panel_chat_bar.xml
Diffstat (limited to '')
-rw-r--r-- | linden/indra/llimagej2coj/CMakeLists.txt | 4 | ||||
-rw-r--r-- | linden/indra/llimagej2coj/llimagej2coj.cpp | 13 | ||||
-rw-r--r-- | linden/indra/llimagej2coj/llimagej2coj.h | 2 |
3 files changed, 17 insertions, 2 deletions
diff --git a/linden/indra/llimagej2coj/CMakeLists.txt b/linden/indra/llimagej2coj/CMakeLists.txt index ed3ff3c..97d22cf 100644 --- a/linden/indra/llimagej2coj/CMakeLists.txt +++ b/linden/indra/llimagej2coj/CMakeLists.txt | |||
@@ -29,3 +29,7 @@ set_source_files_properties(${llimagej2coj_HEADER_FILES} | |||
29 | list(APPEND llimagej2coj_SOURCE_FILES ${llimagej2coj_HEADER_FILES}) | 29 | list(APPEND llimagej2coj_SOURCE_FILES ${llimagej2coj_HEADER_FILES}) |
30 | 30 | ||
31 | add_library (llimagej2coj ${llimagej2coj_SOURCE_FILES}) | 31 | add_library (llimagej2coj ${llimagej2coj_SOURCE_FILES}) |
32 | target_link_libraries( | ||
33 | llimagej2coj | ||
34 | ${OPENJPEG_LIBRARIES} | ||
35 | ) | ||
diff --git a/linden/indra/llimagej2coj/llimagej2coj.cpp b/linden/indra/llimagej2coj/llimagej2coj.cpp index a0c61d8..ef498db 100644 --- a/linden/indra/llimagej2coj/llimagej2coj.cpp +++ b/linden/indra/llimagej2coj/llimagej2coj.cpp | |||
@@ -4,7 +4,7 @@ | |||
4 | * | 4 | * |
5 | * $LicenseInfo:firstyear=2006&license=viewergpl$ | 5 | * $LicenseInfo:firstyear=2006&license=viewergpl$ |
6 | * | 6 | * |
7 | * Copyright (c) 2006-2008, Linden Research, Inc. | 7 | * Copyright (c) 2006-2009, Linden Research, Inc. |
8 | * | 8 | * |
9 | * Second Life Viewer Source Code | 9 | * Second Life Viewer Source Code |
10 | * The source code in this file ("Source Code") is provided by Linden Lab | 10 | * The source code in this file ("Source Code") is provided by Linden Lab |
@@ -183,6 +183,17 @@ BOOL LLImageJ2COJ::decodeImpl(LLImageJ2C &base, LLImageRaw &raw_image, F32 decod | |||
183 | return TRUE; | 183 | return TRUE; |
184 | } | 184 | } |
185 | 185 | ||
186 | if(image->numcomps <= first_channel) | ||
187 | { | ||
188 | llwarns << "trying to decode more channels than are present in image: numcomps: " << image->numcomps << " first_channel: " << first_channel << llendl; | ||
189 | if (image) | ||
190 | { | ||
191 | opj_image_destroy(image); | ||
192 | } | ||
193 | |||
194 | return TRUE; | ||
195 | } | ||
196 | |||
186 | // Copy image data into our raw image format (instead of the separate channel format | 197 | // Copy image data into our raw image format (instead of the separate channel format |
187 | 198 | ||
188 | S32 img_components = image->numcomps; | 199 | S32 img_components = image->numcomps; |
diff --git a/linden/indra/llimagej2coj/llimagej2coj.h b/linden/indra/llimagej2coj/llimagej2coj.h index df061ea..05504d6 100644 --- a/linden/indra/llimagej2coj/llimagej2coj.h +++ b/linden/indra/llimagej2coj/llimagej2coj.h | |||
@@ -4,7 +4,7 @@ | |||
4 | * | 4 | * |
5 | * $LicenseInfo:firstyear=2006&license=viewergpl$ | 5 | * $LicenseInfo:firstyear=2006&license=viewergpl$ |
6 | * | 6 | * |
7 | * Copyright (c) 2006-2008, Linden Research, Inc. | 7 | * Copyright (c) 2006-2009, Linden Research, Inc. |
8 | * | 8 | * |
9 | * Second Life Viewer Source Code | 9 | * Second Life Viewer Source Code |
10 | * The source code in this file ("Source Code") is provided by Linden Lab | 10 | * The source code in this file ("Source Code") is provided by Linden Lab |