diff options
author | Jacek Antonelli | 2008-09-06 18:24:57 -0500 |
---|---|---|
committer | Jacek Antonelli | 2008-09-06 18:25:07 -0500 |
commit | 798d367d54a6c6379ad355bd8345fa40e31e7fe9 (patch) | |
tree | 1921f1708cd0240648c97bc02df2c2ab5f2fc41e /linden/indra/llimagej2coj/CMakeLists.txt | |
parent | Second Life viewer sources 1.20.15 (diff) | |
download | meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.zip meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.gz meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.bz2 meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.xz |
Second Life viewer sources 1.21.0-RC
Diffstat (limited to 'linden/indra/llimagej2coj/CMakeLists.txt')
-rw-r--r-- | linden/indra/llimagej2coj/CMakeLists.txt | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/linden/indra/llimagej2coj/CMakeLists.txt b/linden/indra/llimagej2coj/CMakeLists.txt new file mode 100644 index 0000000..ed3ff3c --- /dev/null +++ b/linden/indra/llimagej2coj/CMakeLists.txt | |||
@@ -0,0 +1,31 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | project(llimagej2coj) | ||
4 | |||
5 | include(00-Common) | ||
6 | include(LLCommon) | ||
7 | include(LLImage) | ||
8 | include(OpenJPEG) | ||
9 | |||
10 | include_directories( | ||
11 | ${LLCOMMON_INCLUDE_DIRS} | ||
12 | ${LLIMAGE_INCLUDE_DIRS} | ||
13 | ${OPENJPEG_INCLUDE_DIR} | ||
14 | ) | ||
15 | |||
16 | set(llimagej2coj_SOURCE_FILES | ||
17 | llimagej2coj.cpp | ||
18 | ) | ||
19 | |||
20 | set(llimagej2coj_HEADER_FILES | ||
21 | CMakeLists.txt | ||
22 | |||
23 | llimagej2coj.h | ||
24 | ) | ||
25 | |||
26 | set_source_files_properties(${llimagej2coj_HEADER_FILES} | ||
27 | PROPERTIES HEADER_FILE_ONLY TRUE) | ||
28 | |||
29 | list(APPEND llimagej2coj_SOURCE_FILES ${llimagej2coj_HEADER_FILES}) | ||
30 | |||
31 | add_library (llimagej2coj ${llimagej2coj_SOURCE_FILES}) | ||