aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llimagej2coj/CMakeLists.txt
diff options
context:
space:
mode:
authorJacek Antonelli2008-09-06 18:24:57 -0500
committerJacek Antonelli2008-09-06 18:25:07 -0500
commit798d367d54a6c6379ad355bd8345fa40e31e7fe9 (patch)
tree1921f1708cd0240648c97bc02df2c2ab5f2fc41e /linden/indra/llimagej2coj/CMakeLists.txt
parentSecond Life viewer sources 1.20.15 (diff)
downloadmeta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.zip
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.gz
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.bz2
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.xz
Second Life viewer sources 1.21.0-RC
Diffstat (limited to 'linden/indra/llimagej2coj/CMakeLists.txt')
-rw-r--r--linden/indra/llimagej2coj/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/linden/indra/llimagej2coj/CMakeLists.txt b/linden/indra/llimagej2coj/CMakeLists.txt
new file mode 100644
index 0000000..ed3ff3c
--- /dev/null
+++ b/linden/indra/llimagej2coj/CMakeLists.txt
@@ -0,0 +1,31 @@
1# -*- cmake -*-
2
3project(llimagej2coj)
4
5include(00-Common)
6include(LLCommon)
7include(LLImage)
8include(OpenJPEG)
9
10include_directories(
11 ${LLCOMMON_INCLUDE_DIRS}
12 ${LLIMAGE_INCLUDE_DIRS}
13 ${OPENJPEG_INCLUDE_DIR}
14 )
15
16set(llimagej2coj_SOURCE_FILES
17 llimagej2coj.cpp
18 )
19
20set(llimagej2coj_HEADER_FILES
21 CMakeLists.txt
22
23 llimagej2coj.h
24 )
25
26set_source_files_properties(${llimagej2coj_HEADER_FILES}
27 PROPERTIES HEADER_FILE_ONLY TRUE)
28
29list(APPEND llimagej2coj_SOURCE_FILES ${llimagej2coj_HEADER_FILES})
30
31add_library (llimagej2coj ${llimagej2coj_SOURCE_FILES})