aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llcharacter/CMakeLists.txt
diff options
context:
space:
mode:
authorJacek Antonelli2008-09-06 18:24:57 -0500
committerJacek Antonelli2008-09-06 18:25:07 -0500
commit798d367d54a6c6379ad355bd8345fa40e31e7fe9 (patch)
tree1921f1708cd0240648c97bc02df2c2ab5f2fc41e /linden/indra/llcharacter/CMakeLists.txt
parentSecond Life viewer sources 1.20.15 (diff)
downloadmeta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.zip
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.gz
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.bz2
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.xz
Second Life viewer sources 1.21.0-RC
Diffstat (limited to 'linden/indra/llcharacter/CMakeLists.txt')
-rw-r--r--linden/indra/llcharacter/CMakeLists.txt76
1 files changed, 76 insertions, 0 deletions
diff --git a/linden/indra/llcharacter/CMakeLists.txt b/linden/indra/llcharacter/CMakeLists.txt
new file mode 100644
index 0000000..6301062
--- /dev/null
+++ b/linden/indra/llcharacter/CMakeLists.txt
@@ -0,0 +1,76 @@
1# -*- cmake -*-
2
3project(llcharacter)
4
5include(00-Common)
6include(LLCommon)
7include(LLMath)
8include(LLMessage)
9include(LLVFS)
10include(LLXML)
11
12include_directories(
13 ${LLCOMMON_INCLUDE_DIRS}
14 ${LLMATH_INCLUDE_DIRS}
15 ${LLMESSAGE_INCLUDE_DIRS}
16 ${LLVFS_INCLUDE_DIRS}
17 ${LLXML_INCLUDE_DIRS}
18 )
19
20set(llcharacter_SOURCE_FILES
21 llanimationstates.cpp
22 llbvhloader.cpp
23 llcharacter.cpp
24 lleditingmotion.cpp
25 llgesture.cpp
26 llhandmotion.cpp
27 llheadrotmotion.cpp
28 lljoint.cpp
29 lljointsolverrp3.cpp
30 llkeyframefallmotion.cpp
31 llkeyframemotion.cpp
32 llkeyframemotionparam.cpp
33 llkeyframestandmotion.cpp
34 llkeyframewalkmotion.cpp
35 llmotioncontroller.cpp
36 llmotion.cpp
37 llmultigesture.cpp
38 llpose.cpp
39 llstatemachine.cpp
40 lltargetingmotion.cpp
41 llvisualparam.cpp
42 )
43
44set(llcharacter_HEADER_FILES
45 CMakeLists.txt
46
47 llanimationstates.h
48 llbvhloader.h
49 llcharacter.h
50 lleditingmotion.h
51 llgesture.h
52 llhandmotion.h
53 llheadrotmotion.h
54 lljoint.h
55 lljointsolverrp3.h
56 lljointstate.h
57 llkeyframefallmotion.h
58 llkeyframemotion.h
59 llkeyframemotionparam.h
60 llkeyframestandmotion.h
61 llkeyframewalkmotion.h
62 llmotion.h
63 llmotioncontroller.h
64 llmultigesture.h
65 llpose.h
66 llstatemachine.h
67 lltargetingmotion.h
68 llvisualparam.h
69 )
70
71set_source_files_properties(${llcharacter_HEADER_FILES}
72 PROPERTIES HEADER_FILE_ONLY TRUE)
73
74list(APPEND llcharacter_SOURCE_FILES ${llcharacter_HEADER_FILES})
75
76add_library (llcharacter ${llcharacter_SOURCE_FILES})