aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llaudio
diff options
context:
space:
mode:
authorJacek Antonelli2009-04-06 04:41:58 -0500
committerJacek Antonelli2009-04-06 04:41:58 -0500
commit87c760f959788e3ec9dc06cbd2207d0242b6a4c9 (patch)
tree3265d96edbb9aba1eefc2744b03baf037e62402a /linden/indra/llaudio
parentConverted BOOLs to bools in llthread. (diff)
parentAdded libgstdecodebin.so plugin to Mac manifest. (diff)
downloadmeta-impy-87c760f959788e3ec9dc06cbd2207d0242b6a4c9.zip
meta-impy-87c760f959788e3ec9dc06cbd2207d0242b6a4c9.tar.gz
meta-impy-87c760f959788e3ec9dc06cbd2207d0242b6a4c9.tar.bz2
meta-impy-87c760f959788e3ec9dc06cbd2207d0242b6a4c9.tar.xz
Merge branch 'mac-1.1.0' into next
Required substantial portability changes to set_gst_plugin_path(). Conflicts: linden/indra/llmedia/llmediaimplgstreamer.cpp
Diffstat (limited to 'linden/indra/llaudio')
-rw-r--r--linden/indra/llaudio/CMakeLists.txt1
-rw-r--r--linden/indra/llaudio/audioengine_openal.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/linden/indra/llaudio/CMakeLists.txt b/linden/indra/llaudio/CMakeLists.txt
index aa15a9d..8a26e54 100644
--- a/linden/indra/llaudio/CMakeLists.txt
+++ b/linden/indra/llaudio/CMakeLists.txt
@@ -4,6 +4,7 @@ project(llaudio)
4 4
5include(00-Common) 5include(00-Common)
6include(Audio) 6include(Audio)
7include(OPENAL)
7include(FMOD) 8include(FMOD)
8include(LLCommon) 9include(LLCommon)
9include(LLMath) 10include(LLMath)
diff --git a/linden/indra/llaudio/audioengine_openal.cpp b/linden/indra/llaudio/audioengine_openal.cpp
index 8f836a6..6d9a242 100644
--- a/linden/indra/llaudio/audioengine_openal.cpp
+++ b/linden/indra/llaudio/audioengine_openal.cpp
@@ -172,6 +172,17 @@ LLAudioChannelOpenAL::LLAudioChannelOpenAL()
172 mLastSamplePos(0) 172 mLastSamplePos(0)
173{ 173{
174 alGenSources(1, &mALSource); 174 alGenSources(1, &mALSource);
175
176 if( mALSource == AL_NONE )
177 {
178 ALenum error = alGetError();
179 if( error == AL_NO_ERROR )
180 {
181 LL_WARNS("OpenAL") << "LLAudioChannelOpenAL::LLAudioChannelOpenAL() Could not generate mALSource, but no error is indicated!" << LL_ENDL;
182 }
183 LL_WARNS("OpenAL") << "LLAudioChannelOpenAL::LLAudioChannelOpenAL() Could not generate mALSource: (" << error << ") " << alGetString( error ) << LL_ENDL;
184 }
185
175} 186}
176 187
177LLAudioChannelOpenAL::~LLAudioChannelOpenAL() 188LLAudioChannelOpenAL::~LLAudioChannelOpenAL()