aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llaudio/CMakeLists.txt
diff options
context:
space:
mode:
authorJacek Antonelli2009-02-12 02:06:41 -0600
committerJacek Antonelli2009-02-12 02:06:45 -0600
commit61f97b33f9850d21965d397b947a298c16ba576d (patch)
treea2edff0a7fbc83e2259eda952511b0fbdbea290b /linden/indra/llaudio/CMakeLists.txt
parentSecond Life viewer sources 1.22.7-RC (diff)
downloadmeta-impy-61f97b33f9850d21965d397b947a298c16ba576d.zip
meta-impy-61f97b33f9850d21965d397b947a298c16ba576d.tar.gz
meta-impy-61f97b33f9850d21965d397b947a298c16ba576d.tar.bz2
meta-impy-61f97b33f9850d21965d397b947a298c16ba576d.tar.xz
Second Life viewer sources 1.22.8-RC
Diffstat (limited to 'linden/indra/llaudio/CMakeLists.txt')
-rw-r--r--linden/indra/llaudio/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/linden/indra/llaudio/CMakeLists.txt b/linden/indra/llaudio/CMakeLists.txt
index ebedcab..235248e 100644
--- a/linden/indra/llaudio/CMakeLists.txt
+++ b/linden/indra/llaudio/CMakeLists.txt
@@ -5,10 +5,12 @@ project(llaudio)
5include(00-Common) 5include(00-Common)
6include(Audio) 6include(Audio)
7include(FMOD) 7include(FMOD)
8include(OPENAL)
8include(LLCommon) 9include(LLCommon)
9include(LLMath) 10include(LLMath)
10include(LLMessage) 11include(LLMessage)
11include(LLVFS) 12include(LLVFS)
13include(LLMedia)
12 14
13include_directories( 15include_directories(
14 ${FMOD_INCLUDE_DIR} 16 ${FMOD_INCLUDE_DIR}
@@ -20,6 +22,9 @@ include_directories(
20 ${VORBISENC_INCLUDE_DIRS} 22 ${VORBISENC_INCLUDE_DIRS}
21 ${VORBISFILE_INCLUDE_DIRS} 23 ${VORBISFILE_INCLUDE_DIRS}
22 ${VORBIS_INCLUDE_DIRS} 24 ${VORBIS_INCLUDE_DIRS}
25 ${OPENAL_LIB_INCLUDE_DIRS}
26 ${FREEAULT_LIB_INCLUDE_DIRS}
27 ${LLMEDIA_INCLUDE_DIRS}
23 ) 28 )
24 29
25set(llaudio_SOURCE_FILES 30set(llaudio_SOURCE_FILES
@@ -38,6 +43,7 @@ set(llaudio_HEADER_FILES
38 llaudiodecodemgr.h 43 llaudiodecodemgr.h
39 vorbisdecode.h 44 vorbisdecode.h
40 vorbisencode.h 45 vorbisencode.h
46 windgen.h
41 ) 47 )
42 48
43if (FMOD) 49if (FMOD)
@@ -59,6 +65,18 @@ if (FMOD)
59 endif (LINUX) 65 endif (LINUX)
60endif (FMOD) 66endif (FMOD)
61 67
68if (OPENAL)
69 list(APPEND llaudio_SOURCE_FILES
70 audioengine_openal.cpp
71 listener_openal.cpp
72 )
73
74 list(APPEND llaudio_HEADER_FILES
75 audioengine_openal.h
76 listener_openal.h
77 )
78endif (OPENAL)
79
62set_source_files_properties(${llaudio_HEADER_FILES} 80set_source_files_properties(${llaudio_HEADER_FILES}
63 PROPERTIES HEADER_FILE_ONLY TRUE) 81 PROPERTIES HEADER_FILE_ONLY TRUE)
64 82