aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llaudio/CMakeLists.txt
diff options
context:
space:
mode:
authorMcCabe Maxsted2009-06-07 23:14:43 -0700
committerMcCabe Maxsted2009-06-07 23:14:43 -0700
commite0a70bea805cf07b92efabca15ffe56a777f90ac (patch)
tree2c93d38e210832e737d09cff7561373d8d5453b2 /linden/indra/llaudio/CMakeLists.txt
parent1.1 version final (diff)
parentMerge branch 'sl-base-1.22' into next (diff)
downloadmeta-impy-e0a70bea805cf07b92efabca15ffe56a777f90ac.zip
meta-impy-e0a70bea805cf07b92efabca15ffe56a777f90ac.tar.gz
meta-impy-e0a70bea805cf07b92efabca15ffe56a777f90ac.tar.bz2
meta-impy-e0a70bea805cf07b92efabca15ffe56a777f90ac.tar.xz
Moved base up to 1.22
Diffstat (limited to 'linden/indra/llaudio/CMakeLists.txt')
-rw-r--r--linden/indra/llaudio/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/linden/indra/llaudio/CMakeLists.txt b/linden/indra/llaudio/CMakeLists.txt
index 8a26e54..70041e7 100644
--- a/linden/indra/llaudio/CMakeLists.txt
+++ b/linden/indra/llaudio/CMakeLists.txt
@@ -6,6 +6,7 @@ include(00-Common)
6include(Audio) 6include(Audio)
7include(OPENAL) 7include(OPENAL)
8include(FMOD) 8include(FMOD)
9include(OPENAL)
9include(LLCommon) 10include(LLCommon)
10include(LLMath) 11include(LLMath)
11include(LLMessage) 12include(LLMessage)
@@ -76,7 +77,6 @@ if (OPENAL)
76 audioengine_openal.h 77 audioengine_openal.h
77 listener_openal.h 78 listener_openal.h
78 ) 79 )
79
80endif (OPENAL) 80endif (OPENAL)
81 81
82set_source_files_properties(${llaudio_HEADER_FILES} 82set_source_files_properties(${llaudio_HEADER_FILES}
@@ -85,3 +85,11 @@ set_source_files_properties(${llaudio_HEADER_FILES}
85list(APPEND llaudio_SOURCE_FILES ${llaudio_HEADER_FILES}) 85list(APPEND llaudio_SOURCE_FILES ${llaudio_HEADER_FILES})
86 86
87add_library (llaudio ${llaudio_SOURCE_FILES}) 87add_library (llaudio ${llaudio_SOURCE_FILES})
88
89target_link_libraries(
90 llaudio
91 ${VORBISENC_LIBRARIES}
92 ${VORBISFILE_LIBRARIES}
93 ${VORBIS_LIBRARIES}
94 ${OGG_LIBRARIES}
95 )