aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/linux_crash_logger
diff options
context:
space:
mode:
authorJacek Antonelli2009-06-08 00:41:31 -0500
committerJacek Antonelli2009-06-08 00:41:31 -0500
commit0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa (patch)
tree2c93d38e210832e737d09cff7561373d8d5453b2 /linden/indra/linux_crash_logger
parentImprudence 1.1.0 released. (diff)
parentUpdated Imprudence to be based on SL 1.22.11. (ChangeLog Entry) (diff)
downloadmeta-impy-0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa.zip
meta-impy-0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa.tar.gz
meta-impy-0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa.tar.bz2
meta-impy-0e5df9bdf8d6b418bb6e25615e2ffc922d0f02aa.tar.xz
Merge branch 'sl-base-1.22' into next
Conflicts: linden/indra/newview/English.lproj/InfoPlist.strings linden/indra/newview/skins/default/xui/en-us/panel_chat_bar.xml
Diffstat (limited to 'linden/indra/linux_crash_logger')
-rw-r--r--linden/indra/linux_crash_logger/CMakeLists.txt7
-rw-r--r--linden/indra/linux_crash_logger/linux_crash_logger.cpp2
-rw-r--r--linden/indra/linux_crash_logger/llcrashloggerlinux.cpp17
-rw-r--r--linden/indra/linux_crash_logger/llcrashloggerlinux.h2
4 files changed, 17 insertions, 11 deletions
diff --git a/linden/indra/linux_crash_logger/CMakeLists.txt b/linden/indra/linux_crash_logger/CMakeLists.txt
index 628d4ac..6f6754e 100644
--- a/linden/indra/linux_crash_logger/CMakeLists.txt
+++ b/linden/indra/linux_crash_logger/CMakeLists.txt
@@ -3,7 +3,6 @@
3project(linux_crash_logger) 3project(linux_crash_logger)
4 4
5include(00-Common) 5include(00-Common)
6include(Boost)
7include(LLCommon) 6include(LLCommon)
8include(LLCrashLogger) 7include(LLCrashLogger)
9include(LLMath) 8include(LLMath)
@@ -52,17 +51,15 @@ target_link_libraries(linux-crash-logger
52 ${LLMATH_LIBRARIES} 51 ${LLMATH_LIBRARIES}
53 ${LLCOMMON_LIBRARIES} 52 ${LLCOMMON_LIBRARIES}
54 ${UI_LIBRARIES} 53 ${UI_LIBRARIES}
55 ${BOOST_SIGNALS_LIBRARY}
56 ${DB_LIBRARIES} 54 ${DB_LIBRARIES}
57 ) 55 )
58 56
59add_custom_command( 57add_custom_command(
60 OUTPUT linux-crash-logger-stripped 58 OUTPUT linux-crash-logger-stripped
61 COMMAND strip 59 COMMAND strip
62 ARGS --strip-debug -o linux-crash-logger-stripped 60 ARGS --strip-debug -o linux-crash-logger-stripped linux-crash-logger
63 linux-crash-logger
64 DEPENDS linux-crash-logger 61 DEPENDS linux-crash-logger
65 ) 62 )
66 63
67add_custom_target(linux-crash-logger-stripped ALL 64add_custom_target(linux-crash-logger-strip-target ALL
68 DEPENDS linux-crash-logger-stripped) 65 DEPENDS linux-crash-logger-stripped)
diff --git a/linden/indra/linux_crash_logger/linux_crash_logger.cpp b/linden/indra/linux_crash_logger/linux_crash_logger.cpp
index 22c38c6..18e2637 100644
--- a/linden/indra/linux_crash_logger/linux_crash_logger.cpp
+++ b/linden/indra/linux_crash_logger/linux_crash_logger.cpp
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2003&license=viewergpl$ 5 * $LicenseInfo:firstyear=2003&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2003-2008, Linden Research, Inc. 7 * Copyright (c) 2003-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
diff --git a/linden/indra/linux_crash_logger/llcrashloggerlinux.cpp b/linden/indra/linux_crash_logger/llcrashloggerlinux.cpp
index c4294d6..4ccbe9a 100644
--- a/linden/indra/linux_crash_logger/llcrashloggerlinux.cpp
+++ b/linden/indra/linux_crash_logger/llcrashloggerlinux.cpp
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2003&license=viewergpl$ 5 * $LicenseInfo:firstyear=2003&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2003-2008, Linden Research, Inc. 7 * Copyright (c) 2003-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab
@@ -124,11 +124,20 @@ void LLCrashLoggerLinux::gatherPlatformSpecificFiles()
124 124
125bool LLCrashLoggerLinux::mainLoop() 125bool LLCrashLoggerLinux::mainLoop()
126{ 126{
127 if(!do_ask_dialog()) 127 bool send_logs = true;
128 if(CRASH_BEHAVIOR_ASK == getCrashBehavior())
128 { 129 {
129 return true; 130 send_logs = do_ask_dialog();
131 }
132 else if(CRASH_BEHAVIOR_NEVER_SEND == getCrashBehavior())
133 {
134 send_logs = false;
135 }
136
137 if(send_logs)
138 {
139 sendCrashLogs();
130 } 140 }
131 sendCrashLogs();
132 return true; 141 return true;
133} 142}
134 143
diff --git a/linden/indra/linux_crash_logger/llcrashloggerlinux.h b/linden/indra/linux_crash_logger/llcrashloggerlinux.h
index 4708493..b9b56bb 100644
--- a/linden/indra/linux_crash_logger/llcrashloggerlinux.h
+++ b/linden/indra/linux_crash_logger/llcrashloggerlinux.h
@@ -4,7 +4,7 @@
4 * 4 *
5 * $LicenseInfo:firstyear=2003&license=viewergpl$ 5 * $LicenseInfo:firstyear=2003&license=viewergpl$
6 * 6 *
7 * Copyright (c) 2003-2008, Linden Research, Inc. 7 * Copyright (c) 2003-2009, Linden Research, Inc.
8 * 8 *
9 * Second Life Viewer Source Code 9 * Second Life Viewer Source Code
10 * The source code in this file ("Source Code") is provided by Linden Lab 10 * The source code in this file ("Source Code") is provided by Linden Lab