diff options
author | Jacek Antonelli | 2008-09-06 18:24:57 -0500 |
---|---|---|
committer | Jacek Antonelli | 2008-09-06 18:25:07 -0500 |
commit | 798d367d54a6c6379ad355bd8345fa40e31e7fe9 (patch) | |
tree | 1921f1708cd0240648c97bc02df2c2ab5f2fc41e /linden/indra/CMakeLists.txt | |
parent | Second Life viewer sources 1.20.15 (diff) | |
download | meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.zip meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.gz meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.bz2 meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.xz |
Second Life viewer sources 1.21.0-RC
Diffstat (limited to '')
-rw-r--r-- | linden/indra/CMakeLists.txt | 102 |
1 files changed, 102 insertions, 0 deletions
diff --git a/linden/indra/CMakeLists.txt b/linden/indra/CMakeLists.txt new file mode 100644 index 0000000..fac2afa --- /dev/null +++ b/linden/indra/CMakeLists.txt | |||
@@ -0,0 +1,102 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | # cmake_minimum_required should appear before any | ||
4 | # other commands to guarantee full compatibility | ||
5 | # with the version specified | ||
6 | |||
7 | # The "cmake -E touch" command was released with 2.4.8. | ||
8 | cmake_minimum_required(VERSION 2.4.8 FATAL_ERROR) | ||
9 | |||
10 | # This makes cmake 2.6 not complain about a version | ||
11 | # 2.4 compatibility mode | ||
12 | if(COMMAND cmake_policy) | ||
13 | cmake_policy(SET CMP0003 OLD) | ||
14 | endif(COMMAND cmake_policy) | ||
15 | |||
16 | project(SecondLife) | ||
17 | |||
18 | set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake") | ||
19 | |||
20 | include(Variables) | ||
21 | |||
22 | if (NOT CMAKE_BUILD_TYPE) | ||
23 | set(CMAKE_BUILD_TYPE RelWithDebInfo CACHE STRING | ||
24 | "Build type. One of: Debug Release RelWithDebInfo" FORCE) | ||
25 | endif (NOT CMAKE_BUILD_TYPE) | ||
26 | |||
27 | # For the library installation process; | ||
28 | # see cmake/Prebuild.cmake for the counterpart code. | ||
29 | file(MAKE_DIRECTORY ${CMAKE_BINARY_DIR}/temp) | ||
30 | file(WRITE ${CMAKE_BINARY_DIR}/temp/sentinel_installed "0") | ||
31 | add_subdirectory(cmake) | ||
32 | |||
33 | add_subdirectory(${LIBS_OPEN_PREFIX}llaudio) | ||
34 | add_subdirectory(${LIBS_OPEN_PREFIX}llcharacter) | ||
35 | add_subdirectory(${LIBS_OPEN_PREFIX}llcommon) | ||
36 | add_subdirectory(${LIBS_OPEN_PREFIX}llimage) | ||
37 | add_subdirectory(${LIBS_OPEN_PREFIX}llimagej2coj) | ||
38 | add_subdirectory(${LIBS_OPEN_PREFIX}llinventory) | ||
39 | add_subdirectory(${LIBS_OPEN_PREFIX}llmath) | ||
40 | add_subdirectory(${LIBS_OPEN_PREFIX}llmedia) | ||
41 | add_subdirectory(${LIBS_OPEN_PREFIX}llmessage) | ||
42 | add_subdirectory(${LIBS_OPEN_PREFIX}llprimitive) | ||
43 | add_subdirectory(${LIBS_OPEN_PREFIX}llrender) | ||
44 | add_subdirectory(${LIBS_OPEN_PREFIX}llvfs) | ||
45 | add_subdirectory(${LIBS_OPEN_PREFIX}llwindow) | ||
46 | add_subdirectory(${LIBS_OPEN_PREFIX}llxml) | ||
47 | |||
48 | if (EXISTS ${LIBS_CLOSED_DIR}llkdu AND NOT STANDALONE) | ||
49 | add_subdirectory(${LIBS_CLOSED_PREFIX}llkdu) | ||
50 | endif (EXISTS ${LIBS_CLOSED_DIR}llkdu AND NOT STANDALONE) | ||
51 | |||
52 | add_subdirectory(${LIBS_OPEN_PREFIX}lscript) | ||
53 | |||
54 | if (WINDOWS AND EXISTS ${LIBS_CLOSED_DIR}copy_win_scripts) | ||
55 | add_subdirectory(${LIBS_CLOSED_PREFIX}copy_win_scripts) | ||
56 | endif (WINDOWS AND EXISTS ${LIBS_CLOSED_DIR}copy_win_scripts) | ||
57 | |||
58 | add_custom_target(viewer) | ||
59 | if (VIEWER) | ||
60 | add_subdirectory(${LIBS_OPEN_PREFIX}llcrashlogger) | ||
61 | add_subdirectory(${LIBS_OPEN_PREFIX}llui) | ||
62 | |||
63 | if (LINUX) | ||
64 | add_subdirectory(${VIEWER_PREFIX}linux_crash_logger) | ||
65 | add_dependencies(viewer linux-crash-logger) | ||
66 | elseif (DARWIN) | ||
67 | add_subdirectory(${VIEWER_PREFIX}mac_crash_logger) | ||
68 | add_subdirectory(${VIEWER_PREFIX}mac_updater) | ||
69 | add_dependencies(viewer mac-updater mac-crash-logger) | ||
70 | elseif (WINDOWS) | ||
71 | add_subdirectory(${VIEWER_PREFIX}win_crash_logger) | ||
72 | add_subdirectory(${VIEWER_PREFIX}win_updater) | ||
73 | add_dependencies(viewer windows-updater windows-crash-logger) | ||
74 | elseif (SOLARIS) | ||
75 | add_subdirectory(solaris_crash_logger) | ||
76 | add_dependencies(viewer solaris-crash-logger) | ||
77 | endif (LINUX) | ||
78 | |||
79 | add_subdirectory(${VIEWER_PREFIX}newview) | ||
80 | add_dependencies(viewer secondlife-bin) | ||
81 | endif (VIEWER) | ||
82 | |||
83 | # Linux builds the viewer and server in 2 separate projects | ||
84 | # In order for ./develop.py build server to work on linux, | ||
85 | # the viewer project needs a server target. | ||
86 | # This is not true for mac and windows. | ||
87 | if (LINUX) | ||
88 | add_custom_target(server) | ||
89 | endif (LINUX) | ||
90 | if (SERVER) | ||
91 | if (NOT LINUX) | ||
92 | add_custom_target(server) | ||
93 | endif (NOT LINUX) | ||
94 | include(${SERVER_PREFIX}Server.cmake) | ||
95 | endif (SERVER) | ||
96 | |||
97 | # Windows builds include tools like VFS tool | ||
98 | if (SERVER) | ||
99 | if (WINDOWS) | ||
100 | add_subdirectory(${SERVER_PREFIX}tools) | ||
101 | endif (WINDOWS) | ||
102 | endif (SERVER) | ||