aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/ChangeLog.txt
diff options
context:
space:
mode:
authorJacek Antonelli2009-10-09 10:11:45 -0500
committerJacek Antonelli2009-10-09 10:11:45 -0500
commitbb657bd4244d0b1b80f368a30e40531f573d3c5f (patch)
treeaef4e3c075ba760f48963d76c9300b6a8b323bf9 /ChangeLog.txt
parentGrid manager no longer appends "/" to URIs. (diff)
parentFixed money change notification happening after logout/login (diff)
downloadmeta-impy-bb657bd4244d0b1b80f368a30e40531f573d3c5f.zip
meta-impy-bb657bd4244d0b1b80f368a30e40531f573d3c5f.tar.gz
meta-impy-bb657bd4244d0b1b80f368a30e40531f573d3c5f.tar.bz2
meta-impy-bb657bd4244d0b1b80f368a30e40531f573d3c5f.tar.xz
Merge remote branch 'mccabe/next' into next
Diffstat (limited to 'ChangeLog.txt')
-rw-r--r--ChangeLog.txt202
1 files changed, 202 insertions, 0 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt
index 9e894ec..3aa5c54 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -1,3 +1,115 @@
12009-10-08 McCabe Maxsted <hakushakukun@gmail.com>
2
3 * Fixed money change notification happening after logout/login.
4
5 modified: linden/indra/newview/llviewermessage.cpp
6
7
8 * Fixed entering sim notification being tied to radar range.
9
10 modified: linden/indra/newview/llfloatermap.cpp
11
12
13 * Fixed stupid error on my part that broke clickable names in chat history.
14
15 modified: linden/indra/newview/llfloaterchat.cpp
16
17
182009-10-07 McCabe Maxsted <hakushakukun@gmail.com>
19
20 * Clickable IMs in chat history was causing readability problems at varying distances,
21 decided it was a bug and fixed it.
22
23 modified: linden/indra/newview/llfloaterchat.cpp
24
25
26 * Mini-map radar now can notify you when someone enters the sim.
27
28 modified: linden/indra/newview/app_settings/settings.xml
29 modified: linden/indra/newview/llfloatermap.cpp
30 modified: linden/indra/newview/llfloatermap.h
31 modified: linden/indra/newview/llpanelgeneral.cpp
32 modified: linden/indra/newview/skins/default/xui/en-us/floater_mini_map.xml
33 modified: linden/indra/newview/skins/default/xui/en-us/panel_preferences_general.xml
34
35
36 * Added typing info to mini-map radar.
37
38 modified: linden/indra/newview/llfloatermap.cpp
39 modified: linden/indra/newview/llfloatermap.h
40 modified: linden/indra/newview/llviewermessage.cpp
41 modified: linden/indra/newview/skins/default/xui/en-us/floater_mini_map.xml
42
43
44 * Fixed random mouseclicks on the edge of the window.
45
46 modified: linden/indra/newview/llviewerwindow.cpp
47
48
492009-10-06 McCabe Maxsted <hakushakukun@gmail.com>
50
51 * Applied RLVa-1.0.3e_20091005_Imprudence-1.2.0-diff.patch by Kitty Barnett.
52
53 modified: linden/indra/newview/CMakeLists.txt
54 modified: linden/indra/newview/app_settings/settings.xml
55 modified: linden/indra/newview/llfirstuse.cpp
56 modified: linden/indra/newview/llfirstuse.h
57 modified: linden/indra/newview/llviewermenu.cpp
58 modified: linden/indra/newview/llviewermessage.cpp
59 modified: linden/indra/newview/rlvevent.h
60 modified: linden/indra/newview/rlvextensions.cpp
61 modified: linden/indra/newview/rlvhandler.cpp
62 modified: linden/indra/newview/rlvhandler.h
63 modified: linden/indra/newview/rlvhelper.cpp
64 modified: linden/indra/newview/rlvhelper.h
65 modified: linden/indra/newview/skins/default/xui/en-us/alerts.xml
66 modified: linden/indra/newview/skins/default/xui/en-us/menu_viewer.xml
67
68
69modified: linden/indra/newview/skins/default/xui/en-us/notify.xml
70
71
72 * Applied RLVa-1.0.2c_20091005_Imprudence-1.2.0-diff.patch by Kitty Barnett.
73
74 modified: linden/indra/newview/llinventorybridge.cpp
75 modified: linden/indra/newview/lltooldraganddrop.cpp
76 modified: linden/indra/newview/llviewermenu.cpp
77 modified: linden/indra/newview/llviewermessage.cpp
78 modified: linden/indra/newview/rlvhandler.cpp
79 modified: linden/indra/newview/rlvhandler.h
80 modified: linden/indra/newview/rlvhelper.cpp
81 modified: linden/indra/newview/rlvhelper.h
82
83
842009-10-05 McCabe Maxsted <hakushakukun@gmail.com>
85
86 * Renamed 'Create' in object pie to 'Build,' moved it to top right and switched 'Wear' and 'Return.'
87
88 modified: indra/newview/skins/default/xui/en-us/menu_pie_object.xml
89
90
912009-10-04 McCabe Maxsted <hakushakukun@gmail.com>
92
93 * Changes that should improve sculpty LOD.
94
95 modified: linden/indra/llmath/llvolume.cpp
96
97
98 * Fixed mini-map distance label and rounding.
99
100 modified: linden/indra/newview/llfloatermap.cpp
101
102
103 * Mini-map radar now notifies when someone enters chat range, and how far away they are.
104
105 modified: linden/indra/newview/app_settings/settings.xml
106 modified: linden/indra/newview/llfloatermap.cpp
107 modified: linden/indra/newview/llfloatermap.h
108 modified: linden/indra/newview/llpanelgeneral.cpp
109 modified: linden/indra/newview/skins/default/xui/en-us/floater_mini_map.xml
110 modified: linden/indra/newview/skins/default/xui/en-us/panel_preferences_general.xml
111
112
12009-10-03 Jacek Antonelli <jacek.antonelli@gmail.com> 1132009-10-03 Jacek Antonelli <jacek.antonelli@gmail.com>
2 114
3 * Grid manager no longer appends "/" to URIs. 115 * Grid manager no longer appends "/" to URIs.
@@ -6,8 +118,98 @@
6 modified: linden/indra/newview/hippoGridManager.cpp 118 modified: linden/indra/newview/hippoGridManager.cpp
7 119
8 120
1212009-10-03 McCabe Maxsted <hakushakukun@gmail.com>
122
123 * Fixed layout of debug permissions in tools window.
124
125 modified: linden/indra/newview/skins/default/xui/en-us/floater_tools.xml
126
127
128 * Reverted slviewer-0-v12100-AllowDiscardForCreator.patch.
129 (Was causing usability issues with new notecard creation).
130
131 modified: linden/indra/newview/llviewermessage.cpp
132
133
134 * Added confirmation alerts for double-click tp and auto-pilot.
135
136 modified: linden/indra/newview/llviewermenu.cpp
137 modified: linden/indra/newview/skins/default/xui/en-us/alerts.xml
138
139
140 * Fixed extern C issue in llmediaimplgstreamer.h for Windows.
141
142 modified: linden/indra/llmedia/llmediaimplgstreamer.h
143
144
145 * Fixed account label not showing up in profiles.
146
147 modified: linden/indra/newview/skins/default/xui/en-us/panel_avatar.xml
148
149
150 * Fixed an issue with llkeywords.cpp(385) and Visual Studio.
151
152 modified: linden/indra/llui/llkeywords.cpp
153
154
155 * Fixed search window height being too small for new profile layout.
156
157 modified: linden/indra/newview/skins/default/xui/en-us/floater_directory.xml
158
159
1602009-10-02 McCabe Maxsted <hakushakukun@gmail.com>
161
162 * Added new color setting for Object IMs.
163
164 modified: linden/indra/llcommon/llchat.h
165 modified: linden/indra/newview/app_settings/settings.xml
166 modified: linden/indra/newview/llfloaterchat.cpp
167 modified: linden/indra/newview/llviewermessage.cpp
168 modified: linden/indra/newview/skins/default/xui/en-us/panel_preferences_chat.xml
169
170
171 * Fixed 1.2 beta features missing from silver skin.
172
173 deleted: linden/indra/newview/skins/silver/xui/en-us/floater_chatterbox.xml
174 modified: linden/indra/newview/skins/silver/xui/en-us/floater_windlight_options.xml
175
176
177 * Applied clickable object names for whisper/say/shout from Emerald viewer.
178
179 modified: linden/indra/newview/llviewermessage.cpp
180
181
182 * Object IMs are now prefixed with "IM: ".
183 As a side effect, names are now clickable when show IMs in chat is enabled.
184
185 modified: linden/indra/newview/llfloaterchat.cpp
186 modified: linden/indra/newview/llviewermessage.cpp
187
188
92009-10-01 McCabe Maxsted <hakushakukun@gmail.com> 1892009-10-01 McCabe Maxsted <hakushakukun@gmail.com>
10 190
191 * Added mini-map partner dot color for future use (currently unused).
192
193 modified: linden/indra/newview/skins/default/colors_base.xml
194 modified: linden/indra/newview/skins/silver/colors_base.xml
195
196
197 * Draw Imprudence developers as purple dots in the mini-map (name list in LLFloaterMap).
198
199 modified: linden/indra/newview/llfloatermap.cpp
200 modified: linden/indra/newview/llfloatermap.h
201 modified: linden/indra/newview/llnetmap.cpp
202 modified: linden/indra/newview/skins/default/colors_base.xml
203 modified: linden/indra/newview/skins/silver/colors_base.xml
204
205
206 * Draw selected avatars last (and fixed silver skin missing selection color).
207
208 modified: linden/indra/newview/llnetmap.cpp
209 modified: linden/indra/newview/skins/default/colors_base.xml
210 modified: linden/indra/newview/skins/silver/colors_base.xml
211
212
11 * Fixed switched Buy and Create locations in object pie menu (regression). 213 * Fixed switched Buy and Create locations in object pie menu (regression).
12 214
13 modified: linden/indra/newview/skins/default/xui/en-us/menu_pie_object.xml 215 modified: linden/indra/newview/skins/default/xui/en-us/menu_pie_object.xml