diff options
author | Jacek Antonelli | 2009-04-06 01:51:38 -0500 |
---|---|---|
committer | Jacek Antonelli | 2009-04-06 01:52:15 -0500 |
commit | bcf93cd3a302fd4cc1f8cf82c47a5b863dc2d937 (patch) | |
tree | 7b2154384c2d1339c6c030e237e3ea6ba7e19e94 /ChangeLog.txt | |
parent | Changed the login splash screen URL. (diff) | |
parent | Merge branch gst-thread into gst-revamp (diff) | |
download | meta-impy-bcf93cd3a302fd4cc1f8cf82c47a5b863dc2d937.zip meta-impy-bcf93cd3a302fd4cc1f8cf82c47a5b863dc2d937.tar.gz meta-impy-bcf93cd3a302fd4cc1f8cf82c47a5b863dc2d937.tar.bz2 meta-impy-bcf93cd3a302fd4cc1f8cf82c47a5b863dc2d937.tar.xz |
Merge branch 'gst-revamp' into next
Diffstat (limited to 'ChangeLog.txt')
-rw-r--r-- | ChangeLog.txt | 289 |
1 files changed, 289 insertions, 0 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt index beb0629..68fb3ca 100644 --- a/ChangeLog.txt +++ b/ChangeLog.txt | |||
@@ -1,9 +1,298 @@ | |||
1 | 2009-04-05 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
2 | |||
3 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
4 | LLMediaImplGStreamer creates new thread for playing. | ||
5 | This keeps the viewer responsive while GStreamer does its thing. | ||
6 | * linden/indra/llmedia/llmediaimplgstreamer.h: | ||
7 | Ditto. | ||
8 | |||
9 | |||
10 | * linden/indra/llmedia/llgstplaythread.cpp: | ||
11 | Added LLGstPlayThread class. | ||
12 | * linden/indra/llmedia/llgstplaythread.h: | ||
13 | Ditto. | ||
14 | * linden/indra/llmedia/CMakeLists.txt: | ||
15 | Ditto. | ||
16 | |||
17 | |||
18 | 2009-04-04 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
19 | |||
20 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
21 | Refactored the heart of the GST play code to startPlay(). | ||
22 | |||
23 | |||
24 | 2009-04-02 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
25 | |||
26 | * linden/indra/newview/llviewermedia.cpp: | ||
27 | Apply saved MediaDebugLevel at media init time. | ||
28 | |||
29 | |||
30 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
31 | Plugged in LLMediaImplGStreamer::gstreamer_log(). | ||
32 | |||
33 | |||
34 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
35 | Implemented LLMediaImplGStreamer::gstreamer_log(). | ||
36 | * linden/indra/llmedia/llmediaimplgstreamer.h: | ||
37 | Ditto. | ||
38 | |||
39 | |||
40 | * linden/indra/newview/llviewercontrol.cpp: | ||
41 | Implemented handleMediaDebugLevelChanged hook. | ||
42 | |||
43 | |||
44 | 2009-04-01 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
45 | |||
46 | * linden/indra/newview/app_settings/settings.xml: | ||
47 | Added MediaDebugLevel setting in XML (does nothing yet). | ||
48 | |||
49 | |||
50 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
51 | Implemented LLMediaImplGstreamer::setDebugLevel(). | ||
52 | * linden/indra/llmedia/llmediaimplgstreamer.h: | ||
53 | Ditto. | ||
54 | |||
55 | |||
56 | * linden/indra/llmedia/llmediaimplcommon.cpp: | ||
57 | Added LLMediaImplCommon::setDebugLevel(). | ||
58 | * linden/indra/llmedia/llmediaimplcommon.h: | ||
59 | Ditto. | ||
60 | |||
61 | |||
62 | * linden/indra/llmedia/llmediabase.h: | ||
63 | Added LLMediaBase::EDebugLevel and setDebugLevel prototype. | ||
64 | |||
65 | |||
66 | 2009-03-30 McCabe Maxsted <hakushakukun@gmail.com> | ||
67 | |||
68 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
69 | Cleaned up logic for bad streams. | ||
70 | |||
71 | |||
72 | 2009-03-29 McCabe Maxsted <hakushakukun@gmail.com> | ||
73 | |||
74 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
75 | Added loading status to the log's plugin list. | ||
76 | set_gst_plugin_path now compiles for windows. | ||
77 | |||
78 | |||
79 | * linden/indra/newview/llappviewer.cpp: | ||
80 | Removed unnecessary headers. | ||
81 | |||
82 | |||
83 | * linden/indra/cmake/00-Common.cmake | ||
84 | Added VS optimizations to cmake | ||
85 | Added flag for multi-core compiling in VS2005 | ||
86 | |||
87 | |||
88 | 2009-03-28 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
89 | |||
90 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
91 | Improved set_gst_plugin_path, more comprehensive path. | ||
92 | Also tried to tidy up a bit. | ||
93 | |||
94 | |||
95 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
96 | Moved Windows GST_PLUGIN_PATH setup to LLMediaImplGStreamer. | ||
97 | LLAppViewer::gst_plugin_path --> | ||
98 | LLMediaImplGStreamer::set_gst_plugin_path | ||
99 | |||
100 | |||
101 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
102 | Ditto. | ||
103 | * linden/indra/newview/llappviewer.h: | ||
104 | Ditto. | ||
105 | * linden/indra/newview/llappviewer.cpp: | ||
106 | Ditto. | ||
107 | |||
108 | |||
109 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
110 | Print out the plugins gstreamer finds, for debugging. | ||
111 | |||
112 | |||
1 | 2009-03-27 Jacek Antonelli <jacek.antonelli@gmail.com> | 113 | 2009-03-27 Jacek Antonelli <jacek.antonelli@gmail.com> |
2 | 114 | ||
3 | * linden/indra/newview/app_settings/settings.xml: | 115 | * linden/indra/newview/app_settings/settings.xml: |
4 | Changed the login splash screen URL. | 116 | Changed the login splash screen URL. |
5 | 117 | ||
6 | 118 | ||
119 | 2009-03-27 McCabe Maxsted <hakushakukun@gmail.com> | ||
120 | |||
121 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
122 | Fixed video streams freezing the viewer. | ||
123 | |||
124 | |||
125 | 2009-03-26 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
126 | |||
127 | * linden/indra/llmedia/llmediaimplgstreamervidplug.cpp: | ||
128 | Fixed/improved how slvideo gst plugin is registered. | ||
129 | |||
130 | |||
131 | * linden/indra/llmedia/llmediaimplgstreamer_syms.cpp: | ||
132 | Removed obsolete gstreamer_syms files. | ||
133 | * linden/indra/llmedia/llmediaimplgstreamer_syms.h: | ||
134 | Ditto. | ||
135 | * linden/indra/llmedia/llmediaimplgstreamer_syms_raw.inc: | ||
136 | Ditto. | ||
137 | * linden/indra/llmedia/llmediaimplgstreamer_syms_rawa.inc: | ||
138 | Ditto. | ||
139 | * linden/indra/llmedia/llmediaimplgstreamer_syms_rawv.inc: | ||
140 | Ditto. | ||
141 | |||
142 | |||
143 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
144 | Removed all that llgst and symbol grabbing silliness. | ||
145 | Some symbols require gstreamer >= 0.10.11. | ||
146 | * linden/indra/llmedia/llmediaimplgstreamervidplug.cpp: | ||
147 | Ditto. | ||
148 | * linden/indra/llmedia/CMakeLists.txt: | ||
149 | Ditto. | ||
150 | |||
151 | |||
152 | * linden/indra/cmake/GStreamer.cmake: | ||
153 | Link with some gstreamer core libs on Linux. | ||
154 | |||
155 | |||
156 | 2009-03-22 McCabe Maxsted <hakushakukun@gmail.com> | ||
157 | |||
158 | * linden/indra/newview/llappviewer.cpp: | ||
159 | Removed slviewer-0-v12160-LostConnectionOnLogin.patch. | ||
160 | |||
161 | * linden/indra/newview/app_settings/settings.xml: | ||
162 | Removed slviewer-0-v12160-RememberStatsPosAndSize.patch. | ||
163 | * linden/indra/newview/lldebugview.cpp: | ||
164 | Ditto. | ||
165 | * linden/indra/newview/llfloaterstats.cpp: | ||
166 | Ditto. | ||
167 | |||
168 | * linden/indra/newview/llfloaterurldisplay.cpp: | ||
169 | Removed slviewer-0-v12160-VisitedLandmarks.patch. | ||
170 | * linden/indra/newview/llinventorybridge.cpp: | ||
171 | Ditto. | ||
172 | * linden/indra/newview/llpanelinventory.cpp: | ||
173 | Ditto. | ||
174 | * linden/indra/newview/llpanelplace.cpp: | ||
175 | Ditto. | ||
176 | * linden/indra/newview/llpanelplace.h: | ||
177 | Ditto. | ||
178 | * linden/indra/newview/llpreviewlandmark.cpp: | ||
179 | Ditto. | ||
180 | * linden/indra/newview/llviewermessage.cpp: | ||
181 | Ditto. | ||
182 | |||
183 | |||
184 | 2009-03-16 McCabe Maxsted <hakushakukun@gmail.com> | ||
185 | |||
186 | * linden/indra/llmedia/llmediaimplgstreamer.cpp: | ||
187 | Visual Studio now ignores C4244 warnings in GStreamer. | ||
188 | Since the change was intentional, I thought it best to | ||
189 | continue using "treat warnings as errors" and ignore it. | ||
190 | * linden/indra/llmedia/llmediaimplgstreamer_syms.cpp: | ||
191 | Ditto. | ||
192 | * linden/indra/llmedia/llmediamanager.cpp: | ||
193 | Ditto. | ||
194 | |||
195 | |||
196 | 2009-03-10 McCabe Maxsted <hakushakukun@gmail.com> | ||
197 | |||
198 | * linden/indra/llaudio/audioengine.cpp: | ||
199 | Changed startinternetstream() a bit to be clearer. | ||
200 | |||
201 | |||
202 | 2009-03-07 McCabe Maxsted <hakushakukun@gmail.com> | ||
203 | |||
204 | * linden/indra/llimagej2coj/llimagej2coj.cpp: | ||
205 | Backported fix for VWR-4070 from 1.22. | ||
206 | |||
207 | * linden/indra/llaudio/audioengine.cpp: | ||
208 | Applied patch by Zwagoth Klaar for muting sounds before decoding. | ||
209 | * linden/indra/newview/llviewermessage.cpp: | ||
210 | Ditto. | ||
211 | |||
212 | * linden/indra/llmessage/llhttpclient.cpp: | ||
213 | Applied memleak patch from VWR-9400 by Henri and Carjay. | ||
214 | |||
215 | * linden/indra/newview/app_settings/settings.xml: | ||
216 | Applied remember stats position and size patch | ||
217 | from Latif Khalifa (VWR-9540). | ||
218 | * linden/indra/newview/lldebugview.cpp: | ||
219 | Ditto. | ||
220 | * linden/indra/newview/llfloaterstats.cpp: | ||
221 | Ditto. | ||
222 | |||
223 | * linden/indra/newview/llappviewer.cpp: | ||
224 | Backported fix for VWR-8783, original patch by Gigs Taggart. | ||
225 | |||
226 | * linden/indra/newview/llfloaterurldisplay.cpp: | ||
227 | Applied patch to correct landmark colors not changing | ||
228 | (VWR-7896) by Zi Ree. | ||
229 | * linden/indra/newview/llinventorybridge.cpp: | ||
230 | Ditto. | ||
231 | * linden/indra/newview/llpanelinventory.cpp: | ||
232 | Ditto. | ||
233 | * linden/indra/newview/llpanelplace.cpp: | ||
234 | Ditto. | ||
235 | * linden/indra/newview/llpanelplace.h: | ||
236 | Ditto. | ||
237 | * linden/indra/newview/llpreviewlandmark.cpp: | ||
238 | Ditto. | ||
239 | * linden/indra/newview/llviewermessage.cpp: | ||
240 | Ditto. | ||
241 | |||
242 | * linden/indra/newview/llvoavatar.cpp: | ||
243 | Use std::string for nametags, removed bizarre name stacking option. | ||
244 | |||
245 | |||
246 | 2009-03-01 McCabe Maxsted <hakushakukun@gmail.com> | ||
247 | |||
248 | * linden/indra/newview/llfloaterchat.cpp: | ||
249 | Backported fix for VWR-6744 (No way to hide IMs in chat console). | ||
250 | * linden/indra/newview/skins/default/xui/en-us/panel_preferences_im.xml: | ||
251 | Ditto. | ||
252 | |||
253 | |||
254 | 2009-02-28 McCabe Maxsted <hakushakukun@gmail.com> | ||
255 | |||
256 | * linden/indra/newview/skins/default/textures/textures.xml: | ||
257 | Fixed pause button texture showing up in certain instances. | ||
258 | * linden/indra/newview/skins/default/xui/de/panel_media_controls.xml: | ||
259 | Ditto. | ||
260 | * linden/indra/newview/skins/default/xui/fr/panel_media_controls.xml: | ||
261 | Ditto. | ||
262 | * linden/indra/newview/skins/default/xui/ja/panel_media_controls.xml: | ||
263 | Ditto. | ||
264 | * linden/indra/newview/skins/default/xui/ko/panel_media_controls.xml: | ||
265 | Ditto. | ||
266 | * linden/indra/newview/skins/silver/xui/en-us/panel_media_controls.xml: | ||
267 | Ditto. | ||
268 | |||
269 | * linden/indra/newview/llfilepicker.cpp: | ||
270 | Applied patch for VWR-5575 (crash in the file picker dealing | ||
271 | with accented characters and bad locale) by Alissa Sabre. | ||
272 | |||
273 | * linden/indra/newview/pipeline.cpp: | ||
274 | Backported possible crash fix while changing graphics settings from 1.22. | ||
275 | |||
276 | * linden/indra/llui/llfloater.cpp: | ||
277 | Backported possible crash fix in llfloater.cpp from 1.22. | ||
278 | |||
279 | * linden/indra/newview/lldrawable.cpp: | ||
280 | Backported fix for VWR-3871 (prim position appears to be off) from 1.22. | ||
281 | |||
282 | * linden/indra/newview/llcompilequeue.cpp: | ||
283 | Backported fix for SVC-2771 (script resetting can fail) from 1.22. | ||
284 | * linden/indra/newview/llviewermenu.cpp: | ||
285 | Ditto. | ||
286 | |||
287 | * linden/indra/llcharacter/llbvhloader.cpp: | ||
288 | Backported fix for VWR-996 (wrong visualisation of animations) from 1.22. | ||
289 | |||
290 | * linden/indra/newview/app_settings/keywords.ini: | ||
291 | Applied my patch for VWR-8454 (PARCEL_FLAG_ALLOW_CREATE_GROUP_OBJECTS | ||
292 | not highlighted in script editor). | ||
293 | |||
294 | |||
295 | |||
7 | =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- | 296 | =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- |
8 | =- 1.1.0 RC2 -= | 297 | =- 1.1.0 RC2 -= |
9 | =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- | 298 | =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- |