diff options
author | Jacek Antonelli | 2010-02-09 21:11:42 -0600 |
---|---|---|
committer | Jacek Antonelli | 2010-02-16 18:50:15 -0600 |
commit | e6247fbe78c4d3dacb74f3b2359aba2b6538133b (patch) | |
tree | 10c42d670a2c635b4339f7f68809c221756774f8 /ChangeLog.txt | |
parent | Ported some cURL and HTTP-related changes from Snowglobe. (diff) | |
download | meta-impy-e6247fbe78c4d3dacb74f3b2359aba2b6538133b.zip meta-impy-e6247fbe78c4d3dacb74f3b2359aba2b6538133b.tar.gz meta-impy-e6247fbe78c4d3dacb74f3b2359aba2b6538133b.tar.bz2 meta-impy-e6247fbe78c4d3dacb74f3b2359aba2b6538133b.tar.xz |
Ported many texture engine changes from Snowglobe.
Diffstat (limited to '')
-rw-r--r-- | ChangeLog.txt | 95 |
1 files changed, 95 insertions, 0 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt index cf6968f..c8d5ade 100644 --- a/ChangeLog.txt +++ b/ChangeLog.txt | |||
@@ -1,3 +1,98 @@ | |||
1 | 2010-02-09 Jacek Antonelli <jacek.antonelli@gmail.com> | ||
2 | |||
3 | * Ported many texture engine changes from Snowglobe. | ||
4 | |||
5 | modified: linden/indra/llimage/llimage.cpp | ||
6 | modified: linden/indra/llimage/llimage.h | ||
7 | modified: linden/indra/llimage/llimagedxt.cpp | ||
8 | modified: linden/indra/llimage/llimagej2c.cpp | ||
9 | modified: linden/indra/llimage/llimagejpeg.cpp | ||
10 | modified: linden/indra/llimage/llimageworker.cpp | ||
11 | modified: linden/indra/llimage/llimageworker.h | ||
12 | modified: linden/indra/llrender/llcubemap.cpp | ||
13 | modified: linden/indra/llrender/llimagegl.cpp | ||
14 | modified: linden/indra/llrender/llimagegl.h | ||
15 | modified: linden/indra/llrender/llrender.cpp | ||
16 | modified: linden/indra/llrender/llrender.h | ||
17 | modified: linden/indra/llrender/llrendertarget.cpp | ||
18 | modified: linden/indra/newview/CMakeLists.txt | ||
19 | modified: linden/indra/newview/app_settings/settings.xml | ||
20 | modified: linden/indra/newview/llappviewer.cpp | ||
21 | modified: linden/indra/newview/llappviewer.h | ||
22 | modified: linden/indra/newview/llassetuploadresponders.cpp | ||
23 | modified: linden/indra/newview/llassetuploadresponders.h | ||
24 | modified: linden/indra/newview/lldrawable.cpp | ||
25 | modified: linden/indra/newview/lldrawable.h | ||
26 | modified: linden/indra/newview/lldrawpool.cpp | ||
27 | modified: linden/indra/newview/lldrawpoolalpha.cpp | ||
28 | modified: linden/indra/newview/lldrawpoolbump.cpp | ||
29 | modified: linden/indra/newview/lldrawpoolterrain.cpp | ||
30 | modified: linden/indra/newview/lldrawpooltree.cpp | ||
31 | modified: linden/indra/newview/lldynamictexture.cpp | ||
32 | modified: linden/indra/newview/llface.cpp | ||
33 | modified: linden/indra/newview/llface.h | ||
34 | modified: linden/indra/newview/llfasttimerview.cpp | ||
35 | modified: linden/indra/newview/llfloaterassetbrowser.cpp | ||
36 | modified: linden/indra/newview/llfloaterreporter.cpp | ||
37 | modified: linden/indra/newview/llpreviewtexture.cpp | ||
38 | modified: linden/indra/newview/llstartup.cpp | ||
39 | modified: linden/indra/newview/lltexlayer.cpp | ||
40 | modified: linden/indra/newview/lltexturecache.cpp | ||
41 | modified: linden/indra/newview/lltexturecache.h | ||
42 | modified: linden/indra/newview/lltexturectrl.cpp | ||
43 | modified: linden/indra/newview/lltexturefetch.cpp | ||
44 | modified: linden/indra/newview/lltexturefetch.h | ||
45 | new file: linden/indra/newview/lltextureinfo.cpp | ||
46 | new file: linden/indra/newview/lltextureinfo.h | ||
47 | new file: linden/indra/newview/lltextureinfodetails.cpp | ||
48 | new file: linden/indra/newview/lltextureinfodetails.h | ||
49 | new file: linden/indra/newview/lltexturestats.cpp | ||
50 | new file: linden/indra/newview/lltexturestats.h | ||
51 | new file: linden/indra/newview/lltexturestatsuploader.cpp | ||
52 | new file: linden/indra/newview/lltexturestatsuploader.h | ||
53 | modified: linden/indra/newview/lltextureview.cpp | ||
54 | modified: linden/indra/newview/llviewercamera.cpp | ||
55 | modified: linden/indra/newview/llviewercamera.h | ||
56 | modified: linden/indra/newview/llviewercontrol.cpp | ||
57 | modified: linden/indra/newview/llviewerimage.cpp | ||
58 | modified: linden/indra/newview/llviewerimage.h | ||
59 | modified: linden/indra/newview/llviewerimagelist.cpp | ||
60 | modified: linden/indra/newview/llviewerimagelist.h | ||
61 | modified: linden/indra/newview/llviewermessage.cpp | ||
62 | modified: linden/indra/newview/llviewerobject.cpp | ||
63 | modified: linden/indra/newview/llviewerobject.h | ||
64 | modified: linden/indra/newview/llviewerobjectlist.cpp | ||
65 | modified: linden/indra/newview/llviewerparceloverlay.cpp | ||
66 | modified: linden/indra/newview/llviewerregion.cpp | ||
67 | modified: linden/indra/newview/llviewerwindow.cpp | ||
68 | modified: linden/indra/newview/llvlcomposition.cpp | ||
69 | modified: linden/indra/newview/llvoavatar.cpp | ||
70 | modified: linden/indra/newview/llvoavatar.h | ||
71 | modified: linden/indra/newview/llvoclouds.cpp | ||
72 | modified: linden/indra/newview/llvoclouds.h | ||
73 | modified: linden/indra/newview/llvograss.cpp | ||
74 | modified: linden/indra/newview/llvograss.h | ||
75 | modified: linden/indra/newview/llvoground.cpp | ||
76 | modified: linden/indra/newview/llvoground.h | ||
77 | modified: linden/indra/newview/llvopartgroup.cpp | ||
78 | modified: linden/indra/newview/llvopartgroup.h | ||
79 | modified: linden/indra/newview/llvosky.cpp | ||
80 | modified: linden/indra/newview/llvosky.h | ||
81 | modified: linden/indra/newview/llvosurfacepatch.cpp | ||
82 | modified: linden/indra/newview/llvosurfacepatch.h | ||
83 | modified: linden/indra/newview/llvotextbubble.cpp | ||
84 | modified: linden/indra/newview/llvotextbubble.h | ||
85 | modified: linden/indra/newview/llvotree.cpp | ||
86 | modified: linden/indra/newview/llvotree.h | ||
87 | modified: linden/indra/newview/llvotreenew.h | ||
88 | modified: linden/indra/newview/llvovolume.cpp | ||
89 | modified: linden/indra/newview/llvovolume.h | ||
90 | modified: linden/indra/newview/llvowater.cpp | ||
91 | modified: linden/indra/newview/llvowater.h | ||
92 | modified: linden/indra/newview/llworldmapview.cpp | ||
93 | modified: linden/indra/newview/primbackup.cpp | ||
94 | |||
95 | |||
1 | 2010-02-08 Jacek Antonelli <jacek.antonelli@gmail.com> | 96 | 2010-02-08 Jacek Antonelli <jacek.antonelli@gmail.com> |
2 | 97 | ||
3 | * Ported some cURL and HTTP-related changes from Snowglobe. | 98 | * Ported some cURL and HTTP-related changes from Snowglobe. |