aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorMcCabe Maxsted2009-11-09 08:41:06 -0700
committerMcCabe Maxsted2009-11-09 08:41:06 -0700
commit3f9a06a697fae80f0aba5302f6bbfbd8e8648fda (patch)
treea1ef912e4662b4b798d7f59e5e4e41670dc61ef3
parentRemoved unused CMake resource files (diff)
downloadmeta-impy-3f9a06a697fae80f0aba5302f6bbfbd8e8648fda.zip
meta-impy-3f9a06a697fae80f0aba5302f6bbfbd8e8648fda.tar.gz
meta-impy-3f9a06a697fae80f0aba5302f6bbfbd8e8648fda.tar.bz2
meta-impy-3f9a06a697fae80f0aba5302f6bbfbd8e8648fda.tar.xz
Fixed First Use Mini-Map
Diffstat (limited to '')
-rw-r--r--ChangeLog.txt7
-rw-r--r--linden/indra/newview/llappviewer.cpp1
-rw-r--r--linden/indra/newview/llfirstuse.cpp2
-rw-r--r--linden/indra/newview/skins/default/xui/en-us/notifications.xml7
-rw-r--r--linden/indra/newview/skins/default/xui/en-us/notify.xml5
5 files changed, 15 insertions, 7 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt
index a5dfa03..fb3f065 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -3,7 +3,12 @@
3=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- 3=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
4 4
52009-11-08 McCabe Maxsted <hakushakukun@gmail.com> 52009-11-08 McCabe Maxsted <hakushakukun@gmail.com>
6 6
7 * Removed unused CMake resource files.
8
9 modified: linden/indra/newview/CMakeLists.txt
10
11
7 * Merged in nearly-done 1.2 with 1.3. 12 * Merged in nearly-done 1.2 with 1.3.
8 13
9 Conflicts: 14 Conflicts:
diff --git a/linden/indra/newview/llappviewer.cpp b/linden/indra/newview/llappviewer.cpp
index 52c4b8d..05d4db9 100644
--- a/linden/indra/newview/llappviewer.cpp
+++ b/linden/indra/newview/llappviewer.cpp
@@ -1730,6 +1730,7 @@ bool LLAppViewer::initConfiguration()
1730 LLFirstUse::addConfigVariable("FirstBalanceDecrease"); 1730 LLFirstUse::addConfigVariable("FirstBalanceDecrease");
1731 LLFirstUse::addConfigVariable("FirstSit"); 1731 LLFirstUse::addConfigVariable("FirstSit");
1732 LLFirstUse::addConfigVariable("FirstMap"); 1732 LLFirstUse::addConfigVariable("FirstMap");
1733 LLFirstUse::addConfigVariable("FirstMiniMap");
1733 LLFirstUse::addConfigVariable("FirstGoTo"); 1734 LLFirstUse::addConfigVariable("FirstGoTo");
1734 LLFirstUse::addConfigVariable("FirstBuild"); 1735 LLFirstUse::addConfigVariable("FirstBuild");
1735 LLFirstUse::addConfigVariable("FirstLeftClickNoHit"); 1736 LLFirstUse::addConfigVariable("FirstLeftClickNoHit");
diff --git a/linden/indra/newview/llfirstuse.cpp b/linden/indra/newview/llfirstuse.cpp
index 513cba3..e504547 100644
--- a/linden/indra/newview/llfirstuse.cpp
+++ b/linden/indra/newview/llfirstuse.cpp
@@ -142,7 +142,7 @@ void LLFirstUse::useMiniMap()
142 { 142 {
143 gSavedSettings.setWarning("FirstMiniMap", FALSE); 143 gSavedSettings.setWarning("FirstMiniMap", FALSE);
144 144
145 LLNotifyBox::showXml("FirstMiniMap"); 145 LLNotifications::instance().add("FirstMiniMap");
146 } 146 }
147} 147}
148 148
diff --git a/linden/indra/newview/skins/default/xui/en-us/notifications.xml b/linden/indra/newview/skins/default/xui/en-us/notifications.xml
index a93373e..e005385 100644
--- a/linden/indra/newview/skins/default/xui/en-us/notifications.xml
+++ b/linden/indra/newview/skins/default/xui/en-us/notifications.xml
@@ -6021,6 +6021,13 @@ Use the controls on the right to find things and display different backgrounds.
6021 6021
6022 <notification 6022 <notification
6023 icon="notify.tga" 6023 icon="notify.tga"
6024 name="FirstMiniMap"
6025 type="notify">
6026Right-click the Mini-Map for more options.
6027 </notification>
6028
6029 <notification
6030 icon="notify.tga"
6024 name="FirstBuild" 6031 name="FirstBuild"
6025 type="notify"> 6032 type="notify">
6026You can build new objects in some areas of [SECOND_LIFE]. 6033You can build new objects in some areas of [SECOND_LIFE].
diff --git a/linden/indra/newview/skins/default/xui/en-us/notify.xml b/linden/indra/newview/skins/default/xui/en-us/notify.xml
index f1a1955..a0ea083 100644
--- a/linden/indra/newview/skins/default/xui/en-us/notify.xml
+++ b/linden/indra/newview/skins/default/xui/en-us/notify.xml
@@ -836,11 +836,6 @@ and display different backgrounds.
836 </message> 836 </message>
837 </notify> 837 </notify>
838<!-- TODO: Make sure all the notifications from Imprudence <= 1.2 are out of here before deleting this. --> 838<!-- TODO: Make sure all the notifications from Imprudence <= 1.2 are out of here before deleting this. -->
839 <notify name="FirstMiniMap" tip="false">
840 <message name="message">
841 Right-click the Mini-Map for more options.
842 </message>
843 </notify>
844 <notify name="FirstBuild" tip="false"> 839 <notify name="FirstBuild" tip="false">
845 <message name="message"> 840 <message name="message">
846 You can build new objects in some areas of [SECOND_LIFE]. 841 You can build new objects in some areas of [SECOND_LIFE].