aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorJacek Antonelli2008-10-14 20:04:32 -0500
committerJacek Antonelli2008-10-14 20:29:58 -0500
commitd9efc718418e6b16cd390aaaeea9cc82cdf151c4 (patch)
tree0d3e0020c41e0d5ca91d7a1b99a136d499cf3a29
parentRebranded platform-independent/shared installer/support files. (diff)
downloadmeta-impy-d9efc718418e6b16cd390aaaeea9cc82cdf151c4.zip
meta-impy-d9efc718418e6b16cd390aaaeea9cc82cdf151c4.tar.gz
meta-impy-d9efc718418e6b16cd390aaaeea9cc82cdf151c4.tar.bz2
meta-impy-d9efc718418e6b16cd390aaaeea9cc82cdf151c4.tar.xz
Rebranded Linux-specific installer/support files.
Replaced instances of "Second Life" with "Imprudence", etc.
Diffstat (limited to '')
-rw-r--r--ChangeLog.txt11
-rw-r--r--linden/indra/cmake/UnixInstall.cmake4
-rw-r--r--linden/indra/linux_crash_logger/llcrashloggerlinux.cpp6
-rwxr-xr-xlinden/indra/newview/linux_tools/handle_secondlifeprotocol.sh2
-rwxr-xr-xlinden/indra/newview/linux_tools/wrapper.sh14
5 files changed, 20 insertions, 17 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt
index 8cf8b07..04a6fad 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -1,5 +1,16 @@
12008-10-14 Jacek Antonelli <jacek.antonelli@gmail.com> 12008-10-14 Jacek Antonelli <jacek.antonelli@gmail.com>
2 2
3 * linden/indra/cmake/UnixInstall.cmake:
4 Rebranded Linux-specific installer/support files.
5 Replaced instances of "Second Life" with "Imprudence", etc.
6 * linden/indra/linux_crash_logger/llcrashloggerlinux.cpp:
7 Ditto.
8 * linden/indra/newview/linux_tools/handle_secondlifeprotocol.sh:
9 Ditto.
10 * linden/indra/newview/linux_tools/wrapper.sh:
11 Ditto.
12
13
3 * linden/indra/CMakeLists.txt: 14 * linden/indra/CMakeLists.txt:
4 Rebranded platform-independent/shared installer/support files. 15 Rebranded platform-independent/shared installer/support files.
5 Replaced instances of "Second Life" with "Imprudence", etc. 16 Replaced instances of "Second Life" with "Imprudence", etc.
diff --git a/linden/indra/cmake/UnixInstall.cmake b/linden/indra/cmake/UnixInstall.cmake
index 139be0a..0234dee 100644
--- a/linden/indra/cmake/UnixInstall.cmake
+++ b/linden/indra/cmake/UnixInstall.cmake
@@ -21,11 +21,11 @@ if (INSTALL)
21 set(INSTALL_SHARE_DIR ${INSTALL_PREFIX}/share CACHE PATH 21 set(INSTALL_SHARE_DIR ${INSTALL_PREFIX}/share CACHE PATH
22 "Installation directory for read-only shared files.") 22 "Installation directory for read-only shared files.")
23 23
24 set(APP_BINARY_DIR ${INSTALL_LIBRARY_DIR}/secondlife-${viewer_VERSION} 24 set(APP_BINARY_DIR ${INSTALL_LIBRARY_DIR}/imprudence-${viewer_VERSION}
25 CACHE PATH 25 CACHE PATH
26 "Installation directory for binaries.") 26 "Installation directory for binaries.")
27 27
28 set(APP_SHARE_DIR ${INSTALL_SHARE_DIR}/secondlife-${viewer_VERSION} 28 set(APP_SHARE_DIR ${INSTALL_SHARE_DIR}/imprudence-${viewer_VERSION}
29 CACHE PATH 29 CACHE PATH
30 "Installation directory for read-only data files.") 30 "Installation directory for read-only data files.")
31endif (INSTALL) 31endif (INSTALL)
diff --git a/linden/indra/linux_crash_logger/llcrashloggerlinux.cpp b/linden/indra/linux_crash_logger/llcrashloggerlinux.cpp
index aa2b82c..6ac9831 100644
--- a/linden/indra/linux_crash_logger/llcrashloggerlinux.cpp
+++ b/linden/indra/linux_crash_logger/llcrashloggerlinux.cpp
@@ -53,13 +53,13 @@
53 53
54// These need to be localized. 54// These need to be localized.
55static const char dialog_text[] = 55static const char dialog_text[] =
56"Second Life appears to have crashed or frozen last time it ran.\n" 56"Imprudence appears to have crashed or frozen last time it ran.\n"
57"This crash reporter collects information about your computer's hardware, operating system, and some Second Life logs, all of which are used for debugging purposes only.\n" 57"This crash reporter collects information about your computer's hardware, operating system, and some Imprudence logs, all of which are used for debugging purposes only.\n"
58"\n" 58"\n"
59"Send crash report?"; 59"Send crash report?";
60 60
61static const char dialog_title[] = 61static const char dialog_title[] =
62"Second Life Crash Logger"; 62"Imprudence Crash Logger";
63 63
64#if LL_GTK 64#if LL_GTK
65static void response_callback (GtkDialog *dialog, 65static void response_callback (GtkDialog *dialog,
diff --git a/linden/indra/newview/linux_tools/handle_secondlifeprotocol.sh b/linden/indra/newview/linux_tools/handle_secondlifeprotocol.sh
index 7ff86d1..3613070 100755
--- a/linden/indra/newview/linux_tools/handle_secondlifeprotocol.sh
+++ b/linden/indra/newview/linux_tools/handle_secondlifeprotocol.sh
@@ -13,5 +13,5 @@ fi
13RUN_PATH=`dirname "$0" || echo .` 13RUN_PATH=`dirname "$0" || echo .`
14cd "${RUN_PATH}" 14cd "${RUN_PATH}"
15 15
16exec ./secondlife -url \'"${URL}"\' 16exec ./imprudence -url \'"${URL}"\'
17 17
diff --git a/linden/indra/newview/linux_tools/wrapper.sh b/linden/indra/newview/linux_tools/wrapper.sh
index 9d2e06b..e1c68b9 100755
--- a/linden/indra/newview/linux_tools/wrapper.sh
+++ b/linden/indra/newview/linux_tools/wrapper.sh
@@ -103,7 +103,7 @@ if [ -n "$LL_TCMALLOC" ]; then
103fi 103fi
104 104
105export SL_ENV='LD_LIBRARY_PATH="`pwd`"/lib:"`pwd`"/app_settings/mozilla-runtime-linux-i686:"${LD_LIBRARY_PATH}"' 105export SL_ENV='LD_LIBRARY_PATH="`pwd`"/lib:"`pwd`"/app_settings/mozilla-runtime-linux-i686:"${LD_LIBRARY_PATH}"'
106export SL_CMD='$LL_WRAPPER bin/do-not-directly-run-secondlife-bin' 106export SL_CMD='$LL_WRAPPER bin/do-not-directly-run-imprudence-bin'
107export SL_OPT="`cat gridargs.dat` $@" 107export SL_OPT="`cat gridargs.dat` $@"
108 108
109# Run the program 109# Run the program
@@ -118,9 +118,9 @@ if [ -n "$LL_RUN_ERR" ]; then
118 if [ "`uname -m`" = "x86_64" ]; then 118 if [ "`uname -m`" = "x86_64" ]; then
119 echo 119 echo
120 cat << EOFMARKER 120 cat << EOFMARKER
121You are running the Second Life Viewer on a x86_64 platform. The 121You are running the Imprudence Viewer on a x86_64 platform. The
122most common problems when launching the Viewer (particularly 122most common problems when launching the Viewer (particularly
123'bin/do-not-directly-run-secondlife-bin: not found' and 'error while 123'bin/do-not-directly-run-imprudence-bin: not found' and 'error while
124loading shared libraries') may be solved by installing your Linux 124loading shared libraries') may be solved by installing your Linux
125distribution's 32-bit compatibility packages. 125distribution's 32-bit compatibility packages.
126For example, on Ubuntu and other Debian-based Linuxes you might run: 126For example, on Ubuntu and other Debian-based Linuxes you might run:
@@ -129,11 +129,3 @@ EOFMARKER
129 fi 129 fi
130 fi 130 fi
131fi 131fi
132
133
134echo
135echo '*******************************************************'
136echo 'This is a BETA release of the Second Life linux client.'
137echo 'Thank you for testing!'
138echo 'Please see README-linux.txt before reporting problems.'
139echo