aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/src/others/mimesh/libg3d-0.0.8/plugins/import/imp_osm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/others/mimesh/libg3d-0.0.8/plugins/import/imp_osm/Makefile.am')
-rw-r--r--src/others/mimesh/libg3d-0.0.8/plugins/import/imp_osm/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/others/mimesh/libg3d-0.0.8/plugins/import/imp_osm/Makefile.am b/src/others/mimesh/libg3d-0.0.8/plugins/import/imp_osm/Makefile.am
new file mode 100644
index 0000000..1e6b4ae
--- /dev/null
+++ b/src/others/mimesh/libg3d-0.0.8/plugins/import/imp_osm/Makefile.am
@@ -0,0 +1,24 @@
1pluginimpdir = $(pkglibdir)/plugins/import
2
3if EXPERIMENTAL
4if HAVE_LIBXML2
5pluginimp_LTLIBRARIES = imp_osm.la
6endif
7endif
8
9AM_CFLAGS = \
10 -Wall -ansi -pedantic \
11 -DG_LOG_DOMAIN=\"LibG3D\" \
12 @DBG_CFLAGS@ -DDEBUG=@DEBUG@ \
13 @GLIB_CFLAGS@ @LIBXML2_CFLAGS@
14
15INCLUDES = -I$(top_srcdir)/include
16
17AM_LDFLAGS = \
18 -no-undefined -module \
19 @PLUGINS_LDFLAGS@
20
21LIBTOOL += --quiet
22
23imp_osm_la_SOURCES = imp_osm.c
24imp_osm_la_LIBADD = $(top_builddir)/src/libg3d.la @GLIB_LIBS@ @LIBXML2_LIBS@