aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/src/others/mimesh/libg3d-0.0.8/plugins/import/imp_ldraw/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/others/mimesh/libg3d-0.0.8/plugins/import/imp_ldraw/Makefile.am')
-rw-r--r--src/others/mimesh/libg3d-0.0.8/plugins/import/imp_ldraw/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/others/mimesh/libg3d-0.0.8/plugins/import/imp_ldraw/Makefile.am b/src/others/mimesh/libg3d-0.0.8/plugins/import/imp_ldraw/Makefile.am
new file mode 100644
index 0000000..f27cd09
--- /dev/null
+++ b/src/others/mimesh/libg3d-0.0.8/plugins/import/imp_ldraw/Makefile.am
@@ -0,0 +1,24 @@
1pluginimpdir = $(pkglibdir)/plugins/import
2
3pluginimp_LTLIBRARIES = imp_ldraw.la
4
5AM_CFLAGS = \
6 -Wall -ansi -pedantic \
7 -DG_LOG_DOMAIN=\"LibG3D\" \
8 @DBG_CFLAGS@ -DDEBUG=@DEBUG@ \
9 @GLIB_CFLAGS@
10
11INCLUDES = -I$(top_srcdir)/include
12
13AM_LDFLAGS = \
14 -no-undefined -module \
15 @PLUGINS_LDFLAGS@
16
17LIBTOOL += --quiet
18
19imp_ldraw_la_SOURCES = imp_ldraw.c imp_ldraw_misc.h imp_ldraw_types.h \
20 imp_ldraw_part.c imp_ldraw_part.h \
21 imp_ldraw_library.c imp_ldraw_library.h \
22 imp_ldraw_color.c imp_ldraw_color.h \
23 imp_ldraw_mpd.c imp_ldraw_mpd.h
24imp_ldraw_la_LIBADD = $(top_builddir)/src/libg3d.la @GLIB_LIBS@